Skip to content
Snippets Groups Projects
Commit a7614714 authored by Anna Wilcox's avatar Anna Wilcox :fox:
Browse files

dev-libs/libfetch: fix retarded build issue.

parent 83bdea22
No related branches found
No related tags found
No related merge requests found
--- a/Makefile 2015-09-16 22:15:02.000000000 -0500
+++ b/Makefile 2016-01-24 01:54:11.547524137 -0600
@@ -31,10 +31,10 @@
CFLAGS += -UDEBUG
endif
-CC = gcc
-LD = gcc
-AR = ar
-RANLIB = ranlib
+CC ?= gcc
+LD ?= gcc
+AR ?= ar
+RANLIB ?= ranlib
INSTALL = install -c -D
OBJS= fetch.o common.o ftp.o http.o file.o
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
# Copyright 2015-2016 Adélie Linux Team
# Distributed under the terms of the NCSA License
EAPI=5
inherit eutils
DESCRIPTION="High-level retrieval and download library for FTP and HTTP(S)"
HOMEPAGE="http://cvsweb.netbsd.org/bsdweb.cgi/pkgsrc/net/libfetch/"
SRC_URI="http://distfiles.foxkit.us/source/${PN}/${P}.tar.bz2"
......@@ -16,6 +17,13 @@ IUSE="+ipv6 +ssl"
DEPEND="ssl? ( dev-libs/openssl:0 )"
RDEPEND="${DEPEND}"
EPATCH_SOURCE=( "${FILESDIR}"/${P}-remove-hardcoded-compiler.patch )
src_prepare() {
epatch
epatch_user
}
src_compile() {
use ssl || export FETCH_WITH_OPENSSL=false
use ipv6 || export FETCH_WITH_INET6=false
......
0% Loading or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment