From a7614714fbd6e7fc9b87636d0ec02dc84815e12c Mon Sep 17 00:00:00 2001
From: Andrew Wilcox <AWilcox@Wilcox-Tech.com>
Date: Sun, 24 Jan 2016 01:57:41 -0600
Subject: [PATCH] dev-libs/libfetch: fix retarded build issue.

---
 ...bfetch-2.33-remove-hardcoded-compiler.patch | 18 ++++++++++++++++++
 dev-libs/libfetch/libfetch-2.33.ebuild         | 14 +++++++++++---
 2 files changed, 29 insertions(+), 3 deletions(-)
 create mode 100644 dev-libs/libfetch/files/libfetch-2.33-remove-hardcoded-compiler.patch

diff --git a/dev-libs/libfetch/files/libfetch-2.33-remove-hardcoded-compiler.patch b/dev-libs/libfetch/files/libfetch-2.33-remove-hardcoded-compiler.patch
new file mode 100644
index 0000000000..91f5c467cd
--- /dev/null
+++ b/dev-libs/libfetch/files/libfetch-2.33-remove-hardcoded-compiler.patch
@@ -0,0 +1,18 @@
+--- a/Makefile    2015-09-16 22:15:02.000000000 -0500
++++ b/Makefile        2016-01-24 01:54:11.547524137 -0600
+@@ -31,10 +31,10 @@
+ CFLAGS += -UDEBUG
+ endif
+ 
+-CC = gcc
+-LD = gcc
+-AR = ar
+-RANLIB = ranlib
++CC ?= gcc
++LD ?= gcc
++AR ?= ar
++RANLIB ?= ranlib
+ INSTALL = install -c -D
+ 
+ OBJS= fetch.o common.o ftp.o http.o file.o
+
diff --git a/dev-libs/libfetch/libfetch-2.33.ebuild b/dev-libs/libfetch/libfetch-2.33.ebuild
index 4ca3a76b12..25f02eb46f 100644
--- a/dev-libs/libfetch/libfetch-2.33.ebuild
+++ b/dev-libs/libfetch/libfetch-2.33.ebuild
@@ -1,9 +1,10 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
+# Copyright 2015-2016 Adélie Linux Team
+# Distributed under the terms of the NCSA License
 
 EAPI=5
 
+inherit eutils
+
 DESCRIPTION="High-level retrieval and download library for FTP and HTTP(S)"
 HOMEPAGE="http://cvsweb.netbsd.org/bsdweb.cgi/pkgsrc/net/libfetch/"
 SRC_URI="http://distfiles.foxkit.us/source/${PN}/${P}.tar.bz2"
@@ -16,6 +17,13 @@ IUSE="+ipv6 +ssl"
 DEPEND="ssl? ( dev-libs/openssl:0 )"
 RDEPEND="${DEPEND}"
 
+EPATCH_SOURCE=( "${FILESDIR}"/${P}-remove-hardcoded-compiler.patch )
+
+src_prepare() {
+	epatch
+	epatch_user
+}
+
 src_compile() {
 	use ssl || export FETCH_WITH_OPENSSL=false
 	use ipv6 || export FETCH_WITH_INET6=false
-- 
GitLab