Skip to content
GitLab
Explore
Sign in
Register
Primary navigation
Search or go to…
Project
Adélie Package Tree
Manage
Activity
Members
Labels
Plan
Issues
Issue boards
Milestones
Code
Merge requests
Repository
Branches
Commits
Tags
Repository graph
Compare revisions
Snippets
Deploy
Releases
Model registry
Monitor
Incidents
Analyze
Value stream analytics
Contributor analytics
Repository analytics
Model experiments
Help
Help
Support
GitLab documentation
Compare GitLab plans
Community forum
Contribute to GitLab
Provide feedback
Keyboard shortcuts
?
Snippets
Groups
Projects
Show more breadcrumbs
Nathan Owens
Adélie Package Tree
Commits
59de3b2e
Verified
Commit
59de3b2e
authored
6 years ago
by
Anna Wilcox
Browse files
Options
Downloads
Patches
Plain Diff
user/opencv: bump to 3.4.3
parent
df42d349
No related branches found
Branches containing commit
No related tags found
Tags containing commit
No related merge requests found
Changes
2
Hide whitespace changes
Inline
Side-by-side
Showing
2 changed files
user/opencv/APKBUILD
+4
-7
4 additions, 7 deletions
user/opencv/APKBUILD
user/opencv/pmmx.patch
+0
-27
0 additions, 27 deletions
user/opencv/pmmx.patch
with
4 additions
and
34 deletions
user/opencv/APKBUILD
+
4
−
7
View file @
59de3b2e
# Contributor: Carlo Landmeter <clandmeter@gmail.com>
# Maintainer:
pkgname
=
opencv
pkgver
=
3.4.
1
pkgrel
=
2
pkgver
=
3.4.
3
pkgrel
=
0
pkgdesc
=
"Computer vision and machine learning software library"
url
=
"https://opencv.org"
arch
=
"all"
...
...
@@ -13,9 +13,7 @@ makedepends="cmake doxygen ffmpeg-dev gst-plugins-base-dev gtk+2.0-dev
gtk+3.0-dev jasper-dev libdc1394-dev libgomp libgphoto2-dev
libjpeg-turbo-dev libpng-dev libwebp-dev tiff-dev v4l-utils-dev"
subpackages
=
"
$pkgname
-dev
$pkgname
-libs"
source
=
"opencv-
$pkgver
.tar.gz::https://github.com/opencv/opencv/archive/
$pkgver
.tar.gz
pmmx.patch
"
source
=
"opencv-
$pkgver
.tar.gz::https://github.com/opencv/opencv/archive/
$pkgver
.tar.gz"
prepare
()
{
cd
"
$builddir
"
...
...
@@ -64,5 +62,4 @@ package() {
make
DESTDIR
=
"
$pkgdir
"
install
}
sha512sums
=
"e1fc14285090c6fe9e26e721f2d67d7096650c523147e925567426ef76aa7f4c6f12035d6f6ce3ec7991a75a6828a810fd4f9b75f78ed5fcccecefbadd79944b opencv-3.4.1.tar.gz
8ebf573e3f02b78b5769eaf828215698073096a1dade9214af0382cfbbe2353307df836a6af8c4e86246ad33fefe1f64a1087d0ff7a6dc7c5f3e231592c20b4c pmmx.patch"
sha512sums
=
"d653a58eb5e3939b9fdb7438ac35f77cf4385cf72d5d22bfd21722a109e1b3283dbb9407985061b7548114f0d05c9395aac9bb62b4d2bc1f68da770a49987fef opencv-3.4.3.tar.gz"
This diff is collapsed.
Click to expand it.
user/opencv/pmmx.patch
deleted
100644 → 0
+
0
−
27
View file @
df42d349
From 7dc162cb4252ccf461f1c63650abde3c8807b79c Mon Sep 17 00:00:00 2001
From: Alexander Alekhin <alexander.alekhin@intel.com>
Date: Mon, 9 Apr 2018 18:25:51 +0300
Subject: [PATCH] core: fix mm_pause() for non-SSE i386 builds
replaced to safe binary compatible 'rep; nop' asm instruction
---
modules/core/src/parallel_impl.cpp | 6 +++++-
1 file changed, 5 insertions(+), 1 deletion(-)
diff --git a/modules/core/src/parallel_impl.cpp b/modules/core/src/parallel_impl.cpp
index 78d9eb63694..bc64fce7a81 100644
--- a/modules/core/src/parallel_impl.cpp
+++ b/modules/core/src/parallel_impl.cpp
@@ -49,7 +49,11 @@
DECLARE_CV_YIELD
DECLARE_CV_PAUSE
#endif
#ifndef CV_PAUSE
-#if defined __GNUC__ && (defined __i386__ || defined __x86_64__)
+# if defined __GNUC__ && (defined __i386__ || defined __x86_64__)
+# if !defined(__SSE__)
+ static inline void cv_non_sse_mm_pause() { __asm__ __volatile__ ("rep; nop"); }
+# define _mm_pause cv_non_sse_mm_pause
+# endif
# define CV_PAUSE(v) do { for (int __delay = (v); __delay > 0; --__delay) { _mm_pause(); } } while (0)
# elif defined __GNUC__ && defined __aarch64__
# define CV_PAUSE(v) do { for (int __delay = (v); __delay > 0; --__delay) { asm volatile("yield" ::: "memory"); } } while (0)
This diff is collapsed.
Click to expand it.
Preview
0%
Loading
Try again
or
attach a new file
.
Cancel
You are about to add
0
people
to the discussion. Proceed with caution.
Finish editing this message first!
Save comment
Cancel
Please
register
or
sign in
to comment