Skip to content
GitLab
Explore
Sign in
Register
Primary navigation
Search or go to…
Project
Adélie Package Tree
Manage
Activity
Members
Labels
Plan
Issues
Issue boards
Milestones
Code
Merge requests
Repository
Branches
Commits
Tags
Repository graph
Compare revisions
Snippets
Deploy
Releases
Model registry
Monitor
Incidents
Analyze
Value stream analytics
Contributor analytics
Repository analytics
Model experiments
Help
Help
Support
GitLab documentation
Compare GitLab plans
Community forum
Contribute to GitLab
Provide feedback
Keyboard shortcuts
?
Snippets
Groups
Projects
Show more breadcrumbs
Nathan Owens
Adélie Package Tree
Commits
2b0e7972
Verified
Commit
2b0e7972
authored
4 years ago
by
Anna Wilcox
Browse files
Options
Downloads
Patches
Plain Diff
user/livecd-support: Actually run the script
parent
71a2201c
No related branches found
No related tags found
No related merge requests found
Changes
2
Hide whitespace changes
Inline
Side-by-side
Showing
2 changed files
user/livecd-support/APKBUILD
+7
-3
7 additions, 3 deletions
user/livecd-support/APKBUILD
user/livecd-support/horizon-ui
+8
-0
8 additions, 0 deletions
user/livecd-support/horizon-ui
with
15 additions
and
3 deletions
user/livecd-support/APKBUILD
+
7
−
3
View file @
2b0e7972
...
...
@@ -6,7 +6,7 @@ pkgrel=0
pkgdesc
=
"Support files for booting Adélie live media"
url
=
"https://www.adelielinux.org/"
arch
=
"noarch"
options
=
"!check"
# Metapackage
options
=
"!check
suid
"
# Metapackage
license
=
"NCSA"
subpackages
=
"
$pkgname
-kde
$pkgname
-lxqt
$pkgname
-mate
$pkgname
-horizon"
depends
=
""
...
...
@@ -14,6 +14,7 @@ install="livecd-support.post-install livecd-support.post-deinstall"
source
=
"kde.sddm.conf
lxqt.sddm.conf
mate.sddm.conf
horizon-ui
"
package
()
{
...
...
@@ -24,6 +25,8 @@ horizon() {
pkgdesc
=
"Add the ability to install Adélie from live media"
depends
=
"horizon-qt5 horizon netsurf partitionmanager xterm"
install
-D
-m4755
"
$srcdir
"
/horizon-ui
"
$subpkgdir
"
/usr/sbin/horizon-ui
mkdir
-p
"
$subpkgdir
"
/usr/share/applications
cat
>
"
$subpkgdir
"
/usr/share/applications/horizon.desktop
<<
DESKTOP
[Desktop Entry]
...
...
@@ -32,7 +35,7 @@ Version=1.1
Name=System Installation
Comment=Install Adélie Linux to your computer
Icon=system-software-install
Exec=/usr/bin/horizon-
qt5
Exec=/usr/
s
bin/horizon-
ui
Categories=System;
DESKTOP
}
...
...
@@ -58,4 +61,5 @@ mate() {
sha512sums
=
"eddcc68917b4dc376bb9b7e7ed5e2c06379957c787c7152e654f31adb402f5811463bff69ce2a41a2cb87b0fa83a4aa3718b63d830eb9ee46b7d0d2058663d34 kde.sddm.conf
9a9a61035c0a8c5ee84d235f319ca158216056221d03a0f5a3846982cb6110c569d7b4eadd2e24de66a75a428c18850e0393e20412e0edcfc8ad41c9d4783604 lxqt.sddm.conf
603d2a5b1fdad0cb0abfefa8a4019c690ee4f5f9ac45057eeeac3bac3207e7871bdb32a564791fb99d965959b39a7de979d575db2694c2d1d88a4a16b68adb25 mate.sddm.conf"
603d2a5b1fdad0cb0abfefa8a4019c690ee4f5f9ac45057eeeac3bac3207e7871bdb32a564791fb99d965959b39a7de979d575db2694c2d1d88a4a16b68adb25 mate.sddm.conf
b6d39b2feb0aa400ac7013d6b8c9080ab00ffc1c8b40dbf9489df999fe08b86aebd878c84d968a53ad29bc2a2c30209d8c6ff5daa4171aab03d5b921f966e08d horizon-ui"
This diff is collapsed.
Click to expand it.
user/livecd-support/horizon-ui
0 → 100644
+
8
−
0
View file @
2b0e7972
#!/bin/sh
#
# Welcome to Adélie Linux.
# This script allows you to run Horizon as the live user.
#
horizon-qt5
if
[
$?
-eq
0
]
;
then
horizon-run-qt5
;
fi
This diff is collapsed.
Click to expand it.
Preview
0%
Loading
Try again
or
attach a new file
.
Cancel
You are about to add
0
people
to the discussion. Proceed with caution.
Finish editing this message first!
Save comment
Cancel
Please
register
or
sign in
to comment