Skip to content
GitLab
Explore
Sign in
Register
Primary navigation
Search or go to…
Project
Adélie Package Tree
Manage
Activity
Members
Labels
Plan
Issues
Issue boards
Milestones
Code
Merge requests
Repository
Branches
Commits
Tags
Repository graph
Compare revisions
Snippets
Deploy
Releases
Model registry
Monitor
Incidents
Analyze
Value stream analytics
Contributor analytics
Repository analytics
Model experiments
Help
Help
Support
GitLab documentation
Compare GitLab plans
Community forum
Contribute to GitLab
Provide feedback
Keyboard shortcuts
?
Snippets
Groups
Projects
Show more breadcrumbs
Hill Ma
Adélie Package Tree
Commits
cf5e3c7c
Verified
Commit
cf5e3c7c
authored
7 years ago
by
Anna Wilcox
Browse files
Options
Downloads
Patches
Plain Diff
user/plasma-workspace: fix crash on wallpaper change
parent
54252e3f
No related branches found
No related tags found
No related merge requests found
Changes
2
Hide whitespace changes
Inline
Side-by-side
Showing
2 changed files
user/plasma-workspace/APKBUILD
+6
-3
6 additions, 3 deletions
user/plasma-workspace/APKBUILD
user/plasma-workspace/fix-crash-on-wallpaper-change.patch
+58
-0
58 additions, 0 deletions
user/plasma-workspace/fix-crash-on-wallpaper-change.patch
with
64 additions
and
3 deletions
user/plasma-workspace/APKBUILD
+
6
−
3
View file @
cf5e3c7c
...
...
@@ -2,7 +2,7 @@
# Maintainer: A. Wilcox <awilfox@adelielinux.org>
pkgname
=
plasma-workspace
pkgver
=
5.8.7
pkgrel
=
7
pkgrel
=
8
pkgdesc
=
"KDE Plasma 5 workspace"
url
=
"https://www.kde.org/plasma-desktop"
arch
=
"all"
...
...
@@ -30,7 +30,9 @@ subpackages="$pkgname-dev $pkgname-doc $pkgname-lang"
source
=
"https://download.kde.org/Attic/plasma/
$pkgver
/plasma-workspace-
$pkgver
.tar.xz
plasma-workspace-5.8-cmake-update.patch
plasma-workspace-5.8.7-disable-broken-test.patch
plasma-workspace-5.8-honour-uint.patch"
plasma-workspace-5.8-honour-uint.patch
fix-crash-on-wallpaper-change.patch
"
builddir
=
"
$srcdir
/plasma-workspace-
$pkgver
"
build
()
{
...
...
@@ -62,4 +64,5 @@ package() {
sha512sums
=
"ba35a050384e0bf410097027bfb70ca7594cd5352fd6470228d537f4e876ec72ec26bac3be9a6750f306b1d2937ff53c267c2246f191c93a13972a0cf33b4faf plasma-workspace-5.8.7.tar.xz
3d7cfb1c7c54bcbca47c5c01497c776d54d1e2327bc0a3777cfaf001f44ec7c1863f15ab0586c00db6d7194f759b91d0a86e47ae99e7fa23782dd7deda264e47 plasma-workspace-5.8-cmake-update.patch
2151dab30716e0b2b6a9146fd6262f4f134884961bebe9cf9baee269f35b1b3955ed07dcee2602b5adc2fc93aa15d37cb72d6983f026a2b504feb451d944d965 plasma-workspace-5.8.7-disable-broken-test.patch
48b4c448a4e964e61f25fa751fbc67f6cfce0e792139a124a70fa5c07f8b1b1a1c51fd5652679a3c46ac997c2dda3df476e8c8ebfdc6a08ece4f2e79282d81a3 plasma-workspace-5.8-honour-uint.patch"
48b4c448a4e964e61f25fa751fbc67f6cfce0e792139a124a70fa5c07f8b1b1a1c51fd5652679a3c46ac997c2dda3df476e8c8ebfdc6a08ece4f2e79282d81a3 plasma-workspace-5.8-honour-uint.patch
52ac2f37a7e1fde97385a372a4c198b573fb51fe1334bddf340c034ba0fbd2a97174d9bab9f9c8446048deb3a2c9ea3c571b0adcdb1f710b513b311c824ab88a fix-crash-on-wallpaper-change.patch"
This diff is collapsed.
Click to expand it.
user/plasma-workspace/fix-crash-on-wallpaper-change.patch
0 → 100644
+
58
−
0
View file @
cf5e3c7c
From a44d84ef47492ca60ee608996b5ab1f2849ef16e Mon Sep 17 00:00:00 2001
From: David Edmundson <kde@davidedmundson.co.uk>
Date: Mon, 14 Aug 2017 10:04:19 +0100
Subject: Don't change fillMode of image just before deleting it
It is still set for when a source is applied for the next
transistion.
Summary:
This saves evaluating a new paintedSize and doing a bunch of evaluations
which are not used.
More importantly it works round a Qt animation crash.
fadeAnim.running is bound to otherImage.status !== loading
with the intention of delaying animations until the images are really
loaded.
By setting the fill mode and then the source, we go to loading and back,
effectively restarting the animation from within the animation.
This leads to a crash.
CCBUG: 381105
Test Plan:
End user result is the same.
Reviewers: #plasma, broulik, mart
Reviewed By: #plasma, broulik, mart
Subscribers: plasma-devel
Tags: #plasma
Differential Revision: https://phabricator.kde.org/D7248
---
wallpapers/image/imagepackage/contents/ui/main.qml | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/wallpapers/image/imagepackage/contents/ui/main.qml b/wallpapers/image/imagepackage/contents/ui/main.qml
index fc22176..0539f37 100644
--- a/wallpapers/image/imagepackage/contents/ui/main.qml
+++ b/wallpapers/image/imagepackage/contents/ui/main.qml
@@ -193,8 +193,8 @@
Item {
}
ScriptAction {
script: {
- otherImage.fillMode = fillMode;
otherImage.source = "";
+ otherImage.fillMode = fillMode;
}
}
}
--
cgit v0.11.2
This diff is collapsed.
Click to expand it.
Preview
0%
Loading
Try again
or
attach a new file
.
Cancel
You are about to add
0
people
to the discussion. Proceed with caution.
Finish editing this message first!
Save comment
Cancel
Please
register
or
sign in
to comment