Skip to content
GitLab
Explore
Sign in
Register
Primary navigation
Search or go to…
Project
Adélie Package Tree
Manage
Activity
Members
Labels
Plan
Issues
Issue boards
Milestones
Code
Merge requests
Repository
Branches
Commits
Tags
Repository graph
Compare revisions
Snippets
Deploy
Releases
Model registry
Monitor
Incidents
Analyze
Value stream analytics
Contributor analytics
Repository analytics
Model experiments
Help
Help
Support
GitLab documentation
Compare GitLab plans
Community forum
Contribute to GitLab
Provide feedback
Keyboard shortcuts
?
Snippets
Groups
Projects
Show more breadcrumbs
Hill Ma
Adélie Package Tree
Commits
9a66dd93
Commit
9a66dd93
authored
7 years ago
by
Max Rees
Browse files
Options
Downloads
Patches
Plain Diff
user/feh: new package
parent
54252e3f
No related branches found
No related tags found
No related merge requests found
Changes
2
Hide whitespace changes
Inline
Side-by-side
Showing
2 changed files
user/feh/APKBUILD
+40
-0
40 additions, 0 deletions
user/feh/APKBUILD
user/feh/stdout-buff.patch
+113
-0
113 additions, 0 deletions
user/feh/stdout-buff.patch
with
153 additions
and
0 deletions
user/feh/APKBUILD
0 → 100644
+
40
−
0
View file @
9a66dd93
# Contributor: Max Rees <maxcrees@me.com>
# Maintainer: Max Rees <maxcrees@me.com>
pkgname
=
feh
pkgver
=
2.22
pkgrel
=
0
pkgdesc
=
"feh is a fast, lightweight image viewer which uses imlib2"
url
=
"http://feh.finalrewind.org/"
arch
=
"all"
license
=
"MIT-feh"
subpackages
=
"
$pkgname
-doc"
depends
=
makedepends
=
"libxt-dev libpng-dev giblib-dev imlib2-dev libjpeg-turbo-dev
libxinerama-dev curl-dev libexif-dev"
checkdepends
=
"perl-utils perl-test-command"
source
=
"https://feh.finalrewind.org/
$pkgname
-
$pkgver
.tar.bz2
stdout-buff.patch"
builddir
=
"
$srcdir
/
$pkgname
-
$pkgver
"
build
()
{
cd
"
$builddir
"
make
PREFIX
=
/usr
curl
=
1
exif
=
1
xinerama
=
1
}
check
()
{
cd
"
$builddir
"
make
PREFIX
=
/usr
test
}
package
()
{
cd
"
$builddir
"
make
PREFIX
=
/usr
DESTDIR
=
"
$pkgdir
"
\
bin_dir
=
"
$pkgdir
"
/usr/bin
\
man_dir
=
"
$pkgdir
"
/usr/share/man
\
doc_dir
=
"
$pkgdir
"
/usr/share/doc/
$pkgname
\
example_dir
=
"
$pkgdir
"
/usr/share/doc/
$pkgname
/examples
\
install
}
sha512sums
=
"403b1e760e2b3e177768b47de5bb7bd45c11152f04a21f6788afcaec12357a085f7c9944000f78a8df41a3d60a67985622d36effd543216153ab04e539b5b85f feh-2.22.tar.bz2
38ead15a58c402181da3e39c09002d9f951b03cfdf5edde19072da313638025dca5fa7dbe466b8f05094d49d44750c467d7fa3832fbaa11ac135c5839e0ecdc1 stdout-buff.patch"
This diff is collapsed.
Click to expand it.
user/feh/stdout-buff.patch
0 → 100644
+
113
−
0
View file @
9a66dd93
On glibc, if output is redirected to a file, output will look like this:
touch test/ok/gif
touch test/ok/jpg
touch test/ok/png
touch test/ok/pnm
test/ok/gif
test/ok/jpg
test/ok/png
test/ok/pnm
On musl, if stdout is redirected to a file, output looks like this:
test/ok/gif
touch test/ok/gif
touch test/ok/jpg
touch test/ok/png
touch test/ok/pnm
test/ok/jpg
test/ok/png
test/ok/pnm
On glibc and musl, if stdout is interactive, it looks like this:
test/ok/gif
touch test/ok/gif
test/ok/jpg
touch test/ok/jpg
test/ok/png
touch test/ok/png
test/ok/pnm
touch test/ok/pnm
Adding two fflush calls makes all behavior look like the last example.
--- feh-2.22/src/list.c 2017-11-04 14:03:43.000000000 +0000
+++ feh-2.22/src/list.c 2018-01-03 02:59:08.840000000 +0000
@@ -92,6 +92,7 @@
if (opt.verbose)
feh_display_status('.');
puts(file->filename);
+ fflush(stdout);
feh_action_run(file, opt.actions[0], NULL);
}
else {
@@ -106,6 +107,7 @@
if (opt.verbose)
feh_display_status('.');
puts(file->filename);
+ fflush(stdout);
feh_action_run(file, opt.actions[0], NULL);
}
else {
--- feh-2.22/test/nx_action/loadable_action 2017-11-04 14:03:43.000000000 +0000
+++ feh-2.22/test/nx_action/loadable_action 2018-01-03 02:46:48.030000000 +0000
@@ -1,8 +1,8 @@
-touch test/ok/gif
-touch test/ok/jpg
-touch test/ok/png
-touch test/ok/pnm
test/ok/gif
+touch test/ok/gif
test/ok/jpg
+touch test/ok/jpg
test/ok/png
+touch test/ok/png
test/ok/pnm
+touch test/ok/pnm
--- feh-2.22/test/nx_action/loadable_naction 2017-11-04 14:03:43.000000000 +0000
+++ feh-2.22/test/nx_action/loadable_naction 2018-01-03 02:51:05.340000000 +0000
@@ -1,8 +1,8 @@
-touch test/ok/gif
-touch test/ok/jpg
-touch test/ok/png
-touch test/ok/pnm
test/ok/gif
+touch test/ok/gif
test/ok/jpg
+touch test/ok/jpg
test/ok/png
+touch test/ok/png
test/ok/pnm
+touch test/ok/pnm
--- feh-2.22/test/nx_action/unloadable_action 2017-11-04 14:03:43.000000000 +0000
+++ feh-2.22/test/nx_action/unloadable_action 2018-01-03 02:51:36.480000000 +0000
@@ -1,8 +1,8 @@
-rm test/fail/gif
-rm test/fail/jpg
-rm test/fail/png
-rm test/fail/pnm
test/fail/gif
+rm test/fail/gif
test/fail/jpg
+rm test/fail/jpg
test/fail/png
+rm test/fail/png
test/fail/pnm
+rm test/fail/pnm
--- feh-2.22/test/nx_action/unloadable_naction 2017-11-04 14:03:43.000000000 +0000
+++ feh-2.22/test/nx_action/unloadable_naction 2018-01-03 02:51:51.850000000 +0000
@@ -1,8 +1,8 @@
-rm test/fail/gif
-rm test/fail/jpg
-rm test/fail/png
-rm test/fail/pnm
test/fail/gif
+rm test/fail/gif
test/fail/jpg
+rm test/fail/jpg
test/fail/png
+rm test/fail/png
test/fail/pnm
+rm test/fail/pnm
This diff is collapsed.
Click to expand it.
Preview
0%
Loading
Try again
or
attach a new file
.
Cancel
You are about to add
0
people
to the discussion. Proceed with caution.
Finish editing this message first!
Save comment
Cancel
Please
register
or
sign in
to comment