-
Síle Ekaterin Liszka authoredSíle Ekaterin Liszka authored
APKBUILD 927 B
# Contributor: Síle Ekaterin Liszka <sheila@vulpine.house>
# Maintainer: Síle Ekaterin Liszka <sheila@vulpine.house>
pkgname=gcab
pkgver=1.6
pkgrel=0
pkgdesc="Gnome library for working with cabinet archives"
url="https://gitlab.gnome.org/GNOME/gcab"
arch="all"
license="LGPL-2.1+ AND LGPL-2.0+"
depends=""
makedepends="glib-dev gobject-introspection-dev gtk-doc meson vala"
subpackages="$pkgname-dev $pkgname-doc"
source="https://download.gnome.org/sources/gcab/$pkgver/gcab-$pkgver.tar.xz"
build() {
meson setup \
--prefix=/usr \
--sysconfdir=/etc \
--mandir=/usr/share/man \
--localstatedir=/var \
--buildtype=release \
. output
meson compile -C output
}
check() {
meson test -C output
}
package() {
DESTDIR="$pkgdir" meson install -C output
}
sha512sums="26b8dcf47ba98e7cc073a551d1c965c13a72d298c8a4e124823bdbb20fe314c8f687232df9ae824a54d81f96fe7d9ac1a40aed24e51f8706595079cec2c61fc9 gcab-1.6.tar.xz"