Skip to content
GitLab
Explore
Sign in
Register
Primary navigation
Search or go to…
Project
Adélie Package Tree
Manage
Activity
Members
Labels
Plan
Issues
Issue boards
Milestones
Wiki
Code
Merge requests
Repository
Branches
Commits
Tags
Repository graph
Compare revisions
Build
Pipelines
Jobs
Pipeline schedules
Artifacts
Deploy
Package Registry
Model registry
Operate
Terraform modules
Analyze
Model experiments
Help
Help
Support
GitLab documentation
Compare GitLab plans
Community forum
Contribute to GitLab
Provide feedback
Keyboard shortcuts
?
Snippets
Groups
Projects
Show more breadcrumbs
andri saputra
Adélie Package Tree
Commits
d44caf81
Commit
d44caf81
authored
7 years ago
by
Anna Wilcox
Browse files
Options
Downloads
Patches
Plain Diff
user/pax: finish writing build
parent
763b7f5d
No related branches found
No related tags found
No related merge requests found
Changes
3
Hide whitespace changes
Inline
Side-by-side
Showing
3 changed files
user/pax/APKBUILD
+18
-7
18 additions, 7 deletions
user/pax/APKBUILD
user/pax/needed-header.patch
+11
-0
11 additions, 0 deletions
user/pax/needed-header.patch
user/pax/pax-20160306-glibc-to-linux.patch
+38
-0
38 additions, 0 deletions
user/pax/pax-20160306-glibc-to-linux.patch
with
67 additions
and
7 deletions
user/pax/APKBUILD
+
18
−
7
View file @
d44caf81
...
...
@@ -7,24 +7,35 @@ pkgdesc="Portable Archive eXchange, the POSIX archival tool"
url
=
"https://www.mirbsd.org/pax.htm"
arch
=
"all"
license
=
"BSD"
depends
=
""
depends_dev
=
"libbsd-dev fts-dev"
makedepends
=
"
$depends_dev
"
install
=
""
subpackages
=
"
$pkgname
-dev
$pkgname
-doc"
source
=
"https://ftp.debian.org/debian/pool/main/p/
$pkgname
/
${
pkgname
}
_
$pkgver
.orig.tar.xz"
subpackages
=
"
$pkgname
-doc"
source
=
"http://ftp.debian.org/debian/pool/main/p/
$pkgname
/
${
pkgname
}
_
$pkgver
.orig.tar.xz
needed-header.patch
pax-20160306-glibc-to-linux.patch"
builddir
=
"
$srcdir
/
$pkgname
"
build
()
{
cd
"
$builddir
"
${
CC
}
${
CPPFLAGS
}
${
CFLAGS
}
\
-DHAVE_STRLCPY
-DHAVE_VIS
-DHAVE_STRMODE
-DLONG_OFF_T
-DHAVE_LINKAT
\
-DHAVE_STRLCPY
-DHAVE_STRMODE
-DLONG_OFF_T
-DHAVE_LINKAT
-DHAVE_SYS_SYSMACROS_H
-D_BSD_SOURCE
\
-DPAX_SAFE_PATH
=
\"
/bin:/usr/bin:/usr/local/bin
\"
\
$(
pkgconf
--cflags
libbsd
)
\
-Wall
${
LDFLAGS
}
*
.c
-o
$pkgname
$(
pkgconf
--libs
libbsd
)
$(
pkgconf
--libs
fts
)
-Wall
${
LDFLAGS
}
*
.c
-o
$pkgname
$(
pkgconf
--libs
libbsd
)
$(
pkgconf
--libs
lib
fts
)
}
package
()
{
cd
"
$builddir
"
install
-Dm755
pax
"
$pkgdir
"
/usr/bin/pax
ln
-s
pax
"
$pkgdir
"
/usr/bin/paxcpio
ln
-s
pax
"
$pkgdir
"
/usr/bin/paxtar
install
-Dm644
pax.1
"
$pkgdir
"
/usr/share/man/man1/pax.1
install
-m644
cpio.1
"
$pkgdir
"
/usr/share/man/man1/paxcpio.1
install
-m644
tar.1
"
$pkgdir
"
/usr/share/man/man1/paxtar.1
}
sha512sums
=
"4ca17a412fde5c0de3ff9820a9a5c7e210e015ccddcc791f0c0936f45471dbbe1e96a97515e65d21e5d36a61b14e920eb3a9181ffeabad801663c812ee084c15 pax_20161104.orig.tar.xz"
sha512sums
=
"4ca17a412fde5c0de3ff9820a9a5c7e210e015ccddcc791f0c0936f45471dbbe1e96a97515e65d21e5d36a61b14e920eb3a9181ffeabad801663c812ee084c15 pax_20161104.orig.tar.xz
f494daeebca58bfc0875138e3b01e1d7b74d982b574b0d06d18244046cd0c0b99d8039a629391a578657489346f580c4eaf347ee43ba78eb1058fadebffef497 needed-header.patch
96d018bd1be2b0d22c9c5e11a92d8cf7ef9bc72d1b13686e572aa15935f2fda9d507baf1e0eb916fec776c2f9d7bab458c203cab64446eed34b70f544109d1d7 pax-20160306-glibc-to-linux.patch"
This diff is collapsed.
Click to expand it.
user/pax/needed-header.patch
0 → 100644
+
11
−
0
View file @
d44caf81
--- pax/pax.h.old 2016-10-25 19:05:17.000000000 +0000
+++ pax/pax.h 2017-07-29 14:52:09.258899166 +0000
@@ -41,6 +41,8 @@
#ifndef MIRCPIO_PAX_H
#define MIRCPIO_PAX_H "$MirOS: src/bin/pax/pax.h,v 1.17 2016/10/25 19:04:26 tg Exp $"
+#include <sys/types.h>
+
/*
* BSD PAX global data structures and constants.
*/
This diff is collapsed.
Click to expand it.
user/pax/pax-20160306-glibc-to-linux.patch
0 → 100644
+
38
−
0
View file @
d44caf81
--- pax/cache.c.old 2016-03-06 08:12:52.000000000 -0600
+++ pax/cache.c 2016-04-17 13:01:26.461307830 -0500
@@ -195,7 +195,7 @@
* No entry for this uid, we will add it
*/
if (!pwopn) {
-#if defined(__GLIBC__)
+#if defined(__GLIBC__) || defined(__linux__)
setpwent();
#elif !defined(__INTERIX)
setpassent(1);
@@ -265,7 +265,7 @@
* No entry for this gid, we will add it
*/
if (!gropn) {
-#if defined(__GLIBC__)
+#if defined(__GLIBC__) || defined(__linux__)
setgrent();
#elif !defined(__INTERIX) && !defined(__CYGWIN__)
setgroupent(1);
@@ -336,7 +336,7 @@
}
if (!pwopn) {
-#if defined(__GLIBC__)
+#if defined(__GLIBC__) || defined(__linux__)
setpwent();
#elif !defined(__INTERIX)
setpassent(1);
@@ -403,7 +403,7 @@
}
if (!gropn) {
-#if defined(__GLIBC__)
+#if defined(__GLIBC__) || defined(__linux__)
setgrent();
#elif !defined(__INTERIX) && !defined(__CYGWIN__)
setgroupent(1);
This diff is collapsed.
Click to expand it.
Preview
0%
Loading
Try again
or
attach a new file
.
Cancel
You are about to add
0
people
to the discussion. Proceed with caution.
Finish editing this message first!
Save comment
Cancel
Please
register
or
sign in
to comment