Skip to content
Snippets Groups Projects
Commit cb6f083b authored by Anna Wilcox's avatar Anna Wilcox :fox:
Browse files

Merge branch 'libreoffice' into 'master'

LibreOffice and dependencies

I have made a deal with Satan.

See merge request !44
parents 7ef2ed32 c5975fc8
No related branches found
No related tags found
No related merge requests found
Showing
with 851 additions and 0 deletions
# Contributor: Natanael Copa <ncopa@alpinelinux.org>
# Maintainer: Max Rees <maxcrees@me.com>
pkgname=clucene
pkgver=2.3.3.4
pkgrel=5
pkgdesc="A C++ port of Lucene"
url="http://www.sourceforge.net/projects/clucene"
arch="all"
license="(LGPL-2.1+ OR Apache-2.0) AND RSA-MD AND (LGPL-2.0+ OR Apache-2.0) AND Zlib AND Apache-2.0"
depends=""
depends_dev="zlib-dev boost-dev"
makedepends="cmake $depends_dev"
subpackages="$pkgname-dev $pkgname-contribs"
source="http://downloads.sourceforge.net/clucene/clucene-core-$pkgver.tar.gz
pkgconfig.patch
install_contribs_lib.patch
usleep.patch
disable-threading.patch
"
builddir="$srcdir/$pkgname-core-$pkgver"
prepare() {
default_prepare
cd "$builddir"
# Do not use bundled zlib or boost
sed -ie '/ADD_SUBDIRECTORY (src\/ext)/d' CMakeLists.txt
rm -rf src/ext
}
build() {
cd "$builddir"
cmake . -DCMAKE_BUILD_TYPE=RelWithDebInfo \
-DCMAKE_INSTALL_PREFIX=/usr \
-DBUILD_CONTRIBS_LIB=BOOL:ON \
-DLIB_DESTINATION:PATH=/usr/lib \
-DLUCENE_SYS_INCLUDES:PATH=/usr/lib \
-DDISABLE_MULTITHREADING=BOOL:ON
make
}
check() {
cd "$builddir"
# Need to force cmake to update - some sort of race condition
touch CMakeCache.txt
make cl_test
cd bin
./cl_test
}
package() {
cd "$builddir"
make install/fast DESTDIR="$pkgdir"
rm -r "$pkgdir"/usr/lib/CLuceneConfig.cmake
}
contribs() {
pkgdesc="Language specific text analyzers for CLucene"
mkdir -p "$subpkgdir"/usr/lib
mv "$pkgdir"/usr/lib/libclucene-contribs*.so.* "$subpkgdir"/usr/lib/
}
dev() {
default_dev
mv "$pkgdir"/usr/lib/CLucene/*.cmake "$subpkgdir"/usr/lib/CLucene/
}
sha512sums="1c9da9077edcebd46563bd9e47d330518e0b30061016650a759cfe051e9748fdad8932a472b1cca53a6adafed5f41656527271fc5f55ddfcefb558f0d83286b4 clucene-core-2.3.3.4.tar.gz
b357cb5a1c5d66219f3168724a71af3ebf5c45c752a612d3a69c170b739acc065dc17c261c3a730298ea6c637fe820637a100f73ab03d931734f80bb598fbf55 pkgconfig.patch
0aa92635949089196e4e7c579e78761e8751987ef5036320a161a4aaa67da3c63756398c903419c76ea0fbdc8a949e871fcb65be98179a9853a24a5a4cacfde3 install_contribs_lib.patch
5de49cb5eba1f9033f28281e0e5ff0e29fe6842ea3e1cb246c12649dc12dedad15e1811b45ccc989a1b743657eb0eeb4937616aa19ec5ee482cd323f54431b99 usleep.patch
3ded79aed693f6de35389377eddea0b4b0bb0cafd016f6f766986297c35912b18c1e90cedb1fb1d256765abdaab05ca2999aec2fe7ae309fa75231ac94c519a9 disable-threading.patch"
Adapted from https://sourceforge.net/p/clucene/bugs/197
--- clucene-core-2.3.3.4/src/shared/CLucene/util/Misc.cpp 2011-03-16 20:21:07.000000000 -0400
+++ clucene-core-2.3.3.4/src/shared/CLucene/util/Misc.cpp 2018-05-20 19:24:09.219901243 -0400
@@ -466,6 +466,7 @@
std::string Misc::toString(const bool value){
return value ? "true" : "false";
}
+#ifndef _CL_DISABLE_MULTITHREADING
std::string Misc::toString(_LUCENE_THREADID_TYPE value){
static int32_t nextindex = 0;
static std::map<_LUCENE_THREADID_TYPE, int32_t> ids;
@@ -474,6 +475,7 @@
}
return toString(ids[value]);
}
+#endif
std::string Misc::toString(const int32_t value){
char buf[20];
TCHAR tbuf[20];
--- clucene-core-2.3.3.4/src/shared/CLucene/util/Misc.h 2011-03-16 20:21:07.000000000 -0400
+++ clucene-core-2.3.3.4/src/shared/CLucene/util/Misc.h 2018-05-20 19:24:09.219901243 -0400
@@ -67,7 +67,9 @@
static std::string toString(const int32_t value);
static std::string toString(const int64_t value);
+ #ifndef _CL_DISABLE_MULTITHREADING
static std::string toString(const _LUCENE_THREADID_TYPE value);
+ #endif
static std::string toString(const bool value);
static std::string toString(const float_t value);
static std::string toString(const TCHAR* s, int32_t len=-1);
--- clucene-core-2.3.3.4/src/shared/CLucene/LuceneThreads.h 2011-03-16 20:21:07.000000000 -0400
+++ clucene-core-2.3.3.4/src/shared/CLucene/LuceneThreads.h 2018-05-20 19:28:05.999899570 -0400
@@ -13,10 +13,10 @@
#if defined(_CL_DISABLE_MULTITHREADING)
#define SCOPED_LOCK_MUTEX(theMutex)
- #define DEFINE_MUTEX(x)
+ //#define DEFINE_MUTEX(x)
#define DEFINE_MUTABLE_MUTEX(x)
#define DEFINE_CONDITION(x)
- #define STATIC_DEFINE_MUTEX(x)
+ //#define STATIC_DEFINE_MUTEX(x)
#define CONDITION_WAIT(theMutex, theCondition)
#define CONDITION_NOTIFYALL(theCondition)
#define _LUCENE_CURRTHREADID 1
@@ -25,11 +25,27 @@
#define _LUCENE_THREAD_FUNC_RETURN(val) return (int)val;
#define _LUCENE_THREAD_CREATE(func, arg) (*func)(arg)
#define _LUCENE_THREAD_JOIN(value) //nothing to do...
- #define _LUCENE_THREADMUTEX void*
+ //#define _LUCENE_THREADMUTEX void*
#define _LUCENE_ATOMIC_INC(theInteger) (++(*theInteger))
#define _LUCENE_ATOMIC_DEC(theInteger) (--(*theInteger))
#define _LUCENE_ATOMIC_INT int
+
+ #define _LUCENE_ATOMIC_INT_SET(x,v) x=v
+ #define _LUCENE_ATOMIC_INT_GET(x) x
+
+ struct CLUCENE_SHARED_EXPORT mutex_thread
+ {
+ void lock() {}
+ void unlock() {}
+ };
+ #define _LUCENE_THREADMUTEX CL_NS(util)::mutex_thread
+
+ #define DEFINE_MUTEX(theMutex) _LUCENE_THREADMUTEX theMutex;
+ #define STATIC_DEFINE_MUTEX(theMutex) static _LUCENE_THREADMUTEX theMutex;
+
+ #define CONDITION_WAIT(theMutex, theCondition)
+ #define CONDITION_NOTIFYALL(theCondition)
#else
#if defined(_LUCENE_DONTIMPLEMENT_THREADMUTEX)
//do nothing
diff -NaurpBb clucene-core-2.3.3.4/CMakeLists.txt clucene-core-2.3.3.4-mod/CMakeLists.txt
--- clucene-core-2.3.3.4/CMakeLists.txt 2011-03-17 03:21:07.000000000 +0300
+++ clucene-core-2.3.3.4-mod/CMakeLists.txt 2011-08-16 16:56:55.968268152 +0400
@@ -163,7 +163,7 @@ IF ( BUILD_CONTRIBS )
SET(BUILD_CONTRIBS_LIB 1)
ENDIF ( BUILD_CONTRIBS )
IF ( BUILD_CONTRIBS_LIB )
- ADD_SUBDIRECTORY (src/contribs-lib EXCLUDE_FROM_ALL)
+ ADD_SUBDIRECTORY (src/contribs-lib)
ENDIF ( BUILD_CONTRIBS_LIB )
diff -NaurpBb clucene-core-2.3.3.4/src/contribs-lib/CMakeLists.txt clucene-core-2.3.3.4-mod/src/contribs-lib/CMakeLists.txt
--- clucene-core-2.3.3.4/src/contribs-lib/CMakeLists.txt 2011-03-17 03:21:07.000000000 +0300
+++ clucene-core-2.3.3.4-mod/src/contribs-lib/CMakeLists.txt 2011-08-16 17:14:13.499275499 +0400
@@ -106,9 +106,26 @@ add_library(clucene-contribs-lib SHARED
)
TARGET_LINK_LIBRARIES(clucene-contribs-lib ${clucene_contrib_extra_libs})
+#install public headers.
+FOREACH(file ${HEADERS})
+ get_filename_component(apath ${file} PATH)
+ get_filename_component(aname ${file} NAME)
+ file(RELATIVE_PATH relpath ${CMAKE_SOURCE_DIR}/src/contribs-lib ${apath})
+ IF ( NOT aname MATCHES "^_.*" )
+ install(FILES ${file}
+ DESTINATION include/${relpath}
+ COMPONENT development)
+ ENDIF ( NOT aname MATCHES "^_.*" )
+ENDFOREACH(file)
+
#set properties on the libraries
SET_TARGET_PROPERTIES(clucene-contribs-lib PROPERTIES
VERSION ${CLUCENE_VERSION}
SOVERSION ${CLUCENE_SOVERSION}
COMPILE_DEFINITIONS_DEBUG _DEBUG
)
+
+#and install library
+install(TARGETS clucene-contribs-lib
+ DESTINATION ${LIB_DESTINATION}
+ COMPONENT runtime )
diff -up clucene-core-2.3.3.4/src/core/libclucene-core.pc.cmake.pkgconfig_sys_includes clucene-core-2.3.3.4/src/core/libclucene-core.pc.cmake
--- clucene-core-2.3.3.4/src/core/libclucene-core.pc.cmake.pkgconfig_sys_includes 2011-03-16 19:21:07.000000000 -0500
+++ clucene-core-2.3.3.4/src/core/libclucene-core.pc.cmake 2012-03-19 09:01:00.689263954 -0500
@@ -6,6 +6,6 @@ includedir=${prefix}/include:${prefix}/i
Name: libclucene
Description: CLucene - a C++ search engine, ported from the popular Apache Lucene
Version: @CLUCENE_VERSION_MAJOR@.@CLUCENE_VERSION_MINOR@.@CLUCENE_VERSION_REVISION@.@CLUCENE_VERSION_PATCH@
-Libs: -L${prefix}/@LIB_DESTINATION@/ -lclucene-core
-Cflags: -I${prefix}/include -I${prefix}/include/CLucene/ext
+Libs: -L${prefix}/@LIB_DESTINATION@/ -lclucene-core -lclucene-shared
+Cflags: -I${prefix}/include -I${prefix}/include/CLucene/ext -I@LUCENE_SYS_INCLUDES@
~
Add missing include needed to run tests which use usleep
--- clucene-core-2.3.3.4/src/test/test.h 2011-03-17 00:21:07.000000000 +0000
+++ clucene-core-2.3.3.4/src/test/test.h 2017-12-27 09:43:25.320000000 +0000
@@ -23,6 +23,7 @@
#include <iostream>
#include <string.h>
#include <stdio.h>
+#include <unistd.h>
using namespace std;
# Contributor: Natanael Copa <ncopa@alpinelinux.org>
# Maintainer: Max Rees <maxcrees@me.com>
pkgname=cppunit
pkgver=1.14.0
pkgrel=0
pkgdesc="C++ unit testing framework"
url="https://www.freedesktop.org/wiki/Software/cppunit/"
arch="all"
license="LGPL-2.1+"
subpackages="$pkgname-dev $pkgname-doc"
source="http://dev-www.libreoffice.org/src/$pkgname-$pkgver.tar.gz"
build() {
cd "$builddir"
LIBS="-ldl" ./configure \
--build=$CBUILD \
--host=$CHOST \
--prefix=/usr \
--sysconfdir=/etc \
--mandir=/usr/share/man \
--infodir=/usr/share/info \
--localstatedir=/var
make
}
check() {
cd "$builddir"
make check
}
package() {
cd "$builddir"
make DESTDIR="$pkgdir" install
}
sha512sums="4ea1da423c6f7ab37e4144689f593396829ce74d43872d6b10709c1ad5fbda4ee945842f7e9803592520ef81ac713e95a3fe130295bf048cd32a605d1959882e cppunit-1.14.0.tar.gz"
# Contributor: Natanael Copa <ncopa@alpinelinux.org>
# Maintainer: Max Rees <maxcrees@me.com>
pkgname=glm
pkgver=0.9.9.0
pkgrel=0
pkgdesc="C++ header-only mathematics library for graphics programming"
url="https://glm.g-truc.net/"
arch="noarch"
license="MIT OR Custom:Happy-Bunny"
makedepends="cmake"
source="https://github.com/g-truc/glm/releases/download/$pkgver/$pkgname-$pkgver.zip"
builddir="$srcdir/$pkgname"
replaces="glm-dev"
build() {
cd "$builddir"
mkdir build
cd build
cmake .. \
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_BUILD_TYPE=RelWithDebInfo \
-DCMAKE_INSTALL_LIBDIR=lib \
-DGLM_TEST_ENABLE=bool:ON
make
}
check() {
cd "$builddir"/build
make test
}
package() {
cd "$builddir"/build
make install DESTDIR="$pkgdir"
}
sha512sums="ac256e8ba515a0a57e27cb9dc79325af7a6f014341c11ba34af604fc2df03ada6979c39c0e5a3fd7526a5dc6dd4af99586e60cefe13bb134ad4df2212193a253 glm-0.9.9.0.zip"
# Contributor: Timo Teräs <timo.teras@iki.fi>
# Maintainer: Max Rees <maxcrees@me.com>
pkgname=hyphen
pkgver=2.8.8
pkgrel=1
pkgdesc="Library for high quality word hyphenation and justification"
url="https://hunspell.sourceforge.net/"
arch="all"
license="LGPL-2.1+ OR LGPL-2.0+ OR MPL-1.0 or GPL-2.0+"
subpackages="$pkgname-dev"
depends=""
depends_dev="perl"
makedepends="$depends_dev"
source="https://downloads.sourceforge.net/hunspell/$pkgname-$pkgver.tar.gz
mawk.patch"
build() {
cd "$builddir"
./configure \
--build=$CBUILD \
--host=$CHOST \
--prefix=/usr \
--disable-static \
--disable-dependency-tracking \
--enable-fast-install
make
}
check() {
cd "$builddir"
make check
}
package() {
cd "$builddir"
make -j1 DESTDIR="$pkgdir" install
# The en_US dictionary that comes with has an unacceptable license
# and it isn't really needed anyway since libreoffice has its own
rm -r "$pkgdir"/usr/share
}
dev() {
default_dev
mkdir -p "$subpkgdir"/usr
mv "$pkgdir"/usr/bin "$subpkgdir"/usr
}
sha512sums="ee514952be56869840b70fb74f60eba14dc4de246733ff8705492367e8cf00c485f8778a9d5a7ba374c988d4ac9fedbe75826dc559e1b62465dbfba21f6ce7de hyphen-2.8.8.tar.gz
c9ee32c265ded1e862baae69ec30f3a1769b447bdcf0b51d1d59d5fe4c986c8fdf04049085344311f411cd0204a5f7c003eb290669a668d9b137c74698d1c8b0 mawk.patch"
--- hyphen-2.8.8/lig.awk 2010-03-04 07:13:47.000000000 -0500
+++ hyphen-2.8.8/lig.awk 2018-08-08 14:53:48.970188512 -0400
@@ -24,14 +24,14 @@
c!=b { print c }
/f[1-9]?$/ {
- print gensub("f[1-9]?$", "ff", "g", b);
- if (c!=b) print gensub("f[1-9]?$", "ff", "g", c);
+ print gsub("f[1-9]?$", "ff", b);
+ if (c!=b) print gsub("f[1-9]?$", "ff", c);
- print gensub("f[1-9]?$", "fi", "g", b);
- if (c!=b) print gensub("f[1-9]?$", "fi", "g", c);
+ print gsub("f[1-9]?$", "fi", b);
+ if (c!=b) print gsub("f[1-9]?$", "fi", c);
- print gensub("f[1-9]?$", "fl", "g", b);
- if (c!=b) print gensub("f[1-9]?$", "fl", "g", c);
+ print gsub("f[1-9]?$", "fl", b);
+ if (c!=b) print gsub("f[1-9]?$", "fl", c);
}
# Contributor: Timo Teräs <timo.teras@iki.fi>
# Maintainer: Max Rees <maxcrees@me.com>
pkgname=libabw
pkgver=0.1.2
pkgrel=0
pkgdesc="Import filter and tools for AbiWord documents"
url="https://wiki.documentfoundation.org/DLP/Libraries/libabw"
arch="all"
options="!check" # No test suite.
license="MPL-2.0"
depends=""
depends_dev="librevenge-dev libxml2-dev zlib-dev boost-dev"
makedepends="$depends_dev doxygen gperf perl"
subpackages="$pkgname-dev $pkgname-doc $pkgname-tools"
source="http://dev-www.libreoffice.org/src/$pkgname/$pkgname-$pkgver.tar.xz"
build() {
cd "$builddir"
./configure \
--build=$CBUILD \
--host=$CHOST \
--prefix=/usr \
--sysconfdir=/etc \
--mandir=/usr/share/man \
--infodir=/usr/share/info \
--localstatedir=/var \
--disable-werror
make
}
package() {
cd "$builddir"
make DESTDIR="$pkgdir" install
}
tools() {
mkdir -p "$subpkgdir"/usr
mv "$pkgdir"/usr/bin "$subpkgdir"/usr
}
sha512sums="a365c1aa047a97a86eee6bce8463646bdf248a51013139ee288402a832fd545586e072d7c7fc11a56f42e3637de9e922197be20d0587e53c51fd80ced409a6cd libabw-0.1.2.tar.xz"
# Contributor: Timo Teräs <timo.teras@iki.fi>
# Maintainer: Max Rees <maxcrees@me.com>
pkgname=libcdr
pkgver=0.1.4
pkgrel=2
pkgdesc="Import filter and tools for Corel DRAW files"
url="https://wiki.documentfoundation.org/DLP/Libraries/libcdr"
arch="all"
license="MPL-2.0"
depends=""
depends_dev="boost-dev"
makedepends="$depends_dev doxygen icu-dev lcms2-dev zlib-dev librevenge-dev"
checkdepends="cppunit-dev"
subpackages="$pkgname-dev $pkgname-doc $pkgname-tools"
source="http://dev-www.libreoffice.org/src/$pkgname/$pkgname-$pkgver.tar.xz"
prepare() {
default_prepare
update_config_sub
}
build() {
cd "$builddir"
./configure \
--build=$CBUILD \
--host=$CHOST \
--prefix=/usr \
--sysconfdir=/etc \
--mandir=/usr/share/man \
--infodir=/usr/share/info \
--localstatedir=/var
make
}
check() {
cd "$builddir"
make check
}
package() {
cd "$builddir"
make DESTDIR="$pkgdir" install
}
tools() {
mkdir -p "$subpkgdir"/usr
mv "$pkgdir"/usr/bin "$subpkgdir"/usr
}
sha512sums="769b0319b5a904ce9f727b7076f82cd915ecd8c9e5e2456416e3e6739c6403bbd4108787ab124d36efb1b47d5c9e37c48b0e12d096eb440ae8f9979ec06048a6 libcdr-0.1.4.tar.xz"
# Contributor: Timo Teräs <timo.teras@iki.fi>
# Maintainer: Max Rees <maxcrees@me.com>
pkgname=libcmis
pkgver=0.5.1
pkgrel=2
pkgdesc="CMIS protocol client library for C/C++"
url="https://github.com/tdf/libcmis"
arch="all"
license="MPL-1.1 OR GPL-2.0+ OR LGPL-2.0+"
depends=""
depends_dev="boost-dev"
makedepends="$depends_dev curl-dev libxml2-dev"
checkdepends="cppunit-dev"
subpackages="$pkgname-dev cmis-client:client"
source="https://github.com/tdf/$pkgname/releases/download/v$pkgver/$pkgname-$pkgver.tar.gz"
build() {
cd "$builddir"
# Note: manpages require docbook2x to build
./configure \
--build=$CBUILD \
--host=$CHOST \
--prefix=/usr \
--sysconfdir=/etc \
--mandir=/usr/share/man \
--infodir=/usr/share/info \
--localstatedir=/var \
--without-man \
--disable-werror
make
}
check() {
cd "$builddir"
make check
}
package() {
cd "$builddir"
make DESTDIR="$pkgdir" install
# Leftover docbook file
rm -r "$pkgdir"/usr/share/man
}
client() {
mkdir -p "$subpkgdir"/usr
mv "$pkgdir"/usr/bin "$subpkgdir"/usr
}
sha512sums="da1e66a7604f90644ad6ee691a5c06df36debec20db361e166ee64c9f8ce85be48623e38367ea2799107c10041ed5f8c3a8011a80d6eaca800c29084fb4fe0f6 libcmis-0.5.1.tar.gz"
# Contributor: Timo Teräs <timo.teras@iki.fi>
# Maintainer: Max Rees <maxcrees@me.com>
pkgname=libe-book
pkgver=0.1.3
pkgrel=1
pkgdesc="Import filter and tools for various ebook formats"
url="https://sourceforge.net/projects/libebook/"
arch="all"
license="MPL-2.0"
depends_dev="boost-dev librevenge-dev liblangtag-dev"
makedepends="$depends_dev icu-dev libxml2-dev zlib-dev doxygen gperf"
checkdepends="cppunit-dev"
subpackages="$pkgname-dev $pkgname-doc $pkgname-tools"
source="http://downloads.sourceforge.net/project/libebook/libe-book-$pkgver/libe-book-$pkgver.tar.bz2"
prepare() {
default_prepare
update_config_sub
}
build() {
cd "$builddir"
./configure \
--build=$CBUILD \
--host=$CHOST \
--prefix=/usr \
--sysconfdir=/etc \
--mandir=/usr/share/man \
--infodir=/usr/share/info \
--localstatedir=/var \
--disable-werror
make
}
check() {
cd "$builddir"
make check
}
package() {
cd "$builddir"
make DESTDIR="$pkgdir" install
}
tools() {
mkdir -p "$subpkgdir"/usr
mv "$pkgdir"/usr/bin "$subpkgdir"/usr
}
sha512sums="9afa2949f702a34fd6278145ce8d18d504326ed5a103bbc872d0493fcf3e2166d41d094bb0d74b80aa913ca6d082f5bd3259799a4a3c7359331ccdfa1e029a21 libe-book-0.1.3.tar.bz2"
# Contributor: Leonardo Arena <rnalrd@alpinelinux.org>
# Maintainer: Max Rees <maxcrees@me.com>
pkgname=libepubgen
pkgver=0.1.1
pkgrel=1
pkgdesc="librevenge export filter to EPUB"
url="https://sourceforge.net/projects/libepubgen/"
arch="all"
license="MPL-2.0"
depends=""
makedepends="librevenge-dev libxml2-dev doxygen"
checkdepends="cppunit-dev"
subpackages="$pkgname-dev $pkgname-doc"
source="https://download.sourceforge.net/project/$pkgname/$pkgname-$pkgver/$pkgname-$pkgver.tar.bz2"
build() {
cd "$builddir"
./configure \
--build=$CBUILD \
--host=$CHOST \
--prefix=/usr \
--sysconfdir=/etc \
--mandir=/usr/share/man \
--infodir=/usr/share/info
make
}
check() {
cd "$builddir"
make check
}
package() {
cd "$builddir"
make DESTDIR="$pkgdir" install
}
sha512sums="8e0d3670d16825ec8262c8cbd990f089b7c85defd9f52bb063085bb9a13fd0bb26ab92b59fb794d5af4ec81f62f560efad133585de71c9e5c27c4706f5738f50 libepubgen-0.1.1.tar.bz2"
# Contributor: Timo Teräs <timo.teras@iki.fi>
# Maintainer: Max Rees <maxcrees@me.com>
pkgname=libetonyek
pkgver=0.1.8
pkgrel=0
pkgdesc="Import filter and tools for Apple iWork documents"
url="https://wiki.documentfoundation.org/DLP/Libraries/libetonyek"
arch="all"
license="MPL-2.0"
depends_dev="glm-dev boost-dev librevenge-dev liblangtag-dev"
makedepends="$depends_dev zlib-dev libxml2-dev gperf doxygen mdds"
checkdepends="cppunit-dev"
subpackages="$pkgname-dev $pkgname-doc $pkgname-tools"
source="http://dev-www.libreoffice.org/src/$pkgname/$pkgname-$pkgver.tar.xz"
build() {
cd "$builddir"
./configure \
--build=$CBUILD \
--host=$CHOST \
--prefix=/usr \
--sysconfdir=/etc \
--mandir=/usr/share/man \
--infodir=/usr/share/info \
--localstatedir=/var \
--disable-werror \
--disable-static
make
}
check() {
cd "$builddir"
make check
}
package() {
cd "$builddir"
make DESTDIR="$pkgdir" install
}
tools() {
mkdir -p "$subpkgdir"/usr
mv "$pkgdir"/usr/bin "$subpkgdir"/usr
}
sha512sums="c8c08100b0c75e0420bbcd796f7cb9285e77ce1be34757df5b237d114a428a4a6094f12e442f81769a2fac5be45ea4376ff9e1d90448e18b3443bfe7c645a865 libetonyek-0.1.8.tar.xz"
# Contributor: Timo Teräs <timo.teras@iki.fi>
# Maintainer: Max Rees <maxcrees@me.com>
pkgname=libexttextcat
pkgver=3.4.5
pkgrel=1
pkgdesc="An N-Gram-based text categorization library"
url="https://wiki.documentfoundation.org/Libexttextcat"
arch="all"
license="BSD-3-Clause"
depends=""
makedepends=""
checkdepends="bash"
subpackages="$pkgname-dev"
source="http://dev-www.libreoffice.org/src/$pkgname/$pkgname-$pkgver.tar.xz"
build() {
cd "$builddir"
./configure \
--build=$CBUILD \
--host=$CHOST \
--prefix=/usr \
--sysconfdir=/etc \
--mandir=/usr/share/man \
--infodir=/usr/share/info \
--localstatedir=/var \
--disable-werror
make
}
check() {
cd "$builddir"
make check
}
package() {
cd "$builddir"
make DESTDIR="$pkgdir" install
}
sha512sums="f05a9f08c2f2f335d0e483c024321b96fee7424bc1398d4c6acbd9c501f92e22f881bc3d6ec2c0434f9bf4604f3c4b0e880e37d3d0de410eac1a20ea6669baa6 libexttextcat-3.4.5.tar.xz"
# Contributor: Timo Teräs <timo.teras@iki.fi>
# Maintainer: Max Rees <maxcrees@me.com>
pkgname=libfreehand
pkgver=0.1.2
pkgrel=1
pkgdesc="Import filter and tools for Adobe FreeHand documents"
url="https://wiki.documentfoundation.org/DLP/Libraries/libfreehand"
arch="all"
license="MPL-2.0 AND Public-Domain"
depends=""
depends_dev="libxml2-dev lcms2-dev icu-dev"
makedepends="$depends_dev gperf perl doxygen librevenge-dev zlib-dev"
checkdepends="cppunit-dev"
subpackages="$pkgname-dev $pkgname-doc $pkgname-tools"
source="http://dev-www.libreoffice.org/src/$pkgname/$pkgname-$pkgver.tar.xz"
prepare() {
default_prepare
update_config_sub
}
build() {
cd "$builddir"
./configure \
--build=$CBUILD \
--host=$CHOST \
--prefix=/usr \
--sysconfdir=/etc \
--mandir=/usr/share/man \
--infodir=/usr/share/info \
--localstatedir=/var \
--disable-werror
make
}
check() {
cd "$builddir"
make check
}
package() {
cd "$builddir"
make DESTDIR="$pkgdir" install
}
tools() {
mkdir -p "$subpkgdir"/usr
mv "$pkgdir"/usr/bin "$subpkgdir"/usr
}
sha512sums="4112a76ac99999801d97d1b282596d631d8496a5bf65778ab26aa06da86637b1e2b630648a67ea01bf3316ecec9f2715546baff27af090b900267c87a011b963 libfreehand-0.1.2.tar.xz"
# Contributor: Timo Teräs <timo.teras@iki.fi>
# Maintainer: Max Rees <maxcrees@me.com>
pkgname=libixion
pkgver=0.13.0
pkgrel=0
pkgdesc="A general purpose formula parser & interpreter"
url="https://gitlab.com/ixion/ixion"
arch="all"
license="MPL-2.0"
depends=""
depends_dev="mdds"
makedepends="$depends_dev boost-dev"
subpackages="$pkgname-dev"
source="http://kohei.us/files/ixion/src/$pkgname-$pkgver.tar.xz"
build() {
cd "$builddir"
./configure \
--build=$CBUILD \
--host=$CHOST \
--prefix=/usr \
--sysconfdir=/etc \
--mandir=/usr/share/man \
--localstatedir=/var \
--disable-python
make
}
check() {
cd "$builddir"
make check
}
package() {
cd "$builddir"
make DESTDIR="$pkgdir" install
}
dev() {
default_dev
cd "$builddir"
mkdir -p "$subpkgdir"/usr
mv "$pkgdir"/usr/bin "$subpkgdir"/usr
}
sha512sums="15784e947164d106e677c59ece53b3cd401d4f9433cc5331a35d3be8332ae4f20a469ca73b30b253433c86da4afde886dfb4ac23e46ed46376a7349e0276c3a0 libixion-0.13.0.tar.xz"
# Contributor: Francesco Colista <fcolista@alpinelinux.org>
# Maintainer: Max Rees <maxcrees@me.com>
pkgname=liblangtag
pkgver=0.6.2
pkgrel=0
pkgdesc="Interface library to access tags for identifying languages"
url="https://bitbucket.org/tagoh/liblangtag"
arch="all"
license="LGPL-3.0+ OR MPL-2.0"
depends=""
makedepends="glib-dev gobject-introspection-dev libtool libxml2-dev"
checkdepends="check-dev"
subpackages="$pkgname-dev $pkgname-doc"
source="https://bitbucket.org/tagoh/$pkgname/downloads/$pkgname-$pkgver.tar.bz2"
build() {
cd "$builddir"
./configure \
--build=$CBUILD \
--host=$CHOST \
--prefix=/usr \
--sysconfdir=/etc \
--mandir=/usr/share/man \
--infodir=/usr/share/info \
--localstatedir=/var
make
}
check() {
cd "$builddir"
make check
}
package() {
cd "$builddir"
make DESTDIR="$pkgdir" install
}
sha512sums="812e00d0a26eedc1fa9bee6d0b9da53b8faca8d1fc5f93a0423106b5b777c7b1ec5854da7d02606c215ad1a1248de93016559c7a55288a4b427857fb1ed1ad8f liblangtag-0.6.2.tar.bz2"
# Contributor: Timo Teräs <timo.teras@iki.fi>
# Maintainer: Max Rees <maxcrees@me.com>
pkgname=libmspub
pkgver=0.1.4
pkgrel=0
pkgdesc="Import filter and tools for Microsoft Publisher files"
url="https://wiki.documentfoundation.org/DLP/Libraries/libmspub"
arch="all"
options="!check" # No test suite.
license="MPL-2.0 AND (MPL-1.1 OR GPL-2.0+ OR LGPL-2.0+)"
depends_dev="boost-dev librevenge-dev"
makedepends="$depends_dev icu-dev doxygen"
subpackages="$pkgname-dev $pkgname-doc $pkgname-tools"
source="http://dev-www.libreoffice.org/src/$pkgname/$pkgname-$pkgver.tar.xz"
build() {
cd "$builddir"
./configure \
--build=$CBUILD \
--host=$CHOST \
--prefix=/usr \
--sysconfdir=/etc \
--mandir=/usr/share/man \
--infodir=/usr/share/info \
--localstatedir=/var
make
}
package() {
cd "$builddir"
make DESTDIR="$pkgdir" install
}
tools() {
mkdir -p "$subpkgdir"/usr
mv "$pkgdir"/usr/bin "$subpkgdir"/usr
}
sha512sums="7275f890645961b3fd56df4584788962e8c064fe3f99f5834c6ba6177ce76d00d544fbe9a25b7ab2f4180d2f3a90c609fe0bb68d61ea24e95b086190390fff31 libmspub-0.1.4.tar.xz"
0% Loading or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment