Skip to content
GitLab
Explore
Sign in
Register
Primary navigation
Search or go to…
Project
Adélie Package Tree
Manage
Activity
Members
Labels
Plan
Issues
Issue boards
Milestones
Wiki
Code
Merge requests
Repository
Branches
Commits
Tags
Repository graph
Compare revisions
Build
Pipelines
Jobs
Pipeline schedules
Artifacts
Deploy
Package Registry
Model registry
Operate
Terraform modules
Analyze
Model experiments
Help
Help
Support
GitLab documentation
Compare GitLab plans
Community forum
Contribute to GitLab
Provide feedback
Keyboard shortcuts
?
Snippets
Groups
Projects
Show more breadcrumbs
andri saputra
Adélie Package Tree
Commits
c75e4e05
Commit
c75e4e05
authored
7 years ago
by
Síle Ekaterin Liszka
Browse files
Options
Downloads
Patches
Plain Diff
user/pcmanfm-qt: new package
parent
f2e73738
No related branches found
No related tags found
No related merge requests found
Changes
2
Hide whitespace changes
Inline
Side-by-side
Showing
2 changed files
user/pcmanfm-qt/APKBUILD
+49
-0
49 additions, 0 deletions
user/pcmanfm-qt/APKBUILD
user/pcmanfm-qt/pcmanfm-qt-0.11.3-const-iterator-fixes.patch
+26
-0
26 additions, 0 deletions
user/pcmanfm-qt/pcmanfm-qt-0.11.3-const-iterator-fixes.patch
with
75 additions
and
0 deletions
user/pcmanfm-qt/APKBUILD
0 → 100644
+
49
−
0
View file @
c75e4e05
# Contributor: Kiyoshi Aman <kiyoshi.aman+adelie@gmail.com>
# Maintainer: Kiyoshi Aman <kiyoshi.aman+adelie@gmail.com>
pkgname
=
pcmanfm-qt
pkgver
=
0.11.3
pkgrel
=
0
pkgdesc
=
"File manager and desktop icon manager for LXQt"
url
=
"http://lxqt.org"
arch
=
"all"
license
=
"GPL-2.0+"
depends
=
""
depends_dev
=
""
makedepends
=
"cmake extra-cmake-modules lxqt-build-tools libfm-qt-dev liblxqt-dev qt5-qtx11extras-dev qt5-qttools-dev kwindowsystem-dev
$depends_dev
"
install
=
""
subpackages
=
"
$pkgname
-doc"
source
=
"https://github.com/lxde/pcmanfm-qt/releases/download/
$pkgver
/pcmanfm-qt-
$pkgver
.tar.xz
pcmanfm-qt-0.11.3-const-iterator-fixes.patch"
builddir
=
"
$srcdir
/pcmanfm-qt-
$pkgver
"
# no tests
options
=
"!check"
build
()
{
cd
"
$builddir
"
if
[
"
$CBUILD
"
!=
"
$CHOST
"
]
;
then
CMAKE_CROSSOPTS
=
"-DCMAKE_SYSTEM_NAME=Linux -DCMAKE_HOST_SYSTEM_NAME=Linux"
fi
cmake
\
-DCMAKE_INSTALL_PREFIX
=
/usr
\
-DCMAKE_INSTALL_LIBDIR
=
lib
\
-DBUILD_SHARED_LIBS
=
True
\
-DCMAKE_BUILD_TYPE
=
RelWithDebugInfo
\
-DCMAKE_CXX_FLAGS
=
"
$CXXFLAGS
"
\
-DCMAKE_C_FLAGS
=
"
$CFLAGS
"
\
-DPULL_TRANSLATIONS
=
False
\
${
CMAKE_CROSSOPTS
}
make
}
check
()
{
cd
"
$builddir
"
CTEST_OUTPUT_ON_FAILURE
=
TRUE ctest
}
package
()
{
cd
"
$builddir
"
make
DESTDIR
=
"
$pkgdir
"
install
}
sha512sums
=
"168012e022da30d4c2821e34f47372fae421b8b400cc3b2b0c16046f31bbdcb08814d0dd2ea2f0b615fafee4ac8af53ffa5fc0ceb170ccaa29468eec8b30de6d pcmanfm-qt-0.11.3.tar.xz
127eca77c12c2b32b6106ae71b306d8d5fd85d8a2a3c25742f230054cfd7940f43f8d7dda5cc8009cae12a46adb62a6037af9dea0bb00b36b680d249b9e3278c pcmanfm-qt-0.11.3-const-iterator-fixes.patch"
This diff is collapsed.
Click to expand it.
user/pcmanfm-qt/pcmanfm-qt-0.11.3-const-iterator-fixes.patch
0 → 100644
+
26
−
0
View file @
c75e4e05
diff -Nurd pcmanfm-qt-0.11.3/pcmanfm/mainwindow.cpp pcmanfm-qt-0.11.3.new/pcmanfm/mainwindow.cpp
--- pcmanfm-qt-0.11.3/pcmanfm/mainwindow.cpp 2017-01-14 02:13:45.000000000 +0000
+++ pcmanfm-qt-0.11.3.new/pcmanfm/mainwindow.cpp 2017-10-12 20:44:25.731044585 +0000
@@ -970,8 +970,8 @@
void MainWindow::onBookmarksChanged(FmBookmarks* bookmarks, MainWindow* pThis) {
// delete existing items
QList<QAction*> actions = pThis->ui.menu_Bookmarks->actions();
- QList<QAction*>::const_iterator it = actions.begin();
- QList<QAction*>::const_iterator last_it = actions.end() - 2;
+ QList<QAction*>::const_iterator it = actions.constBegin();
+ QList<QAction*>::const_iterator last_it = actions.constEnd() - 2;
while(it != last_it) {
QAction* action = *it;
diff -Nurd pcmanfm-qt-0.11.3/pcmanfm/preferencesdialog.cpp pcmanfm-qt-0.11.3.new/pcmanfm/preferencesdialog.cpp
--- pcmanfm-qt-0.11.3/pcmanfm/preferencesdialog.cpp 2017-01-14 02:13:45.000000000 +0000
+++ pcmanfm-qt-0.11.3.new/pcmanfm/preferencesdialog.cpp 2017-10-12 20:45:17.324377059 +0000
@@ -90,7 +90,7 @@
iconThemes.remove("hicolor"); // remove hicolor, which is only a fallback
QHash<QString, QString>::const_iterator it;
- for(it = iconThemes.begin(); it != iconThemes.end(); ++it) {
+ for(it = iconThemes.constBegin(); it != iconThemes.constEnd(); ++it) {
ui.iconTheme->addItem(it.value(), it.key());
}
ui.iconTheme->model()->sort(0); // sort the list of icon theme names
This diff is collapsed.
Click to expand it.
Preview
0%
Loading
Try again
or
attach a new file
.
Cancel
You are about to add
0
people
to the discussion. Proceed with caution.
Finish editing this message first!
Save comment
Cancel
Please
register
or
sign in
to comment