user/weechat: upgrade to 3.4 [CVE]

Síle Ekaterin Liszka requested to merge weechat/3.4 into zv-next

Merge request reports