Skip to content
GitLab
Explore
Sign in
Register
Primary navigation
Search or go to…
Project
Adélie Package Tree
Manage
Activity
Members
Labels
Plan
Issues
Issue boards
Milestones
Wiki
Code
Merge requests
Repository
Branches
Commits
Tags
Repository graph
Compare revisions
Build
Pipelines
Jobs
Pipeline schedules
Artifacts
Help
Help
Support
GitLab documentation
Compare GitLab plans
Community forum
Contribute to GitLab
Provide feedback
Keyboard shortcuts
?
Snippets
Groups
Projects
Show more breadcrumbs
Adélie Linux
Adélie Package Tree
Commits
f2e73738
Commit
f2e73738
authored
7 years ago
by
Síle Ekaterin Liszka
Browse files
Options
Downloads
Patches
Plain Diff
user/lximage-qt: new package
parent
11166611
No related branches found
Branches containing commit
No related tags found
Tags containing commit
1 merge request
!3
LXQt desktop
Changes
2
Hide whitespace changes
Inline
Side-by-side
Showing
2 changed files
user/lximage-qt/APKBUILD
+49
-0
49 additions, 0 deletions
user/lximage-qt/APKBUILD
user/lximage-qt/lximage-qt-0.5.1-const-iterator-fix.patch
+24
-0
24 additions, 0 deletions
user/lximage-qt/lximage-qt-0.5.1-const-iterator-fix.patch
with
73 additions
and
0 deletions
user/lximage-qt/APKBUILD
0 → 100644
+
49
−
0
View file @
f2e73738
# Contributor: Kiyoshi Aman <kiyoshi.aman+adelie@gmail.com>
# Maintainer: Kiyoshi Aman <kiyoshi.aman+adelie@gmail.com>
pkgname
=
lximage-qt
pkgver
=
0.5.1
pkgrel
=
0
pkgdesc
=
"Image viewer & screenshot tool for LXQt"
url
=
"http://lxqt.org"
arch
=
"all"
license
=
"GPL-2.0+"
depends
=
""
depends_dev
=
""
makedepends
=
"cmake extra-cmake-modules lxqt-build-tools libfm-qt-dev libexif-dev qt5-qtx11extras-dev qt5-qttools-dev qt5-qtsvg-dev kwindowsystem-dev
$depends_dev
"
install
=
""
subpackages
=
""
source
=
"https://github.com/lxde/lximage-qt/releases/download/
$pkgver
/lximage-qt-
$pkgver
.tar.xz
lximage-qt-0.5.1-const-iterator-fix.patch"
builddir
=
"
$srcdir
/lximage-qt-
$pkgver
"
# no tests
options
=
"!check"
build
()
{
cd
"
$builddir
"
if
[
"
$CBUILD
"
!=
"
$CHOST
"
]
;
then
CMAKE_CROSSOPTS
=
"-DCMAKE_SYSTEM_NAME=Linux -DCMAKE_HOST_SYSTEM_NAME=Linux"
fi
cmake
\
-DCMAKE_INSTALL_PREFIX
=
/usr
\
-DCMAKE_INSTALL_LIBDIR
=
lib
\
-DBUILD_SHARED_LIBS
=
True
\
-DCMAKE_BUILD_TYPE
=
RelWithDebugInfo
\
-DCMAKE_CXX_FLAGS
=
"
$CXXFLAGS
"
\
-DCMAKE_C_FLAGS
=
"
$CFLAGS
"
\
-DPULL_TRANSLATIONS
=
False
\
${
CMAKE_CROSSOPTS
}
make
}
check
()
{
cd
"
$builddir
"
CTEST_OUTPUT_ON_FAILURE
=
TRUE ctest
}
package
()
{
cd
"
$builddir
"
make
DESTDIR
=
"
$pkgdir
"
install
}
sha512sums
=
"d74adacfc11dee3795db73f813aabcefb95dcf7f93a51dc4e76a8855aa903218fa36876ac835a9f4ac8b3a640f658e20eee8bda033126919251d7dfd2b4466f9 lximage-qt-0.5.1.tar.xz
62733b0603aa43b8f3d111441ddeea47392c3ae96b967bfd6878ebc3a524bd442acb9e2c5357cafe66e2f082ee15e6e6a4d3e46e2ad15227b33ef08abe2d1a1f lximage-qt-0.5.1-const-iterator-fix.patch"
This diff is collapsed.
Click to expand it.
user/lximage-qt/lximage-qt-0.5.1-const-iterator-fix.patch
0 → 100644
+
24
−
0
View file @
f2e73738
From 988a5f40479c23984853fe485a24d356a91343b8 Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?Lu=C3=ADs=20Pereira?= <luis.artur.pereira@gmail.com>
Date: Tue, 17 Jan 2017 17:39:53 +0000
Subject: [PATCH] Use const iterators
Avoid assignment of a non-const pointer to a const pointer and the
consequent container detach.
---
src/preferencesdialog.cpp | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/src/preferencesdialog.cpp b/src/preferencesdialog.cpp
index 123345c..c35183b 100644
--- a/src/preferencesdialog.cpp
+++ b/src/preferencesdialog.cpp
@@ -111,7 +111,7 @@
void PreferencesDialog::initIconThemes(Settings& settings) {
iconThemes.remove("hicolor"); // remove hicolor, which is only a fallback
QHash<QString, QString>::const_iterator it;
- for(it = iconThemes.begin(); it != iconThemes.end(); ++it) {
+ for(it = iconThemes.constBegin(); it != iconThemes.constEnd(); ++it) {
ui.iconTheme->addItem(it.value(), it.key());
}
ui.iconTheme->model()->sort(0); // sort the list of icon theme names
This diff is collapsed.
Click to expand it.
Preview
0%
Loading
Try again
or
attach a new file
.
Cancel
You are about to add
0
people
to the discussion. Proceed with caution.
Finish editing this message first!
Save comment
Cancel
Please
register
or
sign in
to comment