Skip to content
Snippets Groups Projects
Verified Commit d9a0674e authored by Anna Wilcox's avatar Anna Wilcox :fox:
Browse files

user/plasma-workspace: new package

parent 3ab7801c
No related branches found
No related tags found
No related merge requests found
# Contributor: A. Wilcox <awilfox@adelielinux.org>
# Maintainer: A. Wilcox <awilfox@adelielinux.org>
pkgname=plasma-workspace
pkgver=5.8.7
pkgrel=0
pkgdesc="KDE Plasma 5 workspace"
url="https://www.kde.org/plasma-desktop"
arch="all"
license="LGPL-2.1"
options="!check" # Test requires X11 accelration.
depends=""
depends_dev="qt5-qtbase-dev qt5-qtdeclarative-dev qt5-qtscript-dev kwallet-dev
plasma-framework-dev krunner-dev knotifyconfig-dev knewstuff-dev
kcmutils-dev kdeclarative-dev ktextwidgets-dev kdelibs4support-dev
kcrash-dev kglobalaccel-dev kdbusaddons-dev kitemmodels-dev kdesu-dev
kidletime-dev kwayland-dev kjsembed-dev kxmlrpcclient-dev
libksysguard-dev kpackage-dev baloo-dev kwin-dev libdbusmenu-qt-dev
ktexteditor-dev"
makedepends="$depends_dev cmake extra-cmake-modules kdoctools-dev"
install=""
subpackages="$pkgname-dev $pkgname-doc $pkgname-lang"
source="https://download.kde.org/Attic/plasma/$pkgver/plasma-workspace-$pkgver.tar.xz
plasma-workspace-5.8-cmake-update.patch
plasma-workspace-5.8.7-disable-broken-test.patch
plasma-workspace-5.8-honour-uint.patch"
builddir="$srcdir/plasma-workspace-$pkgver"
build() {
cd "$builddir"
if [ "$CBUILD" != "$CHOST" ]; then
CMAKE_CROSSOPTS="-DCMAKE_SYSTEM_NAME=Linux -DCMAKE_HOST_SYSTEM_NAME=Linux"
fi
cmake \
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_INSTALL_LIBDIR=lib \
-DBUILD_SHARED_LIBS=True \
-DCMAKE_BUILD_TYPE=RelWithDebugInfo \
-DCMAKE_CXX_FLAGS="$CXXFLAGS" \
-DCMAKE_C_FLAGS="$CFLAGS" \
${CMAKE_CROSSOPTS}
make
}
check() {
cd "$builddir"
CTEST_OUTPUT_ON_FAILURE=TRUE ctest
}
package() {
cd "$builddir"
make DESTDIR="$pkgdir" install
}
sha512sums="ba35a050384e0bf410097027bfb70ca7594cd5352fd6470228d537f4e876ec72ec26bac3be9a6750f306b1d2937ff53c267c2246f191c93a13972a0cf33b4faf plasma-workspace-5.8.7.tar.xz
3d7cfb1c7c54bcbca47c5c01497c776d54d1e2327bc0a3777cfaf001f44ec7c1863f15ab0586c00db6d7194f759b91d0a86e47ae99e7fa23782dd7deda264e47 plasma-workspace-5.8-cmake-update.patch
2151dab30716e0b2b6a9146fd6262f4f134884961bebe9cf9baee269f35b1b3955ed07dcee2602b5adc2fc93aa15d37cb72d6983f026a2b504feb451d944d965 plasma-workspace-5.8.7-disable-broken-test.patch
48b4c448a4e964e61f25fa751fbc67f6cfce0e792139a124a70fa5c07f8b1b1a1c51fd5652679a3c46ac997c2dda3df476e8c8ebfdc6a08ece4f2e79282d81a3 plasma-workspace-5.8-honour-uint.patch"
From 052ab380b6cb7f27da19ba0937bc2563b175a19b Mon Sep 17 00:00:00 2001
From: David Faure <faure@kde.org>
Date: Mon, 17 Jul 2017 00:07:47 +0200
Subject: Fix compilation with current cmake (git branch release).
I don't see what the private/ in front of the moc_ filenames was for anyway.
---
shell/containmentconfigview.cpp | 2 +-
shell/currentcontainmentactionsmodel.cpp | 2 +-
2 files changed, 2 insertions(+), 2 deletions(-)
diff --git a/shell/containmentconfigview.cpp b/shell/containmentconfigview.cpp
index 4d107be..8d6df0d 100644
--- a/shell/containmentconfigview.cpp
+++ b/shell/containmentconfigview.cpp
@@ -245,4 +245,4 @@ void ContainmentConfigView::syncWallpaperObjects()
m_currentWallpaperConfig = static_cast<KDeclarative::ConfigPropertyMap *>(wallpaperGraphicsObject->property("configuration").value<QObject *>());
}
-#include "private/moc_containmentconfigview.cpp"
+#include "moc_containmentconfigview.cpp"
diff --git a/shell/currentcontainmentactionsmodel.cpp b/shell/currentcontainmentactionsmodel.cpp
index 08317ed..521d1c9 100644
--- a/shell/currentcontainmentactionsmodel.cpp
+++ b/shell/currentcontainmentactionsmodel.cpp
@@ -275,4 +275,4 @@ void CurrentContainmentActionsModel::save()
}
}
-#include "private/moc_currentcontainmentactionsmodel.cpp"
+#include "moc_currentcontainmentactionsmodel.cpp"
--
cgit v0.11.2
From 2f22f0a935b69f2f2a866050be5b905f9df4e4b6 Mon Sep 17 00:00:00 2001
From: Marco Martin <notmart@gmail.com>
Date: Mon, 20 Mar 2017 16:59:25 +0100
Subject: fix compilation with old gcc
Summary:
gcc 4.8.5 (opensuse leap) fails building modeltest with
CMakeFiles/testHistoryModel.dir/modeltest.cpp.o: In function `ModelTest::data()':
modeltest.cpp:(.text+0x5a57): undefined reference to `bool QTest::qCompare<int, unsigned int>(int const&, unsigned int const&, char const*, char const*, char const*, int)'
Test Plan:
builds fine now
same thing should be done to modeltest usage in kwin
Reviewers: #plasma, davidedmundson
Reviewed By: #plasma, davidedmundson
Subscribers: davidedmundson, plasma-devel
Tags: #plasma
Differential Revision: https://phabricator.kde.org/D5083
---
klipper/autotests/modeltest.cpp | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/klipper/autotests/modeltest.cpp b/klipper/autotests/modeltest.cpp
index d42d95f..d9b70f9 100644
--- a/klipper/autotests/modeltest.cpp
+++ b/klipper/autotests/modeltest.cpp
@@ -453,7 +453,7 @@ void ModelTest::data()
// Check that the alignment is one we know about
QVariant textAlignmentVariant = model->data ( model->index ( 0, 0 ), Qt::TextAlignmentRole );
if ( textAlignmentVariant.isValid() ) {
- int alignment = textAlignmentVariant.toInt();
+ unsigned int alignment = textAlignmentVariant.toUInt();
QCOMPARE( alignment, ( alignment & ( Qt::AlignHorizontal_Mask | Qt::AlignVertical_Mask ) ) );
}
--
cgit v0.11.2
--- plasma-workspace-5.8.7/drkonqi/tests/CMakeLists.txt.old 2017-05-23 07:17:40.000000000 -0500
+++ plasma-workspace-5.8.7/drkonqi/tests/CMakeLists.txt 2017-10-05 18:04:03.428394763 -0500
@@ -1,5 +1,5 @@
add_subdirectory(crashtest)
-add_subdirectory(backtraceparsertest)
+#add_subdirectory(backtraceparsertest)
if(KF5XmlRpcClient_FOUND)
add_subdirectory(bugzillalibtest)
endif()
0% Loading or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment