Skip to content
GitLab
Explore
Sign in
Register
Primary navigation
Search or go to…
Project
Adélie Package Tree
Manage
Activity
Members
Labels
Plan
Issues
Issue boards
Milestones
Wiki
Code
Merge requests
Repository
Branches
Commits
Tags
Repository graph
Compare revisions
Build
Pipelines
Jobs
Pipeline schedules
Artifacts
Help
Help
Support
GitLab documentation
Compare GitLab plans
Community forum
Contribute to GitLab
Provide feedback
Keyboard shortcuts
?
Snippets
Groups
Projects
Show more breadcrumbs
Adélie Linux
Adélie Package Tree
Commits
d83763c8
Verified
Commit
d83763c8
authored
5 years ago
by
Anna Wilcox
Browse files
Options
Downloads
Patches
Plain Diff
system/abuild: support dev and symbols metapackages
parent
6095488c
No related branches found
Branches containing commit
No related tags found
Tags containing commit
No related merge requests found
Changes
2
Hide whitespace changes
Inline
Side-by-side
Showing
2 changed files
system/abuild/APKBUILD
+5
-7
5 additions, 7 deletions
system/abuild/APKBUILD
system/abuild/auto-dev-symbols.patch
+18
-0
18 additions, 0 deletions
system/abuild/auto-dev-symbols.patch
with
23 additions
and
7 deletions
system/abuild/APKBUILD
+
5
−
7
View file @
d83763c8
# Maintainer: A. Wilcox <awilfox@adelielinux.org>
pkgname
=
abuild
pkgver
=
3.3.1
pkgrel
=
2
pkgrel
=
3
pkgdesc
=
"Script to build APK packages"
url
=
"https://code.foxkit.us/adelie/abuild"
arch
=
"all"
options
=
"suid !check"
license
=
"GPL-2.0-only"
depends
=
"fakeroot sudo pax-utils openssl apk-tools>=2.0.7-r1 libc-utils
attr libarchive-tools pkgconf patch lzip"
...
...
@@ -16,10 +17,10 @@ makedepends_host="openssl-dev zlib-dev"
makedepends
=
"
$makedepends_host
$makedepends_build
"
install
=
"
$pkgname
.pre-install
$pkgname
.pre-upgrade"
subpackages
=
"abuild-rootbld:_rootbld:noarch
$pkgname
-doc"
options
=
"suid !check"
pkggroups
=
"abuild"
source
=
"https://distfiles.adelielinux.org/source/abuild-
$pkgver
+adelie.tar.xz
keyhole.patch
auto-dev-symbols.patch
"
builddir
=
"
$srcdir
/
$pkgname
-
$pkgver
+adelie"
...
...
@@ -30,18 +31,14 @@ builddir="$srcdir/$pkgname-$pkgver+adelie"
prepare
()
{
default_prepare
cd
"
$builddir
"
sed
-i
-e
"/^CHOST=/s/=.*/=
$CHOST
/"
abuild.conf
}
build
()
{
cd
"
$builddir
"
make
VERSION
=
"
$pkgver
-r
$pkgrel
"
}
package
()
{
cd
"
$builddir
"
make
install
VERSION
=
"
$pkgver
-r
$pkgrel
"
DESTDIR
=
"
$pkgdir
"
install
-m
644 abuild.conf
"
$pkgdir
"
/etc/abuild.conf
...
...
@@ -60,4 +57,5 @@ _rootbld() {
}
sha512sums
=
"c358f84d198527eeeac1a1aacc101174e18f9f34f692b12a4e4deb6b32d5f3ebdc703c90de6a6f81f195a81eebb90a11f9bfea13ef5db531d9b5d5ae6ecd6a66 abuild-3.3.1+adelie.tar.xz
757d750d4b5c88bf00774b64f2b93a9461e03f284d9423dc58c581e1309f276628de3114fcb510afd7c3cd55ceb721c1278e42756977c97ebe2597207805318d keyhole.patch"
757d750d4b5c88bf00774b64f2b93a9461e03f284d9423dc58c581e1309f276628de3114fcb510afd7c3cd55ceb721c1278e42756977c97ebe2597207805318d keyhole.patch
2aa43539fc465f5abdc7c3d994363b80d1f7494c2d659093e5a2c45056e07617506ad8ea98f0e7d4ebe2596802b76605cd7c9f3ffc5a30c488c30bb36248e3d2 auto-dev-symbols.patch"
This diff is collapsed.
Click to expand it.
system/abuild/auto-dev-symbols.patch
0 → 100644
+
18
−
0
View file @
d83763c8
--- abuild-3.3.1+adelie/abuild.in.old 2019-03-07 00:48:00.110000000 +0000
+++ abuild-3.3.1+adelie/abuild.in 2019-12-20 23:44:19.956669659 +0000
@@ -1651,6 +1651,7 @@
default_dbg() {
local f
pkgdesc="$pkgdesc (debug symbols)"
+ install_if="symbols $pkgname=$pkgver-r$pkgrel"
binfiles=$(scanelf -R "$pkgdir" | grep ET_DYN | sed "s:$pkgdir\/::g" | sed "s:ET_DYN ::g")
for f in $binfiles; do
@@ -1681,6 +1682,7 @@
local i= j=
depends="$depends_dev"
pkgdesc="$pkgdesc (development files)"
+ install_if="dev $pkgname=$pkgver-r$pkgrel"
cd "$pkgdir" || return 0
local libdirs=usr/
This diff is collapsed.
Click to expand it.
Preview
0%
Loading
Try again
or
attach a new file
.
Cancel
You are about to add
0
people
to the discussion. Proceed with caution.
Finish editing this message first!
Save comment
Cancel
Please
register
or
sign in
to comment