Skip to content
Snippets Groups Projects
Commit d7573567 authored by Anna Wilcox's avatar Anna Wilcox :fox:
Browse files

Merge branch 'powerdns-reqs' into 'master'

New packages: user/libgeoip, user/libmaxminddb, user/lua-yaml, user/yaml-cpp

See merge request adelie/packages!403
parents f302f06f a2d344c9
No related branches found
No related tags found
1 merge request!403New packages: user/libgeoip, user/libmaxminddb, user/lua-yaml, user/yaml-cpp
# Contributor: Alyx Wolcott <alyx@leuhta.com>
# Maintainer: Alyx Wolcott <alyx@leuhta.com>
pkgname=libgeoip
pkgver=1.6.12
pkgrel=0
pkgdesc="GeoIP legacy C API"
url="https://github.com/maxmind/geoip-api-c"
arch="all"
license="LGPL-2.1-only"
subpackages="$pkgname-dev $pkgname-doc"
source="https://github.com/maxmind/geoip-api-c/releases/download/v$pkgver/GeoIP-$pkgver.tar.gz"
builddir="$srcdir/GeoIP-$pkgver"
build() {
./configure \
--build=$CBUILD \
--host=$CHOST \
--prefix=/usr \
--sysconfdir=/etc \
--mandir=/usr/share/man \
--localstatedir=/var
make
}
check() {
make check
}
package() {
make DESTDIR="$pkgdir" install
}
sha512sums="a1c8120692a7ba6de5836550917f86f4797dd236a8b7d71b6f92b5389e4b071d89e57036654f5de1d4b762730a2a5c331c31414eab0c889c9befaa097941fee7 GeoIP-1.6.12.tar.gz"
# Contributor: Alyx Wolcott <alyx@leuhta.com>
# Maintainer: Alyx Wolcott <alyx@leuhta.com>
pkgname=libmaxminddb
pkgver=1.4.2
pkgrel=0
pkgdesc="Library for the MaxMind DB file format"
url="http://maxmind.github.io/libmaxminddb/"
arch="all"
license="Apache-2.0"
subpackages="$pkgname-dev $pkgname-doc"
source="https://github.com/maxmind/libmaxminddb/releases/download/$pkgver/$pkgname-$pkgver.tar.gz"
build() {
./configure \
--build=$CBUILD \
--host=$CHOST \
--prefix=/usr \
--sysconfdir=/etc \
--mandir=/usr/share/man \
--localstatedir=/var
make
}
check() {
make check
}
package() {
make DESTDIR="$pkgdir" install
}
sha512sums="bc18d2f19a74639888a466483afde1bccfc3a83787011a6f38808b76e5a513c9912ff369ccbf584091d4def657e0574b16b35dc69ab12ae4c439aaaf3669c4c1 libmaxminddb-1.4.2.tar.gz"
# Contributor: Alyx Wolcott <alyx@leuhta.com>
# Maintainer: Alyx Wolcott <alyx@leuhta.com>
pkgname=lua-yaml
pkgver=6.2.4
pkgrel=0
pkgdesc="LibYAML binding for Lua"
url="https://gvvaughan.github.io/lyaml/"
arch="all"
options="!check" # No tests, sweet.
license="MIT"
depends="lua5.3"
makedepends="lua5.3-dev yaml-dev"
source="$pkgname-$pkgver.tar.gz::https://github.com/gvvaughan/lyaml/archive/v$pkgver.tar.gz"
builddir="$srcdir/lyaml-$pkgver"
build () {
./build-aux/luke PREFOX=$pkgdir/usr VERSION="${pkgver}"
}
package() {
mkdir -p $pkgdir/usr
./build-aux/luke PREFIX=$pkgdir/usr install
}
sha512sums="92dea86a3b1d648093d2134ea4c558432b0861942aa141359d1ca9d7bc55f33a62bb38e12fd653d69139e0a6f0ea6202a9e8c57f750a065d35f0dd674eacaf8a lua-yaml-6.2.4.tar.gz"
# Contributor: Alyx Wolcott <alyx@leuhta.com>
# Maintainer: Alyx Wolcott <alyx@leuhta.com>
pkgname=tinycdb
pkgver=0.78
pkgrel=0
pkgdesc="A constant database"
url="https://www.corpit.ru/mjt/tinycdb.html"
arch="all"
license="Public-Domain"
subpackages="$pkgname-dev $pkgname-doc"
source="https://www.corpit.ru/mjt/tinycdb/$pkgname-$pkgver.tar.gz
Makefile.patch"
build() {
make prefix=/usr sysconfdir=/etc mandir=/usr/share/man localstatedir=/var
}
check() {
make check
}
package() {
make DESTDIR="$pkgdir" install
}
sha512sums="8930086b8e7fddcd4dbd3354c5f5ee05171df68fde1cc222b6c402430042b6e761efbad7e5fa8de18e1d36390f1526cc3e605c5086fe1c363ba1df6c03201553 tinycdb-0.78.tar.gz
199774ee259bd6ba91ec000485c959e9632f2766203c479ffb81144d4cec39b25a1df9e9b3b676217044e2d65275ef80fbc1fd97272bce7a91fe0c1232a5dc40 Makefile.patch"
--- a/Makefile 2012-05-11 14:17:47.000000000 +0000
+++ b/Makefile 2020-02-25 05:56:34.969771664 +0000
@@ -6,14 +6,14 @@
VERSION = 0.78
-prefix=/usr/local
+prefix=/usr
exec_prefix=$(prefix)
bindir=$(exec_prefix)/bin
libdir=$(exec_prefix)/lib
syslibdir=$(libdir)
sysconfdir=/etc
includedir=$(prefix)/include
-mandir=$(prefix)/man
+mandir=$(prefix)/share/man
NSSCDB_DIR = $(sysconfdir)
DESTDIR=
# Contributor: Alyx Wolcott <alyx@leuhta.com>
# Maintainer: Alyx Wolcott <alyx@leuhta.com>
pkgname=yaml-cpp
pkgver=0.6.3
pkgrel=0
pkgdesc="A YAML parser and emitter in C++"
url="https://github.com/jbeder/yaml-cpp"
arch="all"
license="MIT"
makedepends="cmake"
subpackages="$pkgname-dev"
source="$pkgname-$pkgver.tar.gz::https://github.com/jbeder/yaml-cpp/archive/yaml-cpp-$pkgver.tar.gz"
builddir="$srcdir/$pkgname-$pkgname-$pkgver"
build() {
if [ "$CBUILD" != "$CHOST" ]; then
CMAKE_CROSSOPTS="-DCMAKE_SYSTEM_NAME=Linux -DCMAKE_HOST_SYSTEM_NAME=Linux"
fi
cmake \
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_INSTALL_LIBDIR=lib \
-DBUILD_SHARED_LIBS=True \
-DCMAKE_BUILD_TYPE=RelWithDebugInfo \
-DCMAKE_CXX_FLAGS="$CXXFLAGS" \
-DCMAKE_C_FLAGS="$CFLAGS" \
-DYAML_BUILD_SHARED_LIBS=ON \
${CMAKE_CROSSOPTS}
make
}
check() {
CTEST_OUTPUT_ON_FAILURE=TRUE ctest
}
package() {
make DESTDIR="$pkgdir" install
}
sha512sums="68b9ce987cabc1dec79382f922de20cc2c222cb9c090ecb93dc686b048da5c917facf4fce6d8f72feea44b61e5a6770ed3b0c199c4cd4e6bde5b6245c09f8e49 yaml-cpp-0.6.3.tar.gz"
0% Loading or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment