Skip to content
GitLab
Explore
Sign in
Register
Primary navigation
Search or go to…
Project
Adélie Package Tree
Manage
Activity
Members
Labels
Plan
Issues
Issue boards
Milestones
Wiki
Code
Merge requests
Repository
Branches
Commits
Tags
Repository graph
Compare revisions
Build
Pipelines
Jobs
Pipeline schedules
Artifacts
Help
Help
Support
GitLab documentation
Compare GitLab plans
Community forum
Contribute to GitLab
Provide feedback
Keyboard shortcuts
?
Snippets
Groups
Projects
Show more breadcrumbs
Adélie Linux
Adélie Package Tree
Commits
d1794250
Verified
Commit
d1794250
authored
5 years ago
by
Max Rees
Browse files
Options
Downloads
Patches
Plain Diff
user/okular: patch CVE-2020-9359
parent
cebbcb3b
No related branches found
Branches containing commit
No related tags found
Tags containing commit
1 merge request
!411
CVE patches for 2020.03.16
Changes
2
Hide whitespace changes
Inline
Side-by-side
Showing
2 changed files
user/okular/APKBUILD
+8
-2
8 additions, 2 deletions
user/okular/APKBUILD
user/okular/CVE-2020-9359.patch
+27
-0
27 additions, 0 deletions
user/okular/CVE-2020-9359.patch
with
35 additions
and
2 deletions
user/okular/APKBUILD
+
8
−
2
View file @
d1794250
...
...
@@ -2,7 +2,7 @@
# Maintainer: A. Wilcox <awilfox@adelielinux.org>
pkgname
=
okular
pkgver
=
19.12.3
pkgrel
=
0
pkgrel
=
1
pkgdesc
=
"Universal document reader developed by KDE"
url
=
"https://okular.kde.org/"
arch
=
"all"
...
...
@@ -18,8 +18,13 @@ makedepends="cmake extra-cmake-modules qt5-qtbase-dev qt5-qtsvg-dev kconfig-dev
subpackages
=
"
$pkgname
-doc
$pkgname
-lang"
source
=
"https://download.kde.org/stable/release-service/
$pkgver
/src/okular-
$pkgver
.tar.xz
es-doc-fix.patch
CVE-2020-9359.patch
"
# secfixes:
# 19.12.3-r1:
# - CVE-2020-9359
build
()
{
if
[
"
$CBUILD
"
!=
"
$CHOST
"
]
;
then
CMAKE_CROSSOPTS
=
"-DCMAKE_SYSTEM_NAME=Linux -DCMAKE_HOST_SYSTEM_NAME=Linux"
...
...
@@ -45,4 +50,5 @@ package() {
}
sha512sums
=
"ccc3c357fefe04691bba7bc803321789c3a1fdad4cfc610e9c425b2373efd94340fa2ceb2e357569ad14f1c0c69ef0db8079d9bc082a6d5708ccbfb3b65d8b3d okular-19.12.3.tar.xz
de32eabda7ee84c4d894b02c56c7d66d8e2332688c726ad95e1b61c1e730035081ff7721275c7b7a9884aabc268ee0115d9ab8e5f52ae8838e1c09c471c81932 es-doc-fix.patch"
de32eabda7ee84c4d894b02c56c7d66d8e2332688c726ad95e1b61c1e730035081ff7721275c7b7a9884aabc268ee0115d9ab8e5f52ae8838e1c09c471c81932 es-doc-fix.patch
02b27bd206006dbbafbe74e60665ad5159ef6ea32b8bf1526b9c655c046cb6de08630f28d64c9935e73d5707a30d0835f2ab8cd4521740e5236cefc3d3057d29 CVE-2020-9359.patch"
This diff is collapsed.
Click to expand it.
user/okular/CVE-2020-9359.patch
0 → 100644
+
27
−
0
View file @
d1794250
From 6a93a033b4f9248b3cd4d04689b8391df754e244 Mon Sep 17 00:00:00 2001
From: Albert Astals Cid <aacid@kde.org>
Date: Tue, 10 Mar 2020 23:07:24 +0100
Subject: [PATCH] Document::processAction: If the url points to a binary, don't
run it
---
core/document.cpp | 3 ++-
1 file changed, 2 insertions(+), 1 deletion(-)
diff --git a/core/document.cpp b/core/document.cpp
index 3215a1abc..0aa5b6980 100644
--- a/core/document.cpp
+++ b/core/document.cpp
@@ -4388,7 +4388,8 @@
void Document::processAction( const Action * action )
{
const QUrl realUrl = KIO::upUrl(d->m_url).resolved(url);
// KRun autodeletes
- new KRun( realUrl, d->m_widget );
+ KRun *r = new KRun( realUrl, d->m_widget );
+ r->setRunExecutables(false);
}
}
} break;
--
2.25.2
This diff is collapsed.
Click to expand it.
Preview
0%
Loading
Try again
or
attach a new file
.
Cancel
You are about to add
0
people
to the discussion. Proceed with caution.
Finish editing this message first!
Save comment
Cancel
Please
register
or
sign in
to comment