Skip to content
Snippets Groups Projects
Commit c1dbd8de authored by Anna Wilcox's avatar Anna Wilcox :fox:
Browse files

Merge branch 'detoxify' into 'master'

Update some Python packages and drop py3-tox rdeps where unnecessary



See merge request !97
parents 5de1873e d3501fe0
No related branches found
No related tags found
No related merge requests found
# Contributor: Jakub Jirutka <jakub@jirutka.cz>
# Maintainer: Max Rees <maxcrees@me.com>
pkgname=py3-atomicwrites
_pkgname=atomicwrites
pkgver=1.2.1
pkgrel=0
pkgdesc="Powerful Python library for atomic file writes"
url="https://pypi.org/project/atomicwrites/"
arch="noarch"
options="!check" # Cyclic dependency with py3-pytest. Passes on x86_64
# Certified net clean
license="MIT"
depends="python3"
makedepends="python3-dev"
#checkdepends="py3-pytest"
source="$pkgname-$pkgver.tar.gz::https://files.pythonhosted.org/packages/source/a/$_pkgname/$_pkgname-$pkgver.tar.gz"
builddir="$srcdir/$_pkgname-$pkgver"
build() {
cd "$builddir"
python3 setup.py build
}
check() {
cd "$builddir"
PYTHONPATH="$builddir/build/lib:$PYTHONPATH" pytest
}
package() {
cd "$builddir"
python3 setup.py install --prefix=/usr --root="$pkgdir"
}
sha512sums="4df7ee97e0817a80378b273ced310b8ad88eb6ced93a594a6e3dc38ad1e7208226fde01b6d282f85583c57a50859e82c85bacaae8a7c64fce55e6965f74b12c5 py3-atomicwrites-1.2.1.tar.gz"
......@@ -7,11 +7,12 @@ pkgdesc="Python classes without boilerplate"
url="https://www.attrs.org"
arch="noarch"
options="!check" # Circular dependency with py3-pytest. Passes on x86_64
# Certified net clean
license="MIT"
depends="python3"
makedepends="python3-dev"
#checkdepends="py3-tox"
source="py3-attrs-$pkgver.tar.gz::https://github.com/python-attrs/attrs/archive/$pkgver.tar.gz"
#checkdepends="py3-pytest py3-hypothesis py3-six"
source="$pkgname-$pkgver.tar.gz::https://github.com/python-attrs/attrs/archive/$pkgver.tar.gz"
builddir="$srcdir/attrs-$pkgver"
build() {
......@@ -21,7 +22,7 @@ build() {
check() {
cd "$builddir"
tox -e py36
pytest
}
package() {
......
......@@ -7,6 +7,7 @@ pkgrel=0
pkgdesc="Documentation utilities for Python"
url="https://pypi.python.org/pypi/docutils"
arch="noarch"
# Certified net clean
license="Custom"
depends="python3 py3-pillow py3-roman"
makedepends="python3-dev"
......
......@@ -6,12 +6,11 @@ pkgver=4.3.0
pkgrel=0
pkgdesc="More routines for operating on iterables, beyond itertools"
url="https://pypi.org/project/more-itertools"
options="!check" # Circular dependency with py3-pytest. Passes on x86_64
arch="noarch"
# Certified net clean
license="MIT"
depends="python3"
depends="python3 py3-six"
makedepends=""
#checkdepends="py3-tox"
source="$pkgname-$pkgver.tar.gz::https://files.pythonhosted.org/packages/source/m/$_pkgname/$_pkgname-$pkgver.tar.gz"
builddir="$srcdir/$_pkgname-$pkgver"
......@@ -22,7 +21,7 @@ build() {
check() {
cd "$builddir"
tox -e py36
python3 -m unittest discover -v
}
package() {
......
......@@ -2,16 +2,15 @@
# Maintainer: Max Rees <maxcrees@me.com>
pkgname=py3-olefile
_pkgname=olefile
pkgver=0.45.1
pkgver=0.46
pkgrel=0
pkgdesc="A Python module to read/write MS OLE2 files"
url="https://pypi.python.org/project/olefile"
url="https://pypi.org/project/olefile"
arch="noarch"
license="BSD-2-Clause Custom"
# Certified net clean
license="BSD-2-Clause AND Custom"
depends="python3"
makedepends="python3-dev unzip"
install=""
giturl="https://github.com/decalage2/olefile"
source="$pkgname-$pkgver.zip::https://files.pythonhosted.org/packages/source/o/$_pkgname/$_pkgname-$pkgver.zip"
builddir="$srcdir/$_pkgname-$pkgver"
......@@ -31,4 +30,4 @@ package() {
install -Dm644 LICENSE.txt "$pkgdir/usr/share/licenses/$pkgname/LICENSE.txt"
}
sha512sums="31f7584553304b186aad88f1988dfa12ceb34a50d546a38181280a816cfcda8dc54ff502afb31a928d647e6106c9e4878bfac8cec31d24018fdbab65c7007e49 py3-olefile-0.45.1.zip"
sha512sums="2a19c443c1e4519680027ff557b5f737e6d0e707c1932a759ea85105717f4f6393149e0eb04589fe2b2b7e0c474042cfe34801faad38517799483b711001b4ac py3-olefile-0.46.zip"
......@@ -2,18 +2,19 @@
# Maintainer: Max Rees <maxcrees@me.com>
pkgname=py3-pillow
_pkgname=Pillow
pkgver=5.1.0
pkgver=5.3.0
pkgrel=0
pkgdesc="A Python Imaging Library"
url="https://pypi.python.org/project/Pillow"
url="https://pypi.org/project/Pillow"
arch="all"
# Certified net clean
license="Custom"
depends="py3-olefile python3"
makedepends="python3-dev freetype-dev libjpeg-turbo-dev libwebp-dev
tiff-dev libpng-dev lcms2-dev openjpeg-dev zlib-dev"
subpackages="$pkgname-doc"
_scripts_rev="f578e2c"
source="$pkgname-$pkgver.tar.gz::https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz
source="$pkgname-$pkgver.tar.gz::https://files.pythonhosted.org/packages/source/P/$_pkgname/$_pkgname-$pkgver.tar.gz
$pkgname-scripts-$_scripts_rev.tar.gz::https://github.com/python-pillow/pillow-scripts/archive/$_scripts_rev.tar.gz"
builddir="$srcdir/$_pkgname-$pkgver"
......@@ -50,5 +51,5 @@ doc() {
install -Dm644 LICENSE "$subpkgdir/usr/share/licenses/$pkgname/LICENSE"
}
sha512sums="1e1d5f12054e2f3befa8dafef2551eb75dfefc06944a528638a1686ebc480b52edfc3eaa9964d687816caf003314ad1fc4891d7379cd92e41fbf4b3cbddd1cb9 py3-pillow-5.1.0.tar.gz
sha512sums="0596207069a87a645f7694b19ea5100d753dbb7553148fa5982b073e4e1163b5bd83ddf8b1c783a90a0b718576f08d3f15352f2742d46a425cf639de2409c4ab py3-pillow-5.3.0.tar.gz
1a2e6dc45127b3f0b706d5be4fdc8ddeb09a9e046a182eb48239572e1bdc62d1b1f1a1f11ef1f1f23766aaac1b498556cc9a9cf11d3b943c9f2834c9b41612e0 py3-pillow-scripts-f578e2c.tar.gz"
......@@ -2,17 +2,19 @@
# Maintainer: Max Rees <maxcrees@me.com>
pkgname=py3-pluggy
_pkgname=pluggy
pkgver=0.6.0
pkgver=0.7.1
pkgrel=0
pkgdesc="Plugin management and hook calling for Python"
url="https://pypi.python.org/pypi/pluggy"
arch="noarch"
options="!check" # Cyclic dependency with py3-tox. Passes on x86_64
options="!check" # Cyclic dependency with py3-pytest. Passes on x86_64
# Certified net clean
license="MIT"
depends="python3"
makedepends="python3-dev"
#checkdepends="py3-tox"
source="$pkgname-$pkgver.tar.gz::https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
#checkdepends="py3-pytest"
source="$pkgname-$pkgver.tar.gz::https://files.pythonhosted.org/packages/source/p/$_pkgname/$_pkgname-$pkgver.tar.gz
scm.patch"
builddir="$srcdir/$_pkgname-$pkgver"
build() {
......@@ -22,7 +24,7 @@ build() {
check() {
cd "$builddir"
tox -e py36-pytestrelease
PYTHONPATH="$builddir/build/lib:$PYTHONPATH" pytest testing
}
package() {
......@@ -30,4 +32,5 @@ package() {
python3 setup.py install --prefix=/usr --root="$pkgdir"
}
sha512sums="dd58dabe2e65eee64d62c8748c2bbd99457288e99b819eb12312f2acdb0740ac46fd08f83522bc992297b9f14eec14c216c2c9688580f68393bf6fc609e65812 py3-pluggy-0.6.0.tar.gz"
sha512sums="e19f6c1b3f2e711df1c8b075a2b802751afd218f1b692f08b2434c01d71c402331ff8c937550fbdfece2098f6d6856422d485f193e188916b365ded2e4087697 py3-pluggy-0.7.1.tar.gz
6b805de27cf1255e0279e076fbcb94ef0494ab0d8bc73999ab45afdb026108d249b730932e28b723b9a0d63aba1746da6e72901cebb9ab6bd91ea3b5e9e64d3b scm.patch"
--- pluggy-0.7.1/setup.py 2018-07-28 22:45:12.000000000 +0000
+++ pluggy-0.7.1/setup.py 2018-10-11 04:54:18.590233336 +0000
@@ -24,10 +24,7 @@
name='pluggy',
description='plugin and hook calling mechanisms for python',
long_description=long_description,
- use_scm_version={
- 'write_to': 'pluggy/_version.py',
- },
- setup_requires=['setuptools-scm'],
+ version='0.7.1',
license='MIT license',
platforms=['unix', 'linux', 'osx', 'win32'],
author='Holger Krekel',
......@@ -2,17 +2,19 @@
# Maintainer: Max Rees <maxcrees@me.com>
pkgname=py3-py
_pkgname=py
pkgver=1.5.3
pkgver=1.7.0
pkgrel=0
pkgdesc="A python library with cross-python path, ini-parsing, io, code, log facilities"
url="https://pypi.python.org/project/py"
arch="noarch"
options="!check" # Circular dependency with py3-tox. Passes on x86_64
options="!checkroot !check" # Circular dependency with py3-pytest. Passes on x86_64
# Certified net clean
license="MIT"
depends="python3"
makedepends="python3-dev"
#checkdepends="py3-tox"
source="$pkgname-$pkgver.tar.gz::https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
#checkdepends="py3-pytest"
source="$pkgname-$pkgver.tar.gz::https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz
scm.patch"
builddir="$srcdir/$_pkgname-$pkgver"
build() {
......@@ -21,10 +23,8 @@ build() {
}
check() {
# Can't use py3-pytest > 3.0 as of py3-py==1.5.3-r0 because some tests
# haven't been updated yet
cd "$builddir"
tox -e py36-pytest30
PYTHONPATH="$builddir/build/lib:$PYTHONPATH" pytest
}
package() {
......@@ -32,4 +32,5 @@ package() {
python3 setup.py install --prefix=/usr --root="$pkgdir"
}
sha512sums="243c0da94c439163257c525ef00b30fd6d8add5897121ee0b1f19476b50f18823ce2b99a5ab27a9cf47598b538758d0534060123dce0820d2a65d98046548c96 py3-py-1.5.3.tar.gz"
sha512sums="c522be926c5716d866cb800eaa398a55518889da207a00575212254642eda2107e68c286e72b99cf94ecec1c8dcde1f763e2d8f296ab7e7673ae2671e70d5548 py3-py-1.7.0.tar.gz
08a1645832d46ffab5b1fb2e7ef480c55a0d4ac266d53857d9ddae5c46ba11232b04bc0cb035bb9e3d08f9d439e844a623340882080555206811fe0624c61bc1 scm.patch"
--- py-1.7.0/setup.py 2018-08-27 20:39:51.000000000 +0000
+++ py-1.7.0/setup.py 2018-10-11 05:07:12.560247181 +0000
@@ -6,8 +6,7 @@ def main():
name='py',
description='library with cross-python path, ini-parsing, io, code, log facilities',
long_description=open('README.rst').read(),
- use_scm_version={"write_to": "py/_version.py"},
- setup_requires=["setuptools-scm"],
+ version='1.7.0',
url='http://py.readthedocs.io/',
license='MIT license',
platforms=['unix', 'linux', 'osx', 'cygwin', 'win32'],
......@@ -2,17 +2,20 @@
# Maintainer: Max Rees <maxcrees@me.com>
pkgname=py3-pytest
_pkgname=pytest
pkgver=3.5.1
pkgrel=1
pkgver=3.9.1
pkgrel=0
pkgdesc="A python test library"
url="https://pypi.python.org/pypi/pytest"
arch="noarch"
options="net !check" # Circular dependency with py3-tox. Passes on x86_64
options="!checkroot !check" # Cyclic dependency with itself. Passes on x86_64
# Certified net clean
license="MIT"
depends="python3 py3-py py3-more-itertools py3-six py3-pluggy py3-attrs"
depends="python3 py3-atomicwrites py3-attrs py3-more-itertools
py3-pluggy py3-py py3-six"
makedepends="python3-dev"
#checkdepends="py3-tox"
source="$pkgname-$pkgver.tar.gz::https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
#checkdepends="py3-pytest py3-hypothesis"
source="$pkgname-$pkgver.tar.gz::https://files.pythonhosted.org/packages/source/p/$_pkgname/$_pkgname-$pkgver.tar.gz
scm.patch"
builddir="$srcdir/$_pkgname-$pkgver"
build() {
......@@ -22,7 +25,8 @@ build() {
check() {
cd "$builddir"
tox -e py36
# You would think you could get away with "python3 -m pytest" but no...
PYTHONPATH="$builddir/build/lib:$PYTHONPATH" pytest
}
package() {
......@@ -30,4 +34,5 @@ package() {
python3 setup.py install --prefix=/usr --root="$pkgdir"
}
sha512sums="5f54251b197b4bebadb06536054b4f79e16c5cec2cdfd7d95fd74548b8ecfaddaafeb635eb90d085fe4d4bea1108f951fe500d0e548cc8b797b0d23e0c2693a0 py3-pytest-3.5.1.tar.gz"
sha512sums="0a3a6842fb549c8223f0ddf56ca28eb200a21a4cadf382fbcd2ab930c58d57c55c77d5869e84bd79bf611d959cba6d363ace3b5fd33d5ce44259fd580b1a9369 py3-pytest-3.9.1.tar.gz
7fc2cd75f55caa661fb4bed578955511ee38cd28a25fcb405c29eb7227a382c33c0fc52a4eeb8950315793dfc0eb02235b140415deebd113f24df1a320b25959 scm.patch"
--- pytest-3.9.1/setup.py 2018-10-16 15:46:37.000000000 -0400
+++ pytest-3.9.1/setup.py 2018-10-22 19:32:49.261592294 -0400
@@ -25,8 +25,8 @@ if "_PYTEST_SETUP_SKIP_PLUGGY_DEP" not i
def main():
setup(
- use_scm_version={"write_to": "src/_pytest/_version.py"},
- setup_requires=["setuptools-scm", "setuptools>=30.3"],
+ setup_requires=["setuptools>=30.3"],
+ version="3.9.1",
package_dir={"": "src"},
install_requires=INSTALL_REQUIRES,
)
......@@ -2,17 +2,16 @@
# Maintainer: Max Rees <maxcrees@me.com>
pkgname=py3-roman
_pkgname=roman
pkgver=2.0.0
pkgrel=2
pkgver=3.0
pkgrel=0
pkgdesc="Python library to convert integers to Roman numerals"
url="http://pypi.python.org/pypi/roman"
url="https://pypi.org/project/roman/"
arch="noarch"
# Certified net clean
license="Python-2.1.1" # not SPDX
depends="python3"
makedepends="python3-dev unzip"
checkdepends="py3-tox"
source="$pkgname-$pkgver.zip::https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.zip
py36.patch"
makedepends="python3-dev"
source="$pkgname-$pkgver.tar.gz::https://files.pythonhosted.org/packages/source/r/$_pkgname/$_pkgname-$pkgver.tar.gz"
builddir="$srcdir/$_pkgname-$pkgver"
build() {
......@@ -23,7 +22,7 @@ build() {
check() {
cd "$builddir"
tox -e py36
python3 setup.py test
}
package() {
......@@ -31,5 +30,4 @@ package() {
python3 setup.py install --prefix=/usr --root="$pkgdir"
}
sha512sums="d62a95e835232821dbf7a81d0c6b7df63f18c4116cfc7eee0c691a0b31d3d7b69d2dc2e4ea26e0a169a8e24bf080e8bb1e195b853be4adf1491335a5b4d5702c py3-roman-2.0.0.zip
8f6bfe0f7259db6091b71c8744592de34ca305a30b5ac44cb366fd3e71ebbead21b892939a15b19cd0e344445f981f16ae493bb70ade171b2ba1d92daa431931 py36.patch"
sha512sums="468a4ac7188cdf3155698f260de5ecc5bb2072c120c79d046618ac07b6de6f777cfc69661f2e0df4ca66359bb20169d22599b3f342edaa48f8575bdc17b40c08 py3-roman-3.0.tar.gz"
--- roman-2.0.0/tox.ini 2013-02-25 10:15:52.000000000 +0000
+++ roman-2.0.0/tox.ini 2018-01-11 02:04:11.950000000 +0000
@@ -1,6 +1,6 @@
[tox]
envlist =
- py26,py27,py33,pypy
+ py26,py27,py33,pypy,py36
[testenv]
commands =
......@@ -7,12 +7,13 @@ pkgrel=0
pkgdesc="Virtual Python Environment builder"
url="https://pypi.org/project/virtualenv"
arch="noarch"
options="net"
license="MIT"
depends="python3"
makedepends="python3-dev"
checkdepends="py3-pytest cmd:which"
source="$pkgname-$pkgver.tar.gz::https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz
test-python3.patch"
source="$pkgname-$pkgver.tar.gz::https://files.pythonhosted.org/packages/source/v/$_pkgname/$_pkgname-$pkgver.tar.gz
test-python3.6.patch"
builddir="$srcdir/$_pkgname-$pkgver"
build() {
......@@ -34,4 +35,4 @@ package() {
}
sha512sums="43bc37f1da1b65e9a2df5a8813a801f27f5783b7211219d441d1c2132789917df42fdc0aba1d5ec51e3d6f7583af9474d59c1f532d8880c8c325ccc96e73b3df py3-virtualenv-16.0.0.tar.gz
8e022416eb10289fd5215f3810203eefb450ce2fca7bdc581b5cd1892f41f34815beec35fc6c744991536c1f2edebd58ab934a4414c6fe2ae6387aea02787ef8 test-python3.patch"
9c68dcda515dfc974433c9a68d81be0b028a7967eebb1b6d1d912c3859c7925fe970f1668ac9e406768de91ed32b27b3b8ea7a4939f8adc7a09e1bf904df10b9 test-python3.6.patch"
......@@ -72,3 +72,25 @@
import os, sys
expected_site_packages = os.path.join(os.environ['TESTENV'], 'lib','python%s' % sys.version[:3], 'site-packages')
--- virtualenv-16.0.0/setup.py 2018-05-16 19:36:07.000000000 -0400
+++ virtualenv-16.0.0/setup.py 2018-10-22 20:56:04.691681656 -0400
@@ -33,7 +33,7 @@ try:
},
'zip_safe': False,
'cmdclass': {'test': PyTest},
- 'tests_require': ['pytest', 'mock'],
+ 'tests_require': ['pytest'],
}
except ImportError:
from distutils.core import setup
--- virtualenv-16.0.0/tests/test_virtualenv.py 2018-05-16 19:36:07.000000000 -0400
+++ virtualenv-16.0.0/tests/test_virtualenv.py 2018-10-22 20:56:38.771682266 -0400
@@ -7,7 +7,7 @@ import tempfile
import pytest
import platform # noqa
-from mock import patch, Mock
+from unittest.mock import patch, Mock
def test_version():
0% Loading or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment