Skip to content
Snippets Groups Projects
Verified Commit b1eb5059 authored by Anna Wilcox's avatar Anna Wilcox :fox:
Browse files

The New Plan

all pkgs needed to bootstrap -> system
others -> user
parent b9e85bbd
No related branches found
No related tags found
No related merge requests found
Showing
with 859 additions and 0 deletions
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=acl
pkgver=2.2.52
pkgrel=4
pkgdesc="Access control list utilities"
url="https://savannah.nongnu.org/projects/acl"
arch="all"
license="LGPL-2.1-or-later AND GPL-2.0-or-later"
depends=""
makedepends_build="gzip"
makedepends_host="attr-dev"
makedepends="$makedepends_build $makedepends_host"
subpackages="$pkgname-dev $pkgname-doc libacl"
# depends on order of nftw, and requires test machine to have ACLs enabled on FS
options="!check"
source="http://download.savannah.nongnu.org/releases/acl/acl-$pkgver.src.tar.gz"
prepare() {
cd "$builddir"
default_prepare
update_config_sub
sed -i \
-e '/^as_dummy=/s:=":="$PATH$PATH_SEPARATOR:' \
configure # hack PATH with AC_PATH_PROG
sed -i \
-e "/^PKG_DOC_DIR/s:@pkg_name@:$pkgname:" \
-e '/HAVE_ZIPPED_MANPAGES/s:=.*:=false:' \
include/builddefs.in
}
build() {
cd "$builddir"
unset PLATFORM
export OPTIMIZER="${CFLAGS}"
export DEBUG=-DNDEBUG
CONFIG_SHELL=/bin/sh ./configure \
--build=$CBUILD \
--host=$CHOST \
--prefix=/usr \
--libdir=/lib \
--libexecdir=/usr/lib \
--disable-gettext
make
}
package() {
cd "$builddir"
make DIST_ROOT="$pkgdir" install install-lib install-dev
chown -R root:root "$pkgdir"/*
}
libacl() {
pkgdesc="Dynamic library for access control list support"
mkdir -p "$subpkgdir"/lib
mv "$pkgdir"/lib/libacl.so.* "$subpkgdir"/lib/
}
sha512sums="59973199d371cd0b2368e95bc829a1b47f04e808a174fefba4c6854e766158bd19a71d9dbcc8d6fdc1573a1f971cdda39c453f7fa243bce02c1ab97c6e7c72e7 acl-2.2.52.src.tar.gz"
...@@ -37,6 +37,9 @@ build() { ...@@ -37,6 +37,9 @@ build() {
print($1 pw ":0:::::") print($1 pw ":0:::::")
}' "$srcdir"/passwd > "$builddir"/tree/etc/shadow }' "$srcdir"/passwd > "$builddir"/tree/etc/shadow
chmod 640 "$builddir"/tree/etc/shadow chmod 640 "$builddir"/tree/etc/shadow
rm "$builddir"/tree/dev/.dirkeep
rm "$builddir"/tree/proc/.dirkeep
rm "$builddir"/tree/sys/.dirkeep
} }
package() { package() {
......
From 0dcbd933c8d3d305395a99b7b1690a187ce5ec8c Mon Sep 17 00:00:00 2001
From: William Pitcock <nenolod@dereferenced.org>
Date: Wed, 21 Feb 2018 15:35:53 +0000
Subject: [PATCH] solver: allow names with only one provider to be autoselected
regardless of priority
---
src/solver.c | 5 +++--
test/provides.repo | 9 ++++++++-
2 files changed, 11 insertions(+), 3 deletions(-)
diff --git a/src/solver.c b/src/solver.c
index 91e5958..d27a7a3 100644
--- a/src/solver.c
+++ b/src/solver.c
@@ -671,11 +671,12 @@ static void select_package(struct apk_solver_state *ss, struct apk_name *name)
(!p->pkg->ss.iif_triggered ||
!p->pkg->ss.tag_ok))
continue;
- /* Virtual packages without provider_priority cannot be autoselected */
+ /* Virtual packages without provider_priority cannot be autoselected,
+ * unless there is only one provider */
if (p->version == &apk_null_blob &&
p->pkg->name->auto_select_virtual == 0 &&
p->pkg->name->ss.requirers == 0 &&
- p->pkg->provider_priority == 0)
+ (p->pkg->provider_priority == 0 && name->providers->num > 1))
continue;
if (compare_providers(ss, p, &chosen) > 0)
chosen = *p;
diff --git a/test/provides.repo b/test/provides.repo
index 58bd416..358151e 100644
--- a/test/provides.repo
+++ b/test/provides.repo
@@ -82,7 +82,7 @@ P:conflicted-provider-b
V:0.1
S:1
I:1
-p:conflicted-provider
+p:conflicted-provider conflicted-provider-2
C:Q1EyN5AdpAOBJWKMR89ppC66ccccj=
P:conflicted-dep
@@ -104,3 +104,10 @@ V:0.1
S:1
I:1
p:self-provide
+
+C:Q1EyN5AdpAOBJWKMR89ppC66eeeej=
+P:conflicted-dep-2
+V:0.1
+S:1
+I:1
+D:conflicted-provider-2
--
2.16.1
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=apk-tools
pkgver=2.9.1
pkgrel=1
pkgdesc="Alpine Package Keeper - package manager for alpine"
subpackages="$pkgname-static"
depends=
makedepends_build=""
makedepends_host="zlib-dev libressl libressl-dev linux-headers"
makedepends="$makedepends_build $makedepends_host"
if [ "$CBUILD" = "$CHOST" ]; then
subpackages="$subpackages lua5.2-apk:luaapk"
makedepends="$makedepends lua5.2-dev"
fi
source="http://dev.alpinelinux.org/archive/$pkgname/$pkgname-$pkgver.tar.xz
0001-solver-allow-names-with-only-one-provider-to-be-auto.patch
openssl-compat.patch
"
url="https://git.alpinelinux.org/cgit/apk-tools/"
arch="all"
license=GPL2
builddir="$srcdir/$pkgname-$pkgver"
prepare() {
default_prepare || return 1
cd "$builddir"
sed -i -e 's:-Werror::' Make.rules
echo "FULL_VERSION=$pkgver-r$pkgrel" > config.mk || return 1
if [ "$CBUILD" = "$CHOST" ]; then
echo "LUAAPK=YesPlease" >> config.mk
else
echo "LUAAPK=" >> config.mk
fi
echo "export LUAAPK" >> config.mk
}
build() {
cd "$builddir"
make || return 1
make static || return 1
}
check() {
cd "$builddir"
make check
}
package() {
cd "$builddir"
make DESTDIR="$pkgdir" install
install -d "$pkgdir"/var/lib/apk \
"$pkgdir"/var/cache/misc \
"$pkgdir"/etc/apk/keys \
"$pkgdir"/etc/apk/protected_paths.d \
|| return 1
# the shipped README is empty
rm -r "$pkgdir"/usr/share/
}
static() {
pkgdesc="Alpine Package Keeper - static binary"
install -Dm755 "$srcdir"/$pkgname-$pkgver/src/apk.static \
"$subpkgdir"/sbin/apk.static
# lets sign the static binary so it can be vefified from distros
# that does not have apk-tools
local abuild_conf=${ABUILD_CONF:-"/etc/abuild.conf"}
local abuild_home=${ABUILD_USERDIR:-"$HOME/.abuild"}
local abuild_userconf=${ABUILD_USERCONF:-"$abuild_home/abuild.conf"}
[ -f "$abuild_userconf" ] && . "$abuild_userconf"
local privkey="$PACKAGER_PRIVKEY"
local pubkey=${PACKAGER_PUBKEY:-"${privkey}.pub"}
local keyname=${pubkey##*/}
${CROSS_COMPILE}strip "$subpkgdir"/sbin/apk.static
openssl dgst -sha1 -sign "$privkey" \
-out "$subpkgdir"/sbin/apk.static.SIGN.RSA.$keyname \
"$subpkgdir"/sbin/apk.static || return 1
}
luaapk() {
pkgdesc="Lua module for apk-tools"
mkdir -p "$subpkgdir"/usr/
mv "$pkgdir"/usr/lib "$subpkgdir"/usr/lib/
}
sha512sums="4ffb8d1716bbb94421b1cc4277beb47d369c429f4c3bf597d08949abb7586d30c4504edf2f775bea3b93614a280c12391b956ca8f914fb0ec27799a4a005a145 apk-tools-2.9.1.tar.xz
5ca2d2f2646032ed8f9f86357e986b054045a80ddb944be6a540566ff7092f38591ec8dfc7ac06b9daededa95e86c0e892ead55f9e8907eb318aed76644f7f97 0001-solver-allow-names-with-only-one-provider-to-be-auto.patch
5640b746cd3c6d966d5f778ffe2307902503b1fc966bedb35b50dedee34ec3d5fe2c7f200dfd3893d6640150ff6dd4efd2df9aa110b4a7fd162b84904dacb493 openssl-compat.patch"
--- apk-tools-2.8.1/libfetch/common.c.old 2017-10-27 08:12:05.000000000 -0500
+++ apk-tools-2.8.1/libfetch/common.c 2017-11-11 22:37:18.661697875 -0600
@@ -504,7 +504,7 @@
SSL_load_error_strings();
- conn->ssl_meth = TLS_client_method();
+ conn->ssl_meth = SSLv23_client_method();
conn->ssl_ctx = SSL_CTX_new(conn->ssl_meth);
SSL_CTX_set_mode(conn->ssl_ctx, SSL_MODE_AUTO_RETRY);
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=automake
pkgver=1.15.1
pkgrel=1
pkgdesc="A GNU tool for automatically creating Makefiles"
url="https://www.gnu.org/software/automake"
arch="noarch"
license="GPL-2.0-or-later MIT Public-Domain"
depends="perl"
makedepends="autoconf"
checkdepends="bash gzip coreutils diffutils"
subpackages="$pkgname-doc"
source="ftp://ftp.gnu.org/gnu/$pkgname/$pkgname-$pkgver.tar.gz"
builddir="$srcdir/$pkgname-$pkgver"
# many tests have bashisms
options="!check"
build() {
cd "$builddir"
./configure \
--build=$CBUILD \
--host=$CHOST \
--prefix=/usr
make
}
check() {
cd "$builddir"
make check
}
package() {
cd "$builddir"
make DESTDIR=$pkgdir install
}
sha512sums="f0d4717ebe2c76cec5d487de090f6e1c0f784b0d382fd964ffa846287e2a364a52531a26ab98b7033ac04ed302a247b3b114299def54819a03439bfc962ff61b automake-1.15.1.tar.gz"
# Contributor: Łukasz Jendrysik <scadu@yandex.com>
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=bison
pkgver=3.0.4
pkgrel=1
pkgdesc="The GNU general-purpose parser generator"
arch="all"
license="GPL-3.0-or-later"
url="https://www.gnu.org/software/bison/bison.html"
makedepends="perl"
depends="m4"
checkdepends="bison flex"
[ -n "$BOOTSTRAP" ] && options="!check"
source="ftp://ftp.gnu.org/gnu/bison/${pkgname}-${pkgver}.tar.xz"
subpackages="$pkgname-doc"
build() {
cd "$builddir"
./configure \
--build=$CBUILD \
--host=$CHOST \
--prefix=/usr \
--datadir=/usr/share \
--infodir=/usr/share/info \
--mandir=/usr/share/man
make
}
check() {
cd "$builddir"
make check
}
package() {
cd "$builddir"
make DESTDIR="$pkgdir" install
rm -rf "$pkgdir"/usr/lib/charset.alias
rmdir -p "$pkgdir"/usr/lib 2>/dev/null || true
}
sha512sums="bbdc23e7772e49da1c7c47e66d4e4efbfbfe9b21dbc59bf3ad9a6e573eecac6c9f52c7f11a64be9897e8deb99ef7ba015164aa8232aa391b901dd7db03632412 bison-3.0.4.tar.xz"
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=bzip2
pkgver=1.0.6
pkgrel=6
pkgdesc="A high-quality data compression program"
url="http://sources.redhat.com/bzip2"
arch="all"
license="BSD"
depends=""
subpackages="$pkgname-dev $pkgname-doc libbz2"
source="http://www.bzip.org/$pkgver/$pkgname-$pkgver.tar.gz
bzip2-1.0.4-makefile-CFLAGS.patch
bzip2-1.0.6-saneso.patch
bzip2-1.0.4-man-links.patch
bzip2-1.0.2-progress.patch
bzip2-1.0.3-no-test.patch
bzip2-1.0.4-POSIX-shell.patch
CVE-2016-3189.patch
"
# secfixes:
# 1.0.6-r5:
# - CVE-2016-3189
builddir="$srcdir"/$pkgname-$pkgver
prepare() {
default_prepare
# Fix man path
# Generate relative symlinks
sed -i \
-e 's:\$(PREFIX)/man:\$(PREFIX)/share/man:g' \
-e 's:ln -s -f $(PREFIX)/bin/:ln -s :' \
Makefile
# fixup broken version stuff
sed -i \
-e "s:1\.0\.4:$pkgver:" \
bzip2.1 bzip2.txt Makefile-libbz2_so manual.*
}
build () {
cd "$builddir"
make -f Makefile-libbz2_so all
make all
}
check() {
cd "$builddir"
make check
}
package() {
cd "$builddir"
make PREFIX="$pkgdir"/usr install
install -D libbz2.so.$pkgver "$pkgdir"/usr/lib/libbz2.so.$pkgver
ln -s libbz2.so.$pkgver "$pkgdir"/usr/lib/libbz2.so
ln -s libbz2.so.$pkgver "$pkgdir"/usr/lib/libbz2.so.${pkgver%%.*}
}
libbz2() {
pkgdesc="Shared library for bz2"
mkdir -p "$subpkgdir"/usr/lib
mv "$pkgdir"/usr/lib/*.so.* "$subpkgdir"/usr/lib/
}
sha512sums="00ace5438cfa0c577e5f578d8a808613187eff5217c35164ffe044fbafdfec9e98f4192c02a7d67e01e5a5ccced630583ad1003c37697219b0f147343a3fdd12 bzip2-1.0.6.tar.gz
58cc37430555520b6e35db2740e699cf37eacdd82989c21a222a593e36288710a0defb003662d4238235c12b3764bfc89cd646e6be9d0a08d54bd2c9baa6ad15 bzip2-1.0.4-makefile-CFLAGS.patch
8a7528b5b931bb72f637c6940bc811d54fb816fd5bb453af56d9b4a87091004eb5e191ba799d972794b24c56cf8134344a618b58946d3f1d985c508f88190845 bzip2-1.0.6-saneso.patch
2d9a306bc0f552a58916ebc702d32350a225103c487e070d2082121a54e07f1813d3228f43293cc80a4bee62053fd597294c99a1751b1685cd678f4e5c6a2fe7 bzip2-1.0.4-man-links.patch
b6810c73428f17245e0d7c2decd00c88986cd8ad1cfe4982defe34bdab808d53870ed92cb513b2d00c15301747ceb6ca958fb0e0458d0663b7d8f7c524f7ba4e bzip2-1.0.2-progress.patch
aefcafaaadc7f19b20fe023e0bd161127b9f32e0cd364621f6e5c03e95fb976e7e69e354ec46673a554392519532a3bfe56d982a5cde608c10e0b18c3847a030 bzip2-1.0.3-no-test.patch
64ab461bf739c29615383750e7f260abb2d49df7eb23916940d512bd61fd9a37aaade4d8f6f94280c95fc781b8f92587ad4f3dda51e87dec7a92a7a6f8d8ae86 bzip2-1.0.4-POSIX-shell.patch
cef6f448b661a775cc433f9636730e89c1285d07075536217657056be56e0a11e96f41f7c14f6ec59e235464b9ddd649a71fb8de1c60eda2fd5c2cdfbb6a8fdc CVE-2016-3189.patch"
diff --git a/bzip2recover.c b/bzip2recover.c
index f9de049..d159c92 100644
--- a/bzip2recover.c
+++ b/bzip2recover.c
@@ -457,6 +457,7 @@ Int32 main ( Int32 argc, Char** argv )
bsPutUChar ( bsWr, 0x50 ); bsPutUChar ( bsWr, 0x90 );
bsPutUInt32 ( bsWr, blockCRC );
bsClose ( bsWr );
+ outFile = NULL;
}
if (wrBlock >= rbCtr) break;
wrBlock++;
Ripped from Mandrake.
http://bugs.gentoo.org/show_bug.cgi?id=82192
--- bzip2-1.0.2.org/bzip2.1
+++ bzip2-1.0.2/bzip2.1
@@ -235,6 +235,10 @@
Suppress non-essential warning messages. Messages pertaining to
I/O errors and other critical events will not be suppressed.
.TP
+.B \-p --show-progress
+Show percentage of input-file done and while compressing show the percentage
+of the original file the new file is.
+.TP
.B \-v --verbose
Verbose mode -- show the compression ratio for each file processed.
Further \-v's increase the verbosity level, spewing out lots of
--- bzip2-1.0.2.org/bzip2.c
+++ bzip2-1.0.2/bzip2.c
@@ -145,6 +145,7 @@
#include <signal.h>
#include <math.h>
#include <errno.h>
+#include <time.h>
#include <ctype.h>
#include "bzlib.h"
@@ -301,6 +302,7 @@
Char progNameReally[FILE_NAME_LEN];
FILE *outputHandleJustInCase;
Int32 workFactor;
+Char showProgress;
static void panic ( Char* ) NORETURN;
static void ioError ( void ) NORETURN;
@@ -425,6 +427,12 @@
UInt32 nbytes_in_lo32, nbytes_in_hi32;
UInt32 nbytes_out_lo32, nbytes_out_hi32;
Int32 bzerr, bzerr_dummy, ret;
+ double fileSize = 0; /* initialized to make the compiler stop crying */
+ /* double because big files might otherwhise give
+ * overflows. not long long since not all compilers
+ * support that one
+ */
+ time_t startTime, currentTime;
SET_BINARY_MODE(stream);
SET_BINARY_MODE(zStream);
@@ -432,12 +440,21 @@
if (ferror(stream)) goto errhandler_io;
if (ferror(zStream)) goto errhandler_io;
+ if ((srcMode == SM_F2F || srcMode == SM_F2O) && showProgress == True) {
+ (void)fseek(stream, 0, SEEK_END);
+ fileSize = (double)ftell(stream);
+ rewind(stream);
+ if (verbosity >= 1)
+ fprintf(stderr, "Input-file size: %ld\n", (long)fileSize);
+ }
+
bzf = BZ2_bzWriteOpen ( &bzerr, zStream,
blockSize100k, verbosity, workFactor );
if (bzerr != BZ_OK) goto errhandler;
if (verbosity >= 2) fprintf ( stderr, "\n" );
+ time(&startTime);
while (True) {
if (myfeof(stream)) break;
@@ -446,13 +463,32 @@
if (nIbuf > 0) BZ2_bzWrite ( &bzerr, bzf, (void*)ibuf, nIbuf );
if (bzerr != BZ_OK) goto errhandler;
+ if ((srcMode == SM_F2F || srcMode == SM_F2O) && showProgress == True)
+ {
+ time(&currentTime);
+
+ if ((currentTime - startTime) > 1) { /* show progress every 2 seconds */
+ double curInPos = (double)ftell(stream);
+ double curOutPos = (double)ftell(zStream);
+
+ startTime = currentTime;
+
+ fprintf(stderr, "%.2f%% done", (curInPos * 100.0) / fileSize);
+ if (srcMode == SM_F2F)
+ {
+ fprintf(stderr, ", new size: %.2f%%", (curOutPos * 100.0) / curInPos);
+ }
+
+ fprintf(stderr, " \r");
+ }
+ }
}
BZ2_bzWriteClose64 ( &bzerr, bzf, 0,
&nbytes_in_lo32, &nbytes_in_hi32,
&nbytes_out_lo32, &nbytes_out_hi32 );
if (bzerr != BZ_OK) goto errhandler;
-
+
if (ferror(zStream)) goto errhandler_io;
ret = fflush ( zStream );
if (ret == EOF) goto errhandler_io;
@@ -526,6 +562,8 @@
UChar unused[BZ_MAX_UNUSED];
Int32 nUnused;
UChar* unusedTmp;
+ double fileSize = 0; /* initialized to make the compiler stop crying */
+ time_t startTime, currentTime;
nUnused = 0;
streamNo = 0;
@@ -533,9 +571,19 @@
SET_BINARY_MODE(stream);
SET_BINARY_MODE(zStream);
+ if ((srcMode == SM_F2F || srcMode == SM_F2O) && showProgress == True) {
+ long dummy = ftell(zStream);
+ (void)fseek(zStream, 0, SEEK_END);
+ fileSize = (double)ftell(zStream);
+ (void)fseek(zStream, dummy, SEEK_SET);
+ if (verbosity >= 1)
+ fprintf(stderr, "Input-file size: %ld\n", (long)fileSize);
+ }
+
if (ferror(stream)) goto errhandler_io;
if (ferror(zStream)) goto errhandler_io;
+ time(&startTime);
while (True) {
bzf = BZ2_bzReadOpen (
@@ -551,6 +599,17 @@
if ((bzerr == BZ_OK || bzerr == BZ_STREAM_END) && nread > 0)
fwrite ( obuf, sizeof(UChar), nread, stream );
if (ferror(stream)) goto errhandler_io;
+
+ if ((srcMode == SM_F2F || srcMode == SM_F2O) && showProgress == True) {
+ time(&currentTime);
+ if ((currentTime - startTime) >= 2)
+ {
+ double curInPos = (double)ftell(zStream);
+ startTime = currentTime;
+
+ fprintf(stderr, "%.2f%% done\r", (curInPos * 100.0) / fileSize);
+ }
+ }
}
if (bzerr != BZ_STREAM_END) goto errhandler;
@@ -1872,6 +1931,7 @@
deleteOutputOnInterrupt = False;
exitValue = 0;
i = j = 0; /* avoid bogus warning from egcs-1.1.X */
+ showProgress = False;
/*-- Set up signal handlers for mem access errors --*/
signal (SIGSEGV, mySIGSEGVorSIGBUScatcher);
@@ -1949,6 +2009,7 @@
case 'k': keepInputFiles = True; break;
case 's': smallMode = True; break;
case 'q': noisy = False; break;
+ case 'p': showProgress = True; break;
case '1': blockSize100k = 1; break;
case '2': blockSize100k = 2; break;
case '3': blockSize100k = 3; break;
@@ -1985,6 +2046,7 @@
if (ISFLAG("--keep")) keepInputFiles = True; else
if (ISFLAG("--small")) smallMode = True; else
if (ISFLAG("--quiet")) noisy = False; else
+ if (ISFLAG("--show-progress")) showProgress = True; else
if (ISFLAG("--version")) license(); else
if (ISFLAG("--license")) license(); else
if (ISFLAG("--exponential")) workFactor = 1; else
--- ./Makefile
+++ ./Makefile
@@ -23,5 +23,5 @@
bzlib.o
-all: libbz2.a bzip2 bzip2recover test
+all: libbz2.a bzip2 bzip2recover
bzip2: libbz2.a bzip2.o
bzgrep uses !/bin/sh but then uses the bashism ${var//} so replace those
with calls to sed so POSIX shells work
http://bugs.gentoo.org/193365
--- ./bzgrep
+++ ./bzgrep
@@ -63,10 +63,9 @@
bzip2 -cdfq "$i" | $grep $opt "$pat"
r=$?
else
- j=${i//\\/\\\\}
- j=${j//|/\\|}
- j=${j//&/\\&}
- j=`printf "%s" "$j" | tr '\n' ' '`
+ # the backslashes here are doubled up as we have to escape each one for the
+ # shell and then escape each one for the sed expression
+ j=`printf "%s" "${i}" | sed -e 's:\\\\:\\\\\\\\:g' -e 's:[|]:\\\\|:g' -e 's:[&]:\\\\&:g' | tr '\n' ' '`
bzip2 -cdfq "$i" | $grep $opt "$pat" | sed "s|^|${j}:|"
r=$?
fi
--- ./Makefile
+++ ./Makefile
@@ -18,10 +18,9 @@
CC=gcc
AR=ar
RANLIB=ranlib
-LDFLAGS=
BIGFILES=-D_FILE_OFFSET_BITS=64
-CFLAGS=-Wall -Winline -O2 -g $(BIGFILES)
+CFLAGS+=-Wall -Winline $(BIGFILES) $(CPPFLAGS)
# Where you want it installed when you do 'make install'
PREFIX=/usr/local
--- ./Makefile-libbz2_so
+++ ./Makefile-libbz2_so
@@ -24,7 +24,7 @@
SHELL=/bin/sh
CC=gcc
BIGFILES=-D_FILE_OFFSET_BITS=64
-CFLAGS=-fpic -fPIC -Wall -Winline -O2 -g $(BIGFILES)
+CFLAGS+=-fpic -fPIC -Wall -Winline $(BIGFILES) $(CPPFLAGS)
OBJS= blocksort.o \
huffman.o \
http://bugs.gentoo.org/172986
--- bzip2-1.0.4/Makefile
+++ bzip2-1.0.4/Makefile
@@ -85,4 +85,7 @@
cp -f bzip2.1 $(PREFIX)/share/man/man1
chmod a+r $(PREFIX)/share/man/man1/bzip2.1
+ ln -s bzip2.1 $(PREFIX)/share/man/man1/bunzip2.1
+ ln -s bzip2.1 $(PREFIX)/share/man/man1/bzcat.1
+ ln -s bzip2.1 $(PREFIX)/share/man/man1/bzip2recover.1
cp -f bzlib.h $(PREFIX)/include
chmod a+r $(PREFIX)/include/bzlib.h
--- ./Makefile-libbz2_so
+++ ./Makefile-libbz2_so
@@ -35,8 +35,8 @@
bzlib.o
all: $(OBJS)
- $(CC) -shared -Wl,-soname -Wl,libbz2.so.1.0 -o libbz2.so.1.0.6 $(OBJS)
- $(CC) $(CFLAGS) -o bzip2-shared bzip2.c libbz2.so.1.0.6
+ $(CC) $(LDFLAGS) -shared -Wl,-soname -Wl,libbz2.so.1 -o libbz2.so.1.0.6 $(OBJS)
+ $(CC) $(LDFLAGS) $(CFLAGS) -o bzip2-shared bzip2.c libbz2.so.1.0.6
rm -f libbz2.so.1.0
ln -s libbz2.so.1.0.6 libbz2.so.1.0
# Contributor: Natanael Copa <ncopa@alpinelinux.org>
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=cloog
pkgver=0.18.4
pkgrel=1
pkgdesc="The Chunky Loop Generator"
url="http://www.cloog.org/"
arch="all"
license="GPL-2.0-or-later"
depends=""
depends_dev="gmp-dev isl-dev"
makedepends_host="$depends_dev"
makedepends="$makedepends_host"
install=""
subpackages="$pkgname-dev"
source="http://www.bastoul.net/cloog/pages/download/$pkgname-$pkgver.tar.gz"
_builddir="$srcdir"/$pkgname-$pkgver
prepare() {
local i
cd "$_builddir"
for i in $source; do
case $i in
*.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
esac
done
}
build() {
cd "$_builddir"
./configure \
--build=$CBUILD \
--host=$CHOST \
--prefix=/usr \
--sysconfdir=/etc \
--mandir=/usr/share/man \
--infodir=/usr/share/info \
--localstatedir=/var \
--with-sysroot=${CBUILDROOT} \
--with-isl=system \
|| return 1
make || return 1
}
package() {
cd "$_builddir"
make DESTDIR="$pkgdir" INSTALL="install -D" install || return 1
}
md5sums="e531f725244856c92c9bba009ff44faf cloog-0.18.4.tar.gz"
sha256sums="325adf3710ce2229b7eeb9e84d3b539556d093ae860027185e7af8a8b00a750e cloog-0.18.4.tar.gz"
sha512sums="d35d67b08ffe13c1a010b65bfe4dd02b0ae013d5b489e330dc950bd3514defca8f734bd37781856dcedf0491ff6122c34eecb4b0fe32a22d7e6bdadea98c8c23 cloog-0.18.4.tar.gz"
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=db
pkgver=5.3.28
_ver=${pkgver}
pkgrel=0
pkgdesc="The Berkeley DB embedded database system"
url="https://www.oracle.com/technology/software/products/berkeley-db/index.html"
arch="all"
license="custom"
options="!check" # "check target not available"
depends=
makedepends=
subpackages="$pkgname-dev $pkgname-doc $pkgname-utils $pkgname-c++:cxx"
# Patches were found here:
# http://www.oracle.com/technology/products/berkeley-db/db/update/4.7.25/patch.4.7.25.html
source="http://download.oracle.com/berkeley-db/db-$pkgver.tar.gz
"
_builddir="$srcdir/db-$_ver"
prepare() {
cd "$_builddir"
update_config_sub || return 1
}
build () {
cd "$_builddir"
for i in ../patch.*; do
[ -r "$i" ] || continue
msg "Applying $i..."
patch -p0 < $i || return 1
done
cd build_unix
../dist/configure \
--build=$CBUILD \
--host=$CHOST \
--prefix=/usr \
--mandir=/usr/share/man \
--enable-compat185 \
--enable-shared \
--enable-cxx \
--disable-static \
|| return 1
make LIBSO_LIBS=-lpthread || return 1
}
package() {
cd "$srcdir"/db-$_ver/build_unix
make DESTDIR="$pkgdir" install || return 1
mkdir -p "$pkgdir"/usr/share/doc
mv "$pkgdir"/usr/docs "$pkgdir"/usr/share/doc/$pkgname
install -D -m644 "$srcdir"/db-$_ver/LICENSE \
"$pkgdir"/usr/share/licenses/$pkgname/LICENSE
}
utils() {
pkgdesc="Utils for The Berkeley DB embedded database system"
replaces="db"
mkdir -p "$subpkgdir"/usr/
mv "$pkgdir"/usr/bin "$subpkgdir"/usr/
}
cxx() {
pkgdesc="C++ binding for libdb"
mkdir -p "$subpkgdir"/usr/lib
mv "$pkgdir"/usr/lib/libdb_cxx*.so "$subpkgdir"/usr/lib/
}
md5sums="b99454564d5b4479750567031d66fe24 db-5.3.28.tar.gz"
sha256sums="e0a992d740709892e81f9d93f06daf305cf73fb81b545afe72478043172c3628 db-5.3.28.tar.gz"
sha512sums="e91bbe550fc147a8be7e69ade86fdb7066453814971b2b0223f7d17712bd029a8eff5b2b6b238042ff6ec1ffa6879d44cb95c5645a922fee305c26c3eeaee090 db-5.3.28.tar.gz"
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=fakeroot
pkgver=1.22
pkgrel=0
pkgdesc="Gives a fake root environment, useful for building packages as a non-privileged user"
arch="all"
license='GPL'
url="http://fakeroot.alioth.debian.org/"
depends=
options="!checkroot"
checkdepends="bash"
makedepends_build="libtool autoconf automake po4a"
makedepends_host="libcap-dev acl-dev linux-headers"
makedepends="$makedepends_build $makedepends_host"
subpackages="$pkgname-doc"
source="http://ftp.debian.org/debian/pool/main/f/$pkgname/${pkgname}_${pkgver}.orig.tar.bz2
busybox-getopt.patch
fakeroot-hide-dlsym-errors.patch
fakeroot-no64.patch
fakeroot-stdint.patch
fakeroot-no-ldlibrarypath.patch
xstatjunk.patch
"
check() {
cd $startdir/src/$pkgname-$pkgver
/bin/bash -c 'make check'
}
build() {
cd $startdir/src/$pkgname-$pkgver
if [ "$CLIBC" = "musl" ]; then
# musl does not have _STAT_VER, it's really not used for
# anything, so define it as zero (just like uclibc does)
export CFLAGS="-D_STAT_VER=0 $CFLAGS"
fi
CONFIG_SHELL=/bin/sh ./bootstrap
CONFIG_SHELL=/bin/sh ./configure \
--build=$CBUILD \
--host=$CHOST \
--prefix=/usr \
--disable-static
make
cd doc
po4a -k 0 --rm-backups --variable "srcdir=../doc/" po4a/po4a.cfg
}
package() {
cd "$startdir/src/$pkgname-$pkgver"
make DESTDIR="$pkgdir" install
}
sha512sums="193478d9ff88ca2ae69fe47b73b6c61aeb2ba3f2a9e7ed5d455022705857c6f34cdcbe2d3f614c4c4c9509368dc78b9a7b7aa56fb3b50bb3309448140abd796a fakeroot_1.22.orig.tar.bz2
9024263f4452bcb46c9670f8b8106e67c2d9b4cf45215def7ff4e78d2c908e4f98d494dd6f514fb3325165b0f61571fa031632b4642163cf9b1b3386d0867c5f busybox-getopt.patch
666f41d6adc5e65eba419e08d5bbc4f561e40b0fc7bfa82090eb87962a7f3193bf319754e04aca289e865c66df2ecced1dbb45c9aa9f093657f22193dda25354 fakeroot-hide-dlsym-errors.patch
7a832e6bed3838c7c488e0e12ba84b8d256e84bbb06d6020247452a991de505fa5c6bd7bcb84dce8753eb242e0fcab863b5461301cd56695f2b003fe8d6ff209 fakeroot-no64.patch
ed7a58b0d201139545420f9e5429f503c00e00f36dea84473e77ea99b23bb8d421da1a8a8ce98ff90e72e378dff4cb9ea3c1a863a969899a5f50dfac3b9c5fac fakeroot-stdint.patch
acfc1e5efce132279adddf9e11c28d65602059d5cd723ad98b67cb9183e1de68445f3bba7ac54ee60265b85f25141fcc9b2156f551aa5c624a92631320f5b743 fakeroot-no-ldlibrarypath.patch
5efd33fd778bd94a529ed7e439fb8fea25ff865dda3f6f9e431264e942b37f3b5d7a0ad14107b55c5fa81b86efd5a82aedb3803cfab08ec57f27f5b229d2fe88 xstatjunk.patch"
--- ./scripts/fakeroot.in.orig
+++ ./scripts/fakeroot.in
@@ -43,9 +43,9 @@
libfound=no
-GETOPTEST=`getopt --version`
+GETOPTEST=`getopt --version 2>&1 | head -n2`
case $GETOPTEST in
-getopt*) # GNU getopt
+getopt*|*BusyBox*) # GNU getopt
FAKE_TEMP=`getopt -l lib: -l faked: -l unknown-is-real -l fd-base: -l version -l help -- +l:f:i:s:ub:vh "$@"`
;;
*) # POSIX getopt ?
it's normal that the acl_* symbols are not found if the application
is not linked against -lacl. these errors harmless, but mighty
annoying.
--- fakeroot-1.20/libfakeroot.c.orig 2014-03-07 11:20:26.120532847 +0200
+++ fakeroot-1.20/libfakeroot.c 2014-03-07 11:21:26.486872482 +0200
@@ -258,10 +258,12 @@
/* clear dlerror() just in case dlsym() legitimately returns NULL */
msg = dlerror();
*(next_wrap[i].doit)=dlsym(get_libc(), next_wrap[i].name);
- if ( (msg = dlerror()) != NULL){
+#ifdef LIBFAKEROOT_DEBUGGING
+ if ( fakeroot_debug && (msg = dlerror()) != NULL) {
fprintf (stderr, "dlsym(%s): %s\n", next_wrap[i].name, msg);
/* abort ();*/
}
+#endif
}
}
0% Loading or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment