Skip to content
Snippets Groups Projects
Commit ad7138a6 authored by Nathan Owens's avatar Nathan Owens
Browse files

user/scrot: Add

parent 60c5b0f1
No related branches found
No related tags found
1 merge request!527user/scrot: Add
diff --git a/configure.ac b/configure.ac
index e89ac2c..df64719 100644
--- a/configure.ac
+++ b/configure.ac
@@ -3,8 +3,6 @@ dnl Process this file with autoconf to create configure.
AC_INIT([scrot], [1.4], [https://github.com/resurrecting-open-source-projects/scrot/issues])
AC_CONFIG_SRCDIR([src/main.c])
AM_INIT_AUTOMAKE
-AC_CONFIG_HEADER([src/config.h])
-AX_PREFIX_CONFIG_H([src/scrot_config.h])
AC_PROG_CC
AM_PROG_CC_STDC
@@ -29,7 +27,5 @@ AC_SUBST(GIBLIB_CFLAGS)
AC_CHECK_FUNC(getopt_long,,[LIBOBJS="$LIBOBJS getopt.o getopt1.o"])
AC_SUBST(LIBOBJS)
-m4_pattern_forbid([^AX_],[=> GNU autoconf-archive not present. <=])
-
AC_CONFIG_FILES([Makefile src/Makefile])
AC_OUTPUT
# Contributor: Nathan <ndowens@artixlinux.org>
# Maintainer: Nathan <ndowens@artixlinux.org>
pkgname=scrot
pkgver=1.4
pkgrel=0
pkgdesc="Simple command-line screenshot utility for X"
options="!check" # No testsuite
url="https://github.com/resurrecting-open-source-projects/scrot"
arch="all"
license="MIT"
depends=""
makedepends="giblib-dev imlib2-dev libx11-dev libxfixes-dev libxcomposite-dev
automake libtool autoconf autoconf-archive sed"
subpackages="$pkgname-doc"
source="$pkgname-$pkgver.tar.gz::https://github.com/resurrecting-open-source-projects/scrot/archive/$pkgver/$pkgname-$pkgver.tar.gz
0001-remove-ax-forbid.patch
config.h"
prepare() {
default_prepare
autoreconf -fiv
}
build() {
sed -ie '2531d' configure
./configure \
--build=$CBUILD \
--host=$CHOST \
--prefix=/usr \
--mandir=/usr/share/man
cp $srcdir/config.h src/scrot_config.h
make
}
package() {
make DESTDIR="$pkgdir" docsdir=/usr/share/doc/scrot install
}
sha512sums="8423e7b2658f3e0ccf30f61e122016469226328adf8b1e511aeb031dd2655ae66582651e2d046c7c35d23efb98656369a02b59e711980481ddc4db24c299ee11 scrot-1.4.tar.gz
ca7a40345b031c84ccc083202184dbff2418feb97472aca9fd441ba21501608562bdda061283db7793ad07a6d80e302c8f15a2819ac20dff8b741c6c539cbcd2 0001-remove-ax-forbid.patch
95429feb7c107c5adeadf33b5a3e3ff9dc4fb95f0d58f92c6a8de27d776a07256fa9f1825896d569eb32beb77300f46995dcafd1359f305d22861eb5748de84a config.h"
/* src/config.h. Generated from config.h.in by configure. */
/* src/config.h.in. Generated from configure.ac by autoheader. */
/* Name of package */
#define SCROT_PACKAGE "scrot"
/* Define to the address where bug reports for this package should be sent. */
#define PACKAGE_BUGREPORT "https://github.com/resurrecting-open-source-projects/scrot/issues"
/* Define to the full name of this package. */
#define PACKAGE_NAME "scrot"
/* Define to the full name and version of this package. */
#define PACKAGE_STRING "scrot 1.4"
/* Define to the one symbol short name of this package. */
#define PACKAGE_TARNAME "scrot"
/* Define to the home page for this package. */
#define PACKAGE_URL ""
/* Define to the version of this package. */
#define PACKAGE_VERSION "1.4"
/* Version number of package */
#define SCROT_VERSION "1.4"
/* Define to empty if `const' does not conform to ANSI C. */
/* #undef const */
0% Loading or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment