Skip to content
GitLab
Explore
Sign in
Register
Primary navigation
Search or go to…
Project
Adélie Package Tree
Manage
Activity
Members
Labels
Plan
Issues
Issue boards
Milestones
Wiki
Code
Merge requests
Repository
Branches
Commits
Tags
Repository graph
Compare revisions
Build
Pipelines
Jobs
Pipeline schedules
Artifacts
Help
Help
Support
GitLab documentation
Compare GitLab plans
Community forum
Contribute to GitLab
Provide feedback
Keyboard shortcuts
?
Snippets
Groups
Projects
Show more breadcrumbs
Adélie Linux
Adélie Package Tree
Commits
a5639754
Verified
Commit
a5639754
authored
4 years ago
by
Anna Wilcox
Browse files
Options
Downloads
Patches
Plain Diff
user/horizon: Update to 0.9.4
parent
83c341ea
No related branches found
Branches containing commit
No related tags found
Tags containing commit
No related merge requests found
Changes
3
Expand all
Hide whitespace changes
Inline
Side-by-side
Showing
3 changed files
user/horizon/APKBUILD
+13
-8
13 additions, 8 deletions
user/horizon/APKBUILD
user/horizon/fix-qt-runner.patch
+0
-25
0 additions, 25 deletions
user/horizon/fix-qt-runner.patch
user/horizon/git.patch
+0
-660
0 additions, 660 deletions
user/horizon/git.patch
with
13 additions
and
693 deletions
user/horizon/APKBUILD
+
13
−
8
View file @
a5639754
# Contributor: A. Wilcox <awilfox@adelielinux.org>
# Maintainer: A. Wilcox <awilfox@adelielinux.org>
pkgname
=
horizon
pkgver
=
0.9.
3
pkgrel
=
2
pkgver
=
0.9.
4
pkgrel
=
0
pkgdesc
=
"Installation tools for Adélie Linux"
url
=
"https://horizon.adelielinux.org/"
arch
=
"all"
...
...
@@ -17,9 +17,7 @@ makedepends="bcnm-dev boost-dev cmake curl-dev eudev-dev libarchive-dev
libcap-dev libx11-dev libxkbfile-dev qt5-qtbase-dev"
subpackages
=
"
$pkgname
-image
$pkgname
-dbg
$pkgname
-dev
$pkgname
-doc
$pkgname
-qt5
$pkgname
-tools
$pkgname
-wizard
$pkgname
-boot"
source
=
"https://distfiles.adelielinux.org/source/horizon-
$pkgver
.tar.xz
git.patch
"
source
=
"https://distfiles.adelielinux.org/source/horizon-
$pkgver
.tar.xz"
build
()
{
if
[
"
$CBUILD
"
!=
"
$CHOST
"
]
;
then
...
...
@@ -63,7 +61,7 @@ package() {
image
()
{
pkgdesc
=
"Tools for generating images using HorizonScript"
depends
=
"mtools"
depends
=
"
dracut
mtools"
mkdir
-p
"
$subpkgdir
"
/usr/bin
mkdir
-p
"
$subpkgdir
"
/usr/lib
mkdir
-p
"
$subpkgdir
"
/usr/share/horizon
...
...
@@ -108,7 +106,9 @@ boot() {
depends
=
"horizon-qt5 horizon kwin qt5ct sddm
netsurf partitionmanager xterm"
mkdir
-p
"
$subpkgdir
"
/etc/init.d
mkdir
-p
"
$subpkgdir
"
/etc/profile.d
mkdir
-p
"
$subpkgdir
"
/etc/runlevels/default
mkdir
-p
"
$subpkgdir
"
/etc/sddm.conf.d
mkdir
-p
"
$subpkgdir
"
/etc/xdg/qt5ct
mkdir
-p
"
$subpkgdir
"
/usr/bin
...
...
@@ -135,6 +135,12 @@ GLOBALS
install
-D
-m644
"
$builddir
"
/boot/horizon.sddm.conf
\
"
$subpkgdir
"
/etc/sddm.conf.d/horizon.conf
install
-D
-m755
"
$builddir
"
/boot/gfxdetect
\
"
$subpkgdir
"
/etc/init.d/gfxdetect
ln
-s
../../init.d/gfxdetect
\
"
$subpkgdir
"
/etc/runlevels/default/gfxdetect
install
-D
-m755
"
$builddir
"
/boot/start-horizon-qt5
\
"
$subpkgdir
"
/usr/bin/start-horizon-qt5
...
...
@@ -150,5 +156,4 @@ GLOBALS
"
$subpkgdir
"
/usr/share/xsessions/horizon.desktop
}
sha512sums
=
"99c1d939abc33c4a072712e75c6c8ada16deb1fe59b9da839dffd695a0d40dbf48499cc00751285300127a7fc701e8e1c434e9f8a222f1981ccbebd6ee72e43e horizon-0.9.3.tar.xz
7c7c4297ae8d0d879a01ac38c0699dd9338e9b9675a0804dc3ec915e98900343e001d0a0558fcaccbf9f5cfafbf9ae869c7ec194d1529683b5874941a77b0125 git.patch"
sha512sums
=
"202830a4e1313d0761484aeb65bef1e2a109917d4bec8f963672f4017a5fda2dac1383be6dfe2ed9aa3daa913cc62f816e88d2e760824957dbc18070ca901f76 horizon-0.9.4.tar.xz"
This diff is collapsed.
Click to expand it.
user/horizon/fix-qt-runner.patch
deleted
100644 → 0
+
0
−
25
View file @
83c341ea
From 9f737dbab8b9ed9fa57bdf15542cc00a8363d98b Mon Sep 17 00:00:00 2001
From: "A. Wilcox" <AWilcox@Wilcox-Tech.com>
Date: Thu, 4 Jun 2020 21:29:37 -0500
Subject: [PATCH] Qt UI: Ensure log is opened when built in release modes
---
ui/qt5/runner/executepage.cc | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/ui/qt5/runner/executepage.cc b/ui/qt5/runner/executepage.cc
index 999731a..d5788df 100644
--- a/ui/qt5/runner/executepage.cc
+++ b/ui/qt5/runner/executepage.cc
@@ -48,7 +48,7 @@
ExecutePage::ExecutePage(QWidget *parent) : HorizonWizardPage(parent) {
});
log.setFileName("/var/log/horizon/executor.log");
- Q_ASSERT(log.open(QFile::Append));
+ log.open(QFile::Append);
this->current = Prepare;
markRunning(this->current);
--
2.25.4
This diff is collapsed.
Click to expand it.
user/horizon/git.patch
deleted
100644 → 0
+
0
−
660
View file @
83c341ea
This diff is collapsed.
Click to expand it.
Preview
0%
Loading
Try again
or
attach a new file
.
Cancel
You are about to add
0
people
to the discussion. Proceed with caution.
Finish editing this message first!
Save comment
Cancel
Please
register
or
sign in
to comment