Skip to content
Snippets Groups Projects
Commit a524397e authored by Anna Wilcox's avatar Anna Wilcox :fox:
Browse files

Merge branch 'libstatgrab' into 'master'

user/libstatgrab: new package

Packages libstatgrab, needed in order to build lxqt.

See merge request !1
parents b5e44965 32d81be9
No related branches found
No related tags found
No related merge requests found
# Contributor: Kiyoshi Aman <kiyoshi.aman+adelie@gmail.com>
# Maintainer: Kiyoshi Aman <kiyoshi.aman+adelie@gmail.com>
pkgname=libstatgrab
pkgver=0.91
pkgrel=0
pkgdesc="Library for cross-platform access to system statistics."
url="https://www.i-scream.org/libstatgrab"
arch="all"
license="GPL-2.0+ LGPL-2.1+"
depends=""
depends_dev="ncurses-dev"
checkdepends="perl"
makedepends="autoconf automake libtool $depends_dev"
install=""
subpackages="$pkgname-dev $pkgname-doc"
source="https://ftp.i-scream.org/pub/i-scream/$pkgname/$pkgname-$pkgver.tar.gz
fix-configure.patch
nongnu.patch"
builddir="$srcdir/$pkgname-$pkgver"
build() {
cd "$builddir"
aclocal
libtoolize -if --recursive
autoreconf -if
./configure \
--build=$CBUILD \
--host=$CHOST \
--prefix=/usr \
--sysconfdir=/etc \
--mandir=/usr/share/man \
--localstatedir=/var \
--enable-maintainer-mode \
--disable-man-build
make
}
check() {
cd "$builddir"
make check
}
package() {
cd "$builddir"
make DESTDIR="$pkgdir" install
}
sha512sums="f360f2e1b185bf9603b1d9c50649b0050e9502128ff81a9f4de88457e2f5203deafe7fd7ac13ebc4cc56e6ecd1bdf8aacae64987bdf36af0c9929e30626915f6 libstatgrab-0.91.tar.gz
96661b2d4c4c54fde9b2cb57e3a9d84e950aae130017a7496a60b630ec7c30d8c6ee270d8f2976f8179f4926073a39d92116e4abce2f4c742d4d5e08bc031f4e fix-configure.patch
9c42c860c0939b60fcba26d86d65c8e5f1e64e5e6d0646eb7d6ab72b1926f655f0ae8212823cf6e0e1afb1b9098a4d02503847304ce5e20d0540329c10d23d7f nongnu.patch"
diff -Nurd libstatgrab-0.91/configure.ac libstatgrab-0.91.new/configure.ac
--- libstatgrab-0.91/configure.ac 2014-07-11 19:12:06.000000000 +0000
+++ libstatgrab-0.91.new/configure.ac 2017-10-10 18:17:14.094496592 +0000
@@ -609,8 +609,8 @@
[openbsd*], [
AC_DEFINE(OPENBSD, , [Building on OpenBSD])
],
- [linux-gnu*], [
- AC_DEFINE(LINUX, , [Building on GNU/Linux])
+ [linux*], [
+ AC_DEFINE(LINUX, , [Building on Linux])
AM_CONDITIONAL(SETUIDBINS, true)
BIN_OWNER="root"
BIN_PERM="4755"
diff -Nurd libstatgrab-0.91/src/libstatgrab/os_info.c libstatgrab-0.91.new/src/libstatgrab/os_info.c
--- libstatgrab-0.91/src/libstatgrab/os_info.c 2014-06-19 11:41:10.000000000 +0000
+++ libstatgrab-0.91.new/src/libstatgrab/os_info.c 2017-10-10 18:42:04.844471568 +0000
@@ -472,7 +472,7 @@
host_info_buf->bitwidth = 64;
}
else {
- host_info_buf->bitwidth = sysconf(_SC_LONG_BIT); // well, maybe 64-bit disabled 128-bit system o.O
+ host_info_buf->bitwidth = sizeof(long int) * 8; // well, maybe 64-bit disabled 128-bit system o.O
}
host_info_buf->host_state = sg_unknown_configuration;
# endif
0% Loading or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment