Skip to content
GitLab
Explore
Sign in
Register
Primary navigation
Search or go to…
Project
Adélie Package Tree
Manage
Activity
Members
Labels
Plan
Issues
Issue boards
Milestones
Wiki
Code
Merge requests
Repository
Branches
Commits
Tags
Repository graph
Compare revisions
Build
Pipelines
Jobs
Pipeline schedules
Artifacts
Help
Help
Support
GitLab documentation
Compare GitLab plans
Community forum
Contribute to GitLab
Provide feedback
Keyboard shortcuts
?
Snippets
Groups
Projects
Show more breadcrumbs
Adélie Linux
Adélie Package Tree
Commits
a479260b
Commit
a479260b
authored
2 years ago
by
Zach van Rijn
Browse files
Options
Downloads
Patches
Plain Diff
system/libuv: add patch for nonsense test assumption. fixes
#695
.
parent
ebc583dc
No related branches found
Branches containing commit
No related tags found
Tags containing commit
No related merge requests found
Changes
2
Hide whitespace changes
Inline
Side-by-side
Showing
2 changed files
system/libuv/APKBUILD
+5
-2
5 additions, 2 deletions
system/libuv/APKBUILD
system/libuv/fix-test-terminal-illness.patch
+27
-0
27 additions, 0 deletions
system/libuv/fix-test-terminal-illness.patch
with
32 additions
and
2 deletions
system/libuv/APKBUILD
+
5
−
2
View file @
a479260b
...
...
@@ -10,7 +10,9 @@ arch="all"
license
=
"MIT AND BSD-2-Clause AND BSD-3-Clause AND ISC"
makedepends
=
"automake autoconf libtool linux-headers"
subpackages
=
"
$pkgname
-dev"
source
=
"https://dist.libuv.org/dist/v
$pkgver
/
$pkgname
-v
$pkgver
.tar.gz"
source
=
"https://dist.libuv.org/dist/v
$pkgver
/
$pkgname
-v
$pkgver
.tar.gz
fix-test-terminal-illness.patch
"
builddir
=
"
$srcdir
/
$pkgname
-v
$pkgver
"
prepare
()
{
...
...
@@ -39,4 +41,5 @@ package() {
"
$pkgdir
"
/usr/share/licenses/
$pkgname
/LICENSE
}
sha512sums
=
"b4f8944e2c79e3a6a31ded6cccbe4c0eeada50db6bc8a448d7015642795012a4b80ffeef7ca455bb093c59a8950d0e1430566c3c2fa87b73f82699098162d834 libuv-v1.44.1.tar.gz"
sha512sums
=
"b4f8944e2c79e3a6a31ded6cccbe4c0eeada50db6bc8a448d7015642795012a4b80ffeef7ca455bb093c59a8950d0e1430566c3c2fa87b73f82699098162d834 libuv-v1.44.1.tar.gz
46e861417f17a6a423b0d89204d74668c44e96666b69726064799f86b5db2436cfe749619af4c4e1baee8154780738c1eb8892c2a5187f7f46f3c54192b6d749 fix-test-terminal-illness.patch"
This diff is collapsed.
Click to expand it.
system/libuv/fix-test-terminal-illness.patch
0 → 100644
+
27
−
0
View file @
a479260b
This patch addresses the following issue:
https://git.adelielinux.org/adelie/packages/-/issues/695
I've run into this enough times to justify this patch, waking
up in the morning to find that my overnight builds failed, or
during manual testing on laptops with smaller displays that
have a reduce line count when I connect to tmux.
I don't think width is an issue, but saying "you must be 10
columns or higher to ride" is arbitrarily restrictive.
--- a/test/test-tty.c
+++ b/test/test-tty.c
@@ -118,10 +118,10 @@
/*
* Is it a safe assumption that most people have terminals larger than
- * 10x10?
+ * 10x10? -- No; you know what they say about assumptions.
*/
ASSERT(width > 10);
- ASSERT(height > 10);
+ ASSERT(height > 3);
/* Turn on raw mode. */
r = uv_tty_set_mode(&tty_in, UV_TTY_MODE_RAW);
This diff is collapsed.
Click to expand it.
Zach van Rijn
@z
mentioned in issue
#695 (closed)
·
2 years ago
mentioned in issue
#695 (closed)
mentioned in issue #695
Toggle commit list
Preview
0%
Loading
Try again
or
attach a new file
.
Cancel
You are about to add
0
people
to the discussion. Proceed with caution.
Finish editing this message first!
Save comment
Cancel
Please
register
or
sign in
to comment