Skip to content
GitLab
Explore
Sign in
Register
Primary navigation
Search or go to…
Project
Adélie Package Tree
Manage
Activity
Members
Labels
Plan
Issues
Issue boards
Milestones
Wiki
Code
Merge requests
Repository
Branches
Commits
Tags
Repository graph
Compare revisions
Build
Pipelines
Jobs
Pipeline schedules
Artifacts
Help
Help
Support
GitLab documentation
Compare GitLab plans
Community forum
Contribute to GitLab
Provide feedback
Keyboard shortcuts
?
Snippets
Groups
Projects
Show more breadcrumbs
Adélie Linux
Adélie Package Tree
Commits
a2d848c1
Verified
Commit
a2d848c1
authored
5 years ago
by
Anna Wilcox
Browse files
Options
Downloads
Patches
Plain Diff
system/musl: bump to 1.2.0_alpha2
parent
284f0523
No related branches found
Branches containing commit
No related tags found
Tags containing commit
No related merge requests found
Changes
2
Hide whitespace changes
Inline
Side-by-side
Showing
2 changed files
system/musl/APKBUILD
+2
-4
2 additions, 4 deletions
system/musl/APKBUILD
system/musl/time32-setitimer-fix.patch
+0
-20
0 additions, 20 deletions
system/musl/time32-setitimer-fix.patch
with
2 additions
and
24 deletions
system/musl/APKBUILD
+
2
−
4
View file @
a2d848c1
# Maintainer: A. Wilcox <awilfox@adelielinux.org>
pkgname
=
musl
pkgver
=
1.2.0_alpha
1
pkgver
=
1.2.0_alpha
2
pkgrel
=
0
pkgdesc
=
"System library (libc) implementation"
url
=
"https://www.musl-libc.org/"
...
...
@@ -26,7 +26,6 @@ source="https://distfiles.adelielinux.org/source/$pkgname-$pkgver.tar.xz
3001-make-real-lastlog-h.patch
handle-aux-at_base.patch
fgetspent_r.patch
time32-setitimer-fix.patch
ldconfig
getent.c
...
...
@@ -117,12 +116,11 @@ utils() {
install
-D
-m755
"
$srcdir
"
/ldconfig
"
$subpkgdir
"
/sbin
}
sha512sums
=
"
7026b67590a5dc0eda96777476a902e3d7121813d9ff9d9dabec3774365b9d43ce06314c434224fc8eef2b858107e42c10f220b6009ce4b919d8d9996cfcb839
musl-1.2.0_alpha
1
.tar.xz
sha512sums
=
"
3976257352ada259fe9baa31bb7d0193765d4e9d6583503543af0122d02fa75e5b5f9e5fee6b6f2550959a389eec3cc45e54eae9ccd08b7d5601c1207d367de1
musl-1.2.0_alpha
2
.tar.xz
90cc7d683ea62a6b89f5bf4b782d4d70ee59a0498ad938a78c224b4e1058d45e4a196cf9278e57d7f57e40931072c339a9cbcafb8f0b2a902b485e9c757eec9a amalgamation.patch
88ae443dbb8e0a4368235bdc3a1c5c7b718495afa75e06deb8e01becc76cb1f0d6964589e2204fc749c9c1b3190b8b9ac1ae2c0099cab8e2ce3ec877103d4332 3001-make-real-lastlog-h.patch
6a7ff16d95b5d1be77e0a0fbb245491817db192176496a57b22ab037637d97a185ea0b0d19da687da66c2a2f5578e4343d230f399d49fe377d8f008410974238 handle-aux-at_base.patch
ded41235148930f8cf781538f7d63ecb0c65ea4e8ce792565f3649ee2523592a76b2a166785f0b145fc79f5852fd1fb1729a7a09110b3b8f85cba3912e790807 fgetspent_r.patch
6126574e597ced3cc261131699d75d3d972ac460213b55e73d2ac3e974bbf7fb506c2212c387af616ac3a6a4aea689443b28bd1d70b29d359d2e5872a18f8419 time32-setitimer-fix.patch
cb71d29a87f334c75ecbc911becde7be825ab30d8f39fa6d64cb53812a7c9abaf91d9804c72540e5be3ddd3c84cfe7fd9632274309005cb8bcdf9a9b09b4b923 ldconfig
378d70e65bcc65bb4e1415354cecfa54b0c1146dfb24474b69e418cdbf7ad730472cd09f6f103e1c99ba6c324c9560bccdf287f5889bbc3ef0bdf0e08da47413 getent.c
9d42d66fb1facce2b85dad919be5be819ee290bd26ca2db00982b2f8e055a0196290a008711cbe2b18ec9eee8d2270e3b3a4692c5a1b807013baa5c2b70a2bbf iconv.c"
This diff is collapsed.
Click to expand it.
system/musl/time32-setitimer-fix.patch
deleted
100644 → 0
+
0
−
20
View file @
284f0523
diff --git a/compat/time32/setitimer_time32.c b/compat/time32/setitimer_time32.c
index 4651dacb..2475fd8c 100644
--- a/compat/time32/setitimer_time32.c
+++ b/compat/time32/setitimer_time32.c
@@ -15,9 +15,11 @@
int __setitimer_time32(int which, const struct itimerval32 *restrict new32, stru
* timer setting, so we can't fail on out-of-range old value.
* Since these are relative times, values large enough to overflow
* don't make sense anyway. */
- old32->it_interval.tv_sec = old.it_interval.tv_sec;
- old32->it_interval.tv_usec = old.it_interval.tv_usec;
- old32->it_value.tv_sec = old.it_value.tv_sec;
- old32->it_value.tv_usec = old.it_value.tv_usec;
+ if (old32) {
+ old32->it_interval.tv_sec = old.it_interval.tv_sec;
+ old32->it_interval.tv_usec = old.it_interval.tv_usec;
+ old32->it_value.tv_sec = old.it_value.tv_sec;
+ old32->it_value.tv_usec = old.it_value.tv_usec;
+ }
return 0;
}
This diff is collapsed.
Click to expand it.
Preview
0%
Loading
Try again
or
attach a new file
.
Cancel
You are about to add
0
people
to the discussion. Proceed with caution.
Finish editing this message first!
Save comment
Cancel
Please
register
or
sign in
to comment