Skip to content
GitLab
Explore
Sign in
Register
Primary navigation
Search or go to…
Project
Adélie Package Tree
Manage
Activity
Members
Labels
Plan
Issues
Issue boards
Milestones
Wiki
Code
Merge requests
Repository
Branches
Commits
Tags
Repository graph
Compare revisions
Build
Pipelines
Jobs
Pipeline schedules
Artifacts
Help
Help
Support
GitLab documentation
Compare GitLab plans
Community forum
Contribute to GitLab
Provide feedback
Keyboard shortcuts
?
Snippets
Groups
Projects
Show more breadcrumbs
Adélie Linux
Adélie Package Tree
Commits
8bd0e572
Commit
8bd0e572
authored
6 years ago
by
Max Rees
Browse files
Options
Downloads
Patches
Plain Diff
user/py3-pytest: bump to 3.9.1, drop py3-tox dep
parent
f89370f6
No related branches found
Branches containing commit
No related tags found
Tags containing commit
1 merge request
!97
Update some Python packages and drop py3-tox rdeps where unnecessary
Changes
2
Hide whitespace changes
Inline
Side-by-side
Showing
2 changed files
user/py3-pytest/APKBUILD
+13
-8
13 additions, 8 deletions
user/py3-pytest/APKBUILD
user/py3-pytest/scm.patch
+13
-0
13 additions, 0 deletions
user/py3-pytest/scm.patch
with
26 additions
and
8 deletions
user/py3-pytest/APKBUILD
+
13
−
8
View file @
8bd0e572
...
...
@@ -2,17 +2,20 @@
# Maintainer: Max Rees <maxcrees@me.com>
pkgname
=
py3-pytest
_pkgname
=
pytest
pkgver
=
3.
5
.1
pkgrel
=
1
pkgver
=
3.
9
.1
pkgrel
=
0
pkgdesc
=
"A python test library"
url
=
"https://pypi.python.org/pypi/pytest"
arch
=
"noarch"
options
=
"net !check"
# Circular dependency with py3-tox. Passes on x86_64
options
=
"!checkroot !check"
# Cyclic dependency with itself. Passes on x86_64
# Certified net clean
license
=
"MIT"
depends
=
"python3 py3-py py3-more-itertools py3-six py3-pluggy py3-attrs"
depends
=
"python3 py3-atomicwrites py3-attrs py3-more-itertools
py3-pluggy py3-py py3-six"
makedepends
=
"python3-dev"
#checkdepends="py3-tox"
source
=
"
$pkgname
-
$pkgver
.tar.gz::https://files.pythonhosted.org/packages/source/
${
_pkgname
:0:1
}
/
$_pkgname
/
$_pkgname
-
$pkgver
.tar.gz"
#checkdepends="py3-pytest py3-hypothesis"
source
=
"
$pkgname
-
$pkgver
.tar.gz::https://files.pythonhosted.org/packages/source/p/
$_pkgname
/
$_pkgname
-
$pkgver
.tar.gz
scm.patch"
builddir
=
"
$srcdir
/
$_pkgname
-
$pkgver
"
build
()
{
...
...
@@ -22,7 +25,8 @@ build() {
check
()
{
cd
"
$builddir
"
tox
-e
py36
# You would think you could get away with "python3 -m pytest" but no...
PYTHONPATH
=
"
$builddir
/build/lib:
$PYTHONPATH
"
pytest
}
package
()
{
...
...
@@ -30,4 +34,5 @@ package() {
python3 setup.py
install
--prefix
=
/usr
--root
=
"
$pkgdir
"
}
sha512sums
=
"5f54251b197b4bebadb06536054b4f79e16c5cec2cdfd7d95fd74548b8ecfaddaafeb635eb90d085fe4d4bea1108f951fe500d0e548cc8b797b0d23e0c2693a0 py3-pytest-3.5.1.tar.gz"
sha512sums
=
"0a3a6842fb549c8223f0ddf56ca28eb200a21a4cadf382fbcd2ab930c58d57c55c77d5869e84bd79bf611d959cba6d363ace3b5fd33d5ce44259fd580b1a9369 py3-pytest-3.9.1.tar.gz
7fc2cd75f55caa661fb4bed578955511ee38cd28a25fcb405c29eb7227a382c33c0fc52a4eeb8950315793dfc0eb02235b140415deebd113f24df1a320b25959 scm.patch"
This diff is collapsed.
Click to expand it.
user/py3-pytest/scm.patch
0 → 100644
+
13
−
0
View file @
8bd0e572
--- pytest-3.9.1/setup.py 2018-10-16 15:46:37.000000000 -0400
+++ pytest-3.9.1/setup.py 2018-10-22 19:32:49.261592294 -0400
@@ -25,8 +25,8 @@
if "_PYTEST_SETUP_SKIP_PLUGGY_DEP" not i
def main():
setup(
- use_scm_version={"write_to": "src/_pytest/_version.py"},
- setup_requires=["setuptools-scm", "setuptools>=30.3"],
+ setup_requires=["setuptools>=30.3"],
+ version="3.9.1",
package_dir={"": "src"},
install_requires=INSTALL_REQUIRES,
)
This diff is collapsed.
Click to expand it.
Preview
0%
Loading
Try again
or
attach a new file
.
Cancel
You are about to add
0
people
to the discussion. Proceed with caution.
Finish editing this message first!
Save comment
Cancel
Please
register
or
sign in
to comment