Skip to content
GitLab
Explore
Sign in
Register
Primary navigation
Search or go to…
Project
Adélie Package Tree
Manage
Activity
Members
Labels
Plan
Issues
Issue boards
Milestones
Wiki
Code
Merge requests
Repository
Branches
Commits
Tags
Repository graph
Compare revisions
Build
Pipelines
Jobs
Pipeline schedules
Artifacts
Help
Help
Support
GitLab documentation
Compare GitLab plans
Community forum
Contribute to GitLab
Provide feedback
Keyboard shortcuts
?
Snippets
Groups
Projects
Show more breadcrumbs
Adélie Linux
Adélie Package Tree
Commits
8837d763
Verified
Commit
8837d763
authored
6 years ago
by
Anna Wilcox
Browse files
Options
Downloads
Patches
Plain Diff
user/analitza: patch to fix pmmx range()
parent
1b708c8a
No related branches found
Branches containing commit
No related tags found
Tags containing commit
No related merge requests found
Changes
2
Hide whitespace changes
Inline
Side-by-side
Showing
2 changed files
user/analitza/APKBUILD
+5
-3
5 additions, 3 deletions
user/analitza/APKBUILD
user/analitza/pmmx-test-failure.patch
+14
-0
14 additions, 0 deletions
user/analitza/pmmx-test-failure.patch
with
19 additions
and
3 deletions
user/analitza/APKBUILD
+
5
−
3
View file @
8837d763
...
...
@@ -2,7 +2,7 @@
# Maintainer: A. Wilcox <awilfox@adelielinux.org>
pkgname
=
analitza
pkgver
=
17.12.2
pkgrel
=
0
pkgrel
=
1
pkgdesc
=
"Mathematical object library"
url
=
"https://api.kde.org/4.x-api/kdeedu-apidocs/analitza/html/index.html"
arch
=
"all"
...
...
@@ -12,7 +12,8 @@ depends_dev="qt5-qtbase-dev qt5-qtsvg-dev qt5-qtdeclarative-dev eigen-dev"
makedepends
=
"
$depends_dev
cmake extra-cmake-modules qt5-qttools-dev"
install
=
""
subpackages
=
"
$pkgname
-dev
$pkgname
-lang"
source
=
"http://download.kde.org/stable/applications/
$pkgver
/src/analitza-
$pkgver
.tar.xz"
source
=
"http://download.kde.org/stable/applications/
$pkgver
/src/analitza-
$pkgver
.tar.xz
pmmx-test-failure.patch"
build
()
{
cd
"
$builddir
"
...
...
@@ -40,4 +41,5 @@ package() {
make
DESTDIR
=
"
$pkgdir
"
install
}
sha512sums
=
"e326d397db3193492258f156cd71f63e4544abd9724b58769a1593ff57242b18de09291a433ea37658015bd57f75e430ed95bdf99d3863fccfc4b546a9686933 analitza-17.12.2.tar.xz"
sha512sums
=
"e326d397db3193492258f156cd71f63e4544abd9724b58769a1593ff57242b18de09291a433ea37658015bd57f75e430ed95bdf99d3863fccfc4b546a9686933 analitza-17.12.2.tar.xz
c38ce1f8265224aebfa8dcf8ef93a83bb2abd4eb757add3a7578660753bf9f16cbd497c9d696f22a6345602585a06bf4bad2bd89b2ea75e70baf9f8739198da9 pmmx-test-failure.patch"
This diff is collapsed.
Click to expand it.
user/analitza/pmmx-test-failure.patch
0 → 100644
+
14
−
0
View file @
8837d763
diff --git a/analitza/commands/listcommands.cpp b/analitza/commands/listcommands.cpp
index b77f49a9..2885169a 100644
--- a/analitza/commands/listcommands.cpp
+++ b/analitza/commands/listcommands.cpp
@@ -69,8 +69,9 @@
Expression RangeCommand::operator()(const QList<Analitza::Expression >& args)
Analitza::List *seq = new Analitza::List;
- for (double x = a; x <= b; x += h)
+ for (double x = a; x < b || qFuzzyCompare(x, b); x += h) {
seq->appendBranch(new Analitza::Cn(x));
+ }
ret.setTree(seq);
This diff is collapsed.
Click to expand it.
Preview
0%
Loading
Try again
or
attach a new file
.
Cancel
You are about to add
0
people
to the discussion. Proceed with caution.
Finish editing this message first!
Save comment
Cancel
Please
register
or
sign in
to comment