Skip to content
Snippets Groups Projects
Verified Commit 87d8bca1 authored by Anna Wilcox's avatar Anna Wilcox :fox:
Browse files

user/akonadi-contacts: new package based on master

Signed-off-by: most of the people in #Adelie
parent 0f29b0b6
No related branches found
No related tags found
No related merge requests found
# Contributor: A. Wilcox <awilfox@adelielinux.org>
# Maintainer: A. Wilcox <awilfox@adelielinux.org>
pkgname=akonadi-contacts
pkgver=17.08.1.55
realpkgver=${pkgver/.55/-55}
pkgrel=0
pkgdesc="Library for integrating contact lists with Akonadi"
url="https://www.kde.org/"
arch="all"
license="LGPL-2.1 GPL-2.0 BSD-2"
depends=""
depends_dev="qt5-qtbase-dev kio-dev kcontacts-dev kmime-dev akonadi-mime-dev
prison-dev"
makedepends="$depends_dev cmake extra-cmake-modules"
install=""
subpackages="$pkgname-dev"
source="https://distfiles.adelielinux.org/source/akonadi-contacts-$realpkgver.tar.xz
build-without-trunk.patch"
builddir="$srcdir/akonadi-contacts-$realpkgver"
build() {
cd "$builddir"
if [ "$CBUILD" != "$CHOST" ]; then
CMAKE_CROSSOPTS="-DCMAKE_SYSTEM_NAME=Linux -DCMAKE_HOST_SYSTEM_NAME=Linux"
fi
cmake \
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_INSTALL_LIBDIR=lib \
-DBUILD_SHARED_LIBS=True \
-DCMAKE_BUILD_TYPE=RelWithDebugInfo \
-DCMAKE_CXX_FLAGS="$CXXFLAGS" \
-DCMAKE_C_FLAGS="$CFLAGS" \
${CMAKE_CROSSOPTS}
make
}
check() {
cd "$builddir"
CTEST_OUTPUT_ON_FAILURE=TRUE ctest
}
package() {
cd "$builddir"
make DESTDIR="$pkgdir" install
}
sha512sums="37bb7fa73efbbdcc59e5832b4e956eb9051d13de3232eb9bb812e4a8c37d326f99874b2f9e9653c36234d6c2c606fadeca1ab2b030eee1160dd1934b44e7d3b0 akonadi-contacts-17.08.1-55.tar.xz
f47a7c2f2c844d691dc688e953bdbf241f89bcda590fb066102a633babdd850eee53fedb04de8f172410266c29e224ca42ef01f1810ad6a128215e44193bb054 build-without-trunk.patch"
--- akonadi-contacts-17.08.1-55/CMakeLists.txt.old 2017-10-11 17:15:27.000000000 -0500
+++ akonadi-contacts-17.08.1-55/CMakeLists.txt 2017-10-11 17:31:53.667300461 -0500
@@ -25,10 +25,10 @@
set(AKONADI_CONTACTS_VERSION ${PIM_VERSION})
-set(AKONADI_MIME_VERSION "5.6.40")
-set(KCONTACTS_VERSION "5.6.40")
-set(KMIMELIB_VERSION "5.6.40")
-set(AKONADI_VERSION "5.6.40")
+set(AKONADI_MIME_VERSION "5.6.1")
+set(KCONTACTS_VERSION "5.6.1")
+set(KMIMELIB_VERSION "5.6.1")
+set(AKONADI_VERSION "5.6.1")
set(QT_REQUIRED_VERSION "5.8.0")
find_package(Qt5 ${QT_REQUIRED_VERSION} CONFIG REQUIRED Widgets Test)
0% Loading or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment