Skip to content
GitLab
Explore
Sign in
Register
Primary navigation
Search or go to…
Project
Adélie Package Tree
Manage
Activity
Members
Labels
Plan
Issues
Issue boards
Milestones
Wiki
Code
Merge requests
Repository
Branches
Commits
Tags
Repository graph
Compare revisions
Build
Pipelines
Jobs
Pipeline schedules
Artifacts
Help
Help
Support
GitLab documentation
Compare GitLab plans
Community forum
Contribute to GitLab
Provide feedback
Keyboard shortcuts
?
Snippets
Groups
Projects
Show more breadcrumbs
Adélie Linux
Adélie Package Tree
Commits
74a96529
Verified
Commit
74a96529
authored
5 years ago
by
Max Rees
Browse files
Options
Downloads
Patches
Plain Diff
user/catdoc: patch for CVE-2017-11110 (#160)
parent
e26f14b3
No related branches found
Branches containing commit
No related tags found
Tags containing commit
1 merge request
!307
CVE catch up, part one
Changes
2
Hide whitespace changes
Inline
Side-by-side
Showing
2 changed files
user/catdoc/APKBUILD
+9
-3
9 additions, 3 deletions
user/catdoc/APKBUILD
user/catdoc/CVE-2017-11110.patch
+32
-0
32 additions, 0 deletions
user/catdoc/CVE-2017-11110.patch
with
41 additions
and
3 deletions
user/catdoc/APKBUILD
+
9
−
3
View file @
74a96529
...
...
@@ -2,7 +2,7 @@
# Maintainer: A. Wilcox <awilfox@adelielinux.org>
pkgname
=
catdoc
pkgver
=
0.95
pkgrel
=
1
pkgrel
=
2
pkgdesc
=
"Read information and data from Microsoft Office documents"
url
=
"http://www.wagner.pp.ru/~vitus/software/catdoc/"
arch
=
"all"
...
...
@@ -11,7 +11,12 @@ license="GPL-2.0-only"
depends
=
""
makedepends
=
""
subpackages
=
"
$pkgname
-doc"
source
=
"http://ftp.wagner.pp.ru/pub/catdoc/catdoc-
$pkgver
.tar.gz"
source
=
"http://ftp.wagner.pp.ru/pub/catdoc/catdoc-
$pkgver
.tar.gz
CVE-2017-11110.patch"
# secfixes:
# 0.95-r2:
# - CVE-2017-11110
build
()
{
cd
"
$builddir
"
...
...
@@ -31,4 +36,5 @@ package() {
make
-j1
install
}
sha512sums
=
"dd6bded4b6b70749c007256b182b063ff266f86d53024d8582001678821e8096c5b980bc8f43015d9c82bbe022d71d4ba5fe68aff31b2ff6db3688595e651b2c catdoc-0.95.tar.gz"
sha512sums
=
"dd6bded4b6b70749c007256b182b063ff266f86d53024d8582001678821e8096c5b980bc8f43015d9c82bbe022d71d4ba5fe68aff31b2ff6db3688595e651b2c catdoc-0.95.tar.gz
15d1da9fe095c6e4a990faa22ee67952d91494057a1fd6334f2eb671898156c95245b54f229549a5662d13dec6ecc4e607583e865fb9775fea8d163755cf04b0 CVE-2017-11110.patch"
This diff is collapsed.
Click to expand it.
user/catdoc/CVE-2017-11110.patch
0 → 100644
+
32
−
0
View file @
74a96529
Description: CVE-2017-11110: Heap buffer overflow in ole_init
Origin: vendor, https://build.opensuse.org/package/view_file/openSUSE:Maintenance:6985/catdoc.openSUSE_Leap_42.2_Update/CVE-2017-11110.patch?rev=d437c3be72c2e5a3516b75f4e9de6b35
Bug-Debian: https://bugs.debian.org/867717
Bug-SuSE: https://bugzilla.novell.com/show_bug.cgi?id=1047877
Forwarded: no
Author: Andreas Stieger <astieger@suse.com>
Reviewed-by: Salvatore Bonaccorso <carnil@debian.org>
Last-Update: 2017-07-20
--- a/src/ole.c
+++ b/src/ole.c
@@ -106,6 +106,11 @@
FILE* ole_init(FILE *f, void *buffer, si
return NULL;
}
sectorSize = 1<<getshort(oleBuf,0x1e);
+ /* CVE-2017-11110 */
+ if (sectorSize < 4) {
+ fprintf(stderr, "sectorSize < 4 not supported\n");
+ return NULL;
+ }
shortSectorSize=1<<getshort(oleBuf,0x20);
/* Read BBD into memory */
@@ -147,7 +152,7 @@
FILE* ole_init(FILE *f, void *buffer, si
}
fseek(newfile, 512+mblock*sectorSize, SEEK_SET);
- if(fread(tmpBuf+MSAT_ORIG_SIZE+(sectorSize-4)*i,
+ if(fread(tmpBuf+MSAT_ORIG_SIZE+(sectorSize-4)*i, /* >=4 for CVE-2017-11110 */
1, sectorSize, newfile) != sectorSize) {
fprintf(stderr, "Error read MSAT!\n");
ole_finish();
This diff is collapsed.
Click to expand it.
Preview
0%
Loading
Try again
or
attach a new file
.
Cancel
You are about to add
0
people
to the discussion. Proceed with caution.
Finish editing this message first!
Save comment
Cancel
Please
register
or
sign in
to comment