Skip to content
Snippets Groups Projects
Verified Commit 72bedd94 authored by Max Rees's avatar Max Rees
Browse files

user/py3-packaging: fix dependencies, bump to 19.1

Depends on py3-attrs, py3-six, and py3-pyparsing which wasn't correctly
specified before.
parent 14c40633
No related branches found
No related tags found
1 merge request!313Misc package bumps for Maintainer: Max Rees, 2019.08.06
......@@ -4,32 +4,32 @@ pkgname=py3-packaging
_pkgname=packaging
_p="${_pkgname#?}"
_p="${_pkgname%"$_p"}"
pkgver=19.0
pkgver=19.1
pkgrel=0
pkgdesc="Core utilities for Python packages"
url="https://pypi.python.org/pypi/packaging"
arch="noarch"
# Certified net clean
license="Apache-2.0 AND BSD-2-Clause"
depends="python3"
depends="python3 py3-attrs py3-pyparsing py3-six"
makedepends="python3-dev"
checkdepends="py3-pytest py3-pretend py3-pyparsing"
source="$pkgname-$pkgver.tar.gz::https://files.pythonhosted.org/packages/source/$_p/$_pkgname/$_pkgname-$pkgver.tar.gz"
checkdepends="py3-pytest py3-pretend"
source="$pkgname-$pkgver.tar.gz::https://files.pythonhosted.org/packages/source/$_p/$_pkgname/$_pkgname-$pkgver.tar.gz
test-glibc.patch"
builddir="$srcdir/$_pkgname-$pkgver"
build() {
cd "$builddir"
python3 setup.py build
}
check() {
cd "$builddir/tests"
python3 -m pytest
PYTHONPATH="$builddir" pytest
}
package() {
cd "$builddir"
python3 setup.py install --prefix=/usr --root="$pkgdir"
}
sha512sums="aa55b6fbca764e7de2992e294b7be9dc90b25f88b64ba0cd2d1d93042402d4360b4c2cdc134a94b083da0c0bc83de8fa7185c0856bcc96fa25828c10a793fba7 py3-packaging-19.0.tar.gz"
sha512sums="1dec7f49c325801eb85b11432f8a316d228bb1881a04ac546f5556d60f5fa33f8085d0e91bbd5abfeb30bfcb05ec0532ed75a977dc996e256b4dc8c27c10e79b py3-packaging-19.1.tar.gz
d67e8f3eae1b7571edf705ba532e1c9a6dc4c241cb01dfeda8addb587c2039114b0e21e73140369e4a30d0256a2073ac877737458cb95006029e7ce44d0bae93 test-glibc.patch"
--- packaging-19.1/tests/test_tags.py 2019-07-20 01:03:21.000000000 -0400
+++ packaging-19.1/tests/test_tags.py 2019-08-06 09:08:16.490018542 -0400
@@ -474,6 +474,7 @@ def test_glibc_version_string(version_st
assert tags._glibc_version_string() is None
+@pytest.mark.skip(reason="musl is not glibc")
def test_have_compatible_glibc(monkeypatch):
if platform.system() == "Linux":
# Assuming no one is running this test with a version of glibc released in
0% Loading or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment