Skip to content
Snippets Groups Projects
Commit 72b3a190 authored by Anna Wilcox's avatar Anna Wilcox :fox:
Browse files

Merge branch 'alpine' into 'master'

user/alpine: new package



See merge request !212
parents c5f55774 3c624f44
No related branches found
No related tags found
No related merge requests found
# Contributor: Kiyoshi Aman <kiyoshi.aman+adelie@gmail.com>
# Maintainer: Kiyoshi Aman <kiyoshi.aman+adelie@gmail.com>
pkgname=alpine
pkgver=2.21
pkgrel=0
pkgdesc="Terminal-based email client"
url="http://alpine.x10host.com/alpine/"
arch="all"
license="Apache-2.0"
depends=""
makedepends="aspell-dev krb5-dev linux-pam-dev ncurses-dev openldap-dev
openssl-dev"
subpackages="$pkgname-doc"
source="http://alpine.x10host.com/alpine/release/src/alpine-$pkgver.tar.xz
support-musl.patch"
prepare() {
cd "$builddir"
default_prepare
autoreconf -vif
}
build() {
cd "$builddir"
./configure \
--build=$CBUILD \
--host=$CHOST \
--prefix=/usr \
--sysconfdir=/etc \
--mandir=/usr/share/man \
--localstatedir=/var
make
}
check() {
cd "$builddir"
make check
}
package() {
cd "$builddir"
make DESTDIR="$pkgdir" install
}
sha512sums="a2a36a033c8af79810816a7da7185c269808ba6d84d013691fd8b3764c63f5fb2284e6844ec5a5e99d168514ae636debf59fae962533a2916679e4e9109c6264 alpine-2.21.tar.xz
cdf827b5947fd14b6a6c1ad86df4ff1b8be1ffd51279aaa02376b2b60f3de742c54364e18d73d9a75c5c87ed3c8668a3f0c9eb59733f8da195e85833b4364782 support-musl.patch"
--- ./configure.ac.orig
+++ ./configure.ac
@@ -723,7 +723,7 @@
else
dnl preload c-client default locations/options
case $host in
- *-linux-gnu*|*-k*bsd*-gnu*|*-gnu*)
+ *-linux-gnu*|*-k*bsd*-gnu*|*-gnu*|*-linux-musl*)
if test -f /etc/fedora-release -o -f /etc/redhat-release -o -f /etc/redhat_version ; then
alpine_SSLTYPE="nopwd"
if test -d /etc/pki/tls ; then
@@ -1059,7 +1059,7 @@
dnl build from c-client. Most of this will go away when c-client
dnl adopts configure
case "$host" in
- *-linux-gnu*|*-k*bsd*-gnu*|*-gnu*)
+ *-linux-gnu*|*-k*bsd*-gnu*|*-gnu*|*-linux-musl*)
alpine_path_delim="/"
alpine_mode_readonly="(0600)"
if test -f /etc/fedora-release ; then
0% Loading or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment