Skip to content
GitLab
Explore
Sign in
Register
Primary navigation
Search or go to…
Project
Adélie Package Tree
Manage
Activity
Members
Labels
Plan
Issues
Issue boards
Milestones
Wiki
Code
Merge requests
Repository
Branches
Commits
Tags
Repository graph
Compare revisions
Build
Pipelines
Jobs
Pipeline schedules
Artifacts
Help
Help
Support
GitLab documentation
Compare GitLab plans
Community forum
Contribute to GitLab
Provide feedback
Keyboard shortcuts
?
Snippets
Groups
Projects
Show more breadcrumbs
Adélie Linux
Adélie Package Tree
Commits
71c77f31
Verified
Commit
71c77f31
authored
4 years ago
by
Anna Wilcox
Browse files
Options
Downloads
Patches
Plain Diff
user/horizon: Fix issue with runner logging
parent
925fabf5
No related branches found
No related tags found
No related merge requests found
Changes
2
Hide whitespace changes
Inline
Side-by-side
Showing
2 changed files
user/horizon/APKBUILD
+6
-3
6 additions, 3 deletions
user/horizon/APKBUILD
user/horizon/fix-qt-runner.patch
+25
-0
25 additions, 0 deletions
user/horizon/fix-qt-runner.patch
with
31 additions
and
3 deletions
user/horizon/APKBUILD
+
6
−
3
View file @
71c77f31
...
...
@@ -2,7 +2,7 @@
# Maintainer: A. Wilcox <awilfox@adelielinux.org>
pkgname
=
horizon
pkgver
=
0.9.1
pkgrel
=
0
pkgrel
=
1
pkgdesc
=
"Installation tools for Adélie Linux"
url
=
"https://horizon.adelielinux.org/"
arch
=
"all"
...
...
@@ -17,7 +17,9 @@ makedepends="bcnm-dev boost-dev cmake curl-dev eudev-dev libarchive-dev
libcap-dev libx11-dev libxkbfile-dev qt5-qtbase-dev"
subpackages
=
"
$pkgname
-image
$pkgname
-dbg
$pkgname
-dev
$pkgname
-doc
$pkgname
-qt5
$pkgname
-tools
$pkgname
-wizard"
source
=
"https://distfiles.adelielinux.org/source/horizon-
$pkgver
.tar.xz"
source
=
"https://distfiles.adelielinux.org/source/horizon-
$pkgver
.tar.xz
fix-qt-runner.patch
"
build
()
{
if
[
"
$CBUILD
"
!=
"
$CHOST
"
]
;
then
...
...
@@ -97,4 +99,5 @@ wizard() {
rm
-r
"
$subpkgdir
"
/usr/share
}
sha512sums
=
"fe8f58a232b7e577aeba62cecfd97bec4037d41dd179781af912c9974210ce4648b0c56bd84fbf78866698e91882b8f4b7168c22842bde1682ea118ca931832f horizon-0.9.1.tar.xz"
sha512sums
=
"fe8f58a232b7e577aeba62cecfd97bec4037d41dd179781af912c9974210ce4648b0c56bd84fbf78866698e91882b8f4b7168c22842bde1682ea118ca931832f horizon-0.9.1.tar.xz
78d1a1bca7d12a189d506e1fcc42ea0ab968ed3cb9ada7e95fab6256ea2e0cb820d9b41cdd858e22da37a63f899918fe40c00bcd2d67dea81e3a9ce30570ad46 fix-qt-runner.patch"
This diff is collapsed.
Click to expand it.
user/horizon/fix-qt-runner.patch
0 → 100644
+
25
−
0
View file @
71c77f31
From 9f737dbab8b9ed9fa57bdf15542cc00a8363d98b Mon Sep 17 00:00:00 2001
From: "A. Wilcox" <AWilcox@Wilcox-Tech.com>
Date: Thu, 4 Jun 2020 21:29:37 -0500
Subject: [PATCH] Qt UI: Ensure log is opened when built in release modes
---
ui/qt5/runner/executepage.cc | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/ui/qt5/runner/executepage.cc b/ui/qt5/runner/executepage.cc
index 999731a..d5788df 100644
--- a/ui/qt5/runner/executepage.cc
+++ b/ui/qt5/runner/executepage.cc
@@ -48,7 +48,7 @@
ExecutePage::ExecutePage(QWidget *parent) : HorizonWizardPage(parent) {
});
log.setFileName("/var/log/horizon/executor.log");
- Q_ASSERT(log.open(QFile::Append));
+ log.open(QFile::Append);
this->current = Prepare;
markRunning(this->current);
--
2.25.4
This diff is collapsed.
Click to expand it.
Preview
0%
Loading
Try again
or
attach a new file
.
Cancel
You are about to add
0
people
to the discussion. Proceed with caution.
Finish editing this message first!
Save comment
Cancel
Please
register
or
sign in
to comment