Skip to content
GitLab
Explore
Sign in
Register
Primary navigation
Search or go to…
Project
Adélie Package Tree
Manage
Activity
Members
Labels
Plan
Issues
Issue boards
Milestones
Wiki
Code
Merge requests
Repository
Branches
Commits
Tags
Repository graph
Compare revisions
Build
Pipelines
Jobs
Pipeline schedules
Artifacts
Help
Help
Support
GitLab documentation
Compare GitLab plans
Community forum
Contribute to GitLab
Provide feedback
Keyboard shortcuts
?
Snippets
Groups
Projects
Show more breadcrumbs
Adélie Linux
Adélie Package Tree
Commits
6b2b39c0
Verified
Commit
6b2b39c0
authored
6 years ago
by
Anna Wilcox
Browse files
Options
Downloads
Patches
Plain Diff
harmony/gsl: fix license and aarch64 build
parent
b089308d
No related branches found
Branches containing commit
No related tags found
Tags containing commit
No related merge requests found
Changes
2
Hide whitespace changes
Inline
Side-by-side
Showing
2 changed files
harmony/gsl/APKBUILD
+8
-7
8 additions, 7 deletions
harmony/gsl/APKBUILD
harmony/gsl/aarch64-test-failure.patch
+13
-0
13 additions, 0 deletions
harmony/gsl/aarch64-test-failure.patch
with
21 additions
and
7 deletions
harmony/gsl/APKBUILD
+
8
−
7
View file @
6b2b39c0
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
# Contributor: Natanael Copa <ncopa@alpinelinux.org>
# Maintainer: A. Wilcox <awilfox@adelielinux.org>
pkgname
=
gsl
pkgver
=
2.4
pkgrel
=
1
pkgrel
=
2
pkgdesc
=
"The GNU Scientific Library (GSL) is a modern numerical library for C and C++ programmers"
url
=
"http://www.gnu.org/software/gsl/gsl.html"
arch
=
"all"
license
=
"GPL"
license
=
"GPL
-3.0+
"
depends
=
makedepends
=
install
=
subpackages
=
"
$pkgname
-dev
$pkgname
-doc"
source
=
"http://ftp.gnu.org/gnu/gsl/gsl-
$pkgver
.tar.gz
dont-disable-deprecated.patch"
dont-disable-deprecated.patch
aarch64-test-failure.patch"
# dont-disable-deprecated.patch is workaround for:
# https://github.com/SciRuby/rb-gsl/issues/40
builddir
=
"
$srcdir
"
/
$pkgname
-
$pkgver
build
()
{
cd
"
$builddir
"
./configure
\
...
...
@@ -38,4 +38,5 @@ package() {
}
sha512sums
=
"12442b023dd959e8b22a9c486646b5cedec7fdba0daf2604cda365cf96d10d99aefdec2b42e59c536cc071da1525373454e5ed6f4b15293b305ca9b1dc6db130 gsl-2.4.tar.gz
88d40e599a9e619d8968f9848a91c54492d99032734371ee23072c8dae9d9920da445c1f8a880baa613479facec4afca3d3dec1070c240e5dfd5a662a41c92e8 dont-disable-deprecated.patch"
88d40e599a9e619d8968f9848a91c54492d99032734371ee23072c8dae9d9920da445c1f8a880baa613479facec4afca3d3dec1070c240e5dfd5a662a41c92e8 dont-disable-deprecated.patch
68b685270a377341b3c3ce566ae6eff4ebfc27b75a73f3c7915c57446798bdcca7c1d9f0fa4ce8a50118b371bfe3e2947f9bf33590c86e85db8e807b3b0deae6 aarch64-test-failure.patch"
This diff is collapsed.
Click to expand it.
harmony/gsl/aarch64-test-failure.patch
0 → 100644
+
13
−
0
View file @
6b2b39c0
https://lists.gnu.org/archive/html/help-gsl/2017-02/msg00002.html
--- gsl-2.4/linalg/test_cholesky.c.old 2017-06-19 10:00:43.000000000 +0000
+++ gsl-2.4/linalg/test_cholesky.c 2018-05-30 07:37:04.835628069 +0000
@@ -551,7 +551,7 @@
if (N <= 4)
{
create_hilbert_matrix2(m);
- test_mcholesky_invert_eps(m, 256.0 * N * GSL_DBL_EPSILON, "mcholesky_invert unscaled hilbert");
+ test_mcholesky_invert_eps(m, 512.0 * N * GSL_DBL_EPSILON, "mcholesky_invert unscaled hilbert");
}
gsl_matrix_free(m);
This diff is collapsed.
Click to expand it.
Preview
0%
Loading
Try again
or
attach a new file
.
Cancel
You are about to add
0
people
to the discussion. Proceed with caution.
Finish editing this message first!
Save comment
Cancel
Please
register
or
sign in
to comment