Skip to content
GitLab
Explore
Sign in
Register
Primary navigation
Search or go to…
Project
Adélie Package Tree
Manage
Activity
Members
Labels
Plan
Issues
Issue boards
Milestones
Wiki
Code
Merge requests
Repository
Branches
Commits
Tags
Repository graph
Compare revisions
Build
Pipelines
Jobs
Pipeline schedules
Artifacts
Help
Help
Support
GitLab documentation
Compare GitLab plans
Community forum
Contribute to GitLab
Provide feedback
Keyboard shortcuts
?
Snippets
Groups
Projects
Show more breadcrumbs
Adélie Linux
Adélie Package Tree
Commits
69b47e06
Commit
69b47e06
authored
4 years ago
by
Nathan Owens
Committed by
Nathan Owens
4 years ago
Browse files
Options
Downloads
Patches
Plain Diff
system/json-c: upgrade to 0.15
parent
f7628676
No related branches found
Branches containing commit
No related tags found
Tags containing commit
1 merge request
!535
system/json-c: upgrade to 0.15
Changes
2
Hide whitespace changes
Inline
Side-by-side
Showing
2 changed files
system/json-c/APKBUILD
+15
-31
15 additions, 31 deletions
system/json-c/APKBUILD
system/json-c/fix-libdir.patch
+0
-11
0 additions, 11 deletions
system/json-c/fix-libdir.patch
with
15 additions
and
42 deletions
system/json-c/APKBUILD
+
15
−
31
View file @
69b47e06
# Maintainer:
pkgname
=
json-c
pkgver
=
0.1
3.1
pkgrel
=
1
pkgver
=
0.1
5
pkgrel
=
0
pkgdesc
=
"A JSON implementation in C"
url
=
"https://github.com/json-c/json-c/wiki"
arch
=
"all"
license
=
"MIT"
depends
=
""
makedepends
=
"
autoconf automake libtool
"
subpackages
=
"
$pkgname
-static
$pkgname
-dev"
makedepends
=
"
cmake doxygen
"
subpackages
=
"
$pkgname
-dev"
source
=
"https://s3.amazonaws.com/
${
pkgname
}
_releases/releases/
$pkgname
-
${
pkgver
}
.tar.gz
fix-libdir.patch
"
prepare
()
{
default_prepare
autoreconf
-f
-v
-i
}
# secfixes:
# 0.15-r0:
# - CVE-2020-12762
build
()
{
export
CFLAGS
=
"
${
CFLAGS
}
-Wno-error=unused-but-set-variable"
./configure
--prefix
=
/usr
\
--build
=
$CBUILD
\
--host
=
$CHOST
\
--libdir
=
/lib
\
--sysconfdir
=
/etc
\
--mandir
=
/usr/share/man
\
--infodir
=
/usr/share/info
\
--localstatedir
=
/var
\
--enable-shared
\
ac_cv_func_malloc_0_nonnull
=
yes
\
ac_cv_func_realloc_0_nonnull
=
yes
make
-j1
cmake
-B
"
$builddir
"
\
-DCMAKE_INSTALL_PREFIX
=
/usr
\
-DCMAKE_INSTALL_LIBDIR
=
lib
\
-DBUILD_SHARED_LIBS
=
ON
make
make doc
}
check
()
{
make
check
make
test
}
package
()
{
make
-j1
DESTDIR
=
"
$pkgdir
"
install
}
static
()
{
pkgdesc
=
"Static JSON C library"
mkdir
-p
"
$subpkgdir
"
/lib
mv
"
$pkgdir
"
/lib/
*
.a
"
$subpkgdir
"
/lib/
}
sha512sums
=
"e984db2a42b9c95b52c798b2e8dd1b79951a8dcba27370af30c43b9549fbb00008dbcf052a535c528209aaee38e6d1f760168b706905ae72f3e704ed20f8a1a1 json-c-0.13.1.tar.gz
939f2b02fe5beb5d85ebc3fd8463bee0cff6b7da98b48edb599e88dda7955b6ba65afc17f9e828025086a1b384aa99703be06b6613e405d9c48541cf52c380f0 fix-libdir.patch"
sha512sums
=
"dc01298bcc78f0f31a34f5fcfe45c0feebfd88518e97fb4f96f1a652f71ccdd303415a4c7bf5b573bdcbcca80428281f0dfccefc6545ea3a7f18dbb819332f34 json-c-0.15.tar.gz"
This diff is collapsed.
Click to expand it.
system/json-c/fix-libdir.patch
deleted
100644 → 0
+
0
−
11
View file @
f7628676
--- json-c-0.13.1/Makefile.am.old 2018-03-06 04:13:22.000000000 +0000
+++ json-c-0.13.1/Makefile.am 2018-07-19 02:12:00.270000000 +0000
@@ -14,7 +14,7 @@
lib_LTLIBRARIES = libjson-c.la
-pkgconfigdir = $(libdir)/pkgconfig
+pkgconfigdir = /usr/lib/pkgconfig
pkgconfig_DATA = json-c.pc
libjson_cincludedir = $(includedir)/json-c
This diff is collapsed.
Click to expand it.
Zach van Rijn
@z
mentioned in issue
#407 (closed)
·
3 years ago
mentioned in issue
#407 (closed)
mentioned in issue #407
Toggle commit list
Preview
0%
Loading
Try again
or
attach a new file
.
Cancel
You are about to add
0
people
to the discussion. Proceed with caution.
Finish editing this message first!
Save comment
Cancel
Please
register
or
sign in
to comment