Skip to content
GitLab
Explore
Sign in
Register
Primary navigation
Search or go to…
Project
Adélie Package Tree
Manage
Activity
Members
Labels
Plan
Issues
Issue boards
Milestones
Wiki
Code
Merge requests
Repository
Branches
Commits
Tags
Repository graph
Compare revisions
Build
Pipelines
Jobs
Pipeline schedules
Artifacts
Help
Help
Support
GitLab documentation
Compare GitLab plans
Community forum
Contribute to GitLab
Provide feedback
Keyboard shortcuts
?
Snippets
Groups
Projects
Show more breadcrumbs
Adélie Linux
Adélie Package Tree
Commits
69acbb3f
Commit
69acbb3f
authored
6 years ago
by
Max Rees
Browse files
Options
Downloads
Patches
Plain Diff
user/py3-virtualenv: options=net because virtualenvs are stupid
parent
e9c9bbec
No related branches found
Branches containing commit
No related tags found
Tags containing commit
1 merge request
!97
Update some Python packages and drop py3-tox rdeps where unnecessary
Changes
2
Hide whitespace changes
Inline
Side-by-side
Showing
2 changed files
user/py3-virtualenv/APKBUILD
+4
-3
4 additions, 3 deletions
user/py3-virtualenv/APKBUILD
user/py3-virtualenv/test-python3.6.patch
+22
-0
22 additions, 0 deletions
user/py3-virtualenv/test-python3.6.patch
with
26 additions
and
3 deletions
user/py3-virtualenv/APKBUILD
+
4
−
3
View file @
69acbb3f
...
@@ -7,12 +7,13 @@ pkgrel=0
...
@@ -7,12 +7,13 @@ pkgrel=0
pkgdesc
=
"Virtual Python Environment builder"
pkgdesc
=
"Virtual Python Environment builder"
url
=
"https://pypi.org/project/virtualenv"
url
=
"https://pypi.org/project/virtualenv"
arch
=
"noarch"
arch
=
"noarch"
options
=
"net"
license
=
"MIT"
license
=
"MIT"
depends
=
"python3"
depends
=
"python3"
makedepends
=
"python3-dev"
makedepends
=
"python3-dev"
checkdepends
=
"py3-pytest cmd:which"
checkdepends
=
"py3-pytest cmd:which"
source
=
"
$pkgname
-
$pkgver
.tar.gz::https://files.pythonhosted.org/packages/source/
${
_pkgname
:0:1
}
/
$_pkgname
/
$_pkgname
-
$pkgver
.tar.gz
source
=
"
$pkgname
-
$pkgver
.tar.gz::https://files.pythonhosted.org/packages/source/
v
/
$_pkgname
/
$_pkgname
-
$pkgver
.tar.gz
test-python3.patch"
test-python3.
6.
patch"
builddir
=
"
$srcdir
/
$_pkgname
-
$pkgver
"
builddir
=
"
$srcdir
/
$_pkgname
-
$pkgver
"
build
()
{
build
()
{
...
@@ -34,4 +35,4 @@ package() {
...
@@ -34,4 +35,4 @@ package() {
}
}
sha512sums
=
"43bc37f1da1b65e9a2df5a8813a801f27f5783b7211219d441d1c2132789917df42fdc0aba1d5ec51e3d6f7583af9474d59c1f532d8880c8c325ccc96e73b3df py3-virtualenv-16.0.0.tar.gz
sha512sums
=
"43bc37f1da1b65e9a2df5a8813a801f27f5783b7211219d441d1c2132789917df42fdc0aba1d5ec51e3d6f7583af9474d59c1f532d8880c8c325ccc96e73b3df py3-virtualenv-16.0.0.tar.gz
8e022416eb10289fd5215f3810203eefb450ce2fca7bdc581b5cd1892f41f34815beec35fc6c744991536c1f2edebd58ab934a4414c6fe2ae6387aea02787ef8
test-python3.patch"
9c68dcda515dfc974433c9a68d81be0b028a7967eebb1b6d1d912c3859c7925fe970f1668ac9e406768de91ed32b27b3b8ea7a4939f8adc7a09e1bf904df10b9
test-python3.
6.
patch"
This diff is collapsed.
Click to expand it.
user/py3-virtualenv/test-python3.patch
→
user/py3-virtualenv/test-python3.
6.
patch
+
22
−
0
View file @
69acbb3f
...
@@ -72,3 +72,25 @@
...
@@ -72,3 +72,25 @@
import os, sys
import os, sys
expected_site_packages = os.path.join(os.environ['TESTENV'], 'lib','python%s' % sys.version[:3], 'site-packages')
expected_site_packages = os.path.join(os.environ['TESTENV'], 'lib','python%s' % sys.version[:3], 'site-packages')
--- virtualenv-16.0.0/setup.py 2018-05-16 19:36:07.000000000 -0400
+++ virtualenv-16.0.0/setup.py 2018-10-22 20:56:04.691681656 -0400
@@ -33,7 +33,7 @@
try:
},
'zip_safe': False,
'cmdclass': {'test': PyTest},
- 'tests_require': ['pytest', 'mock'],
+ 'tests_require': ['pytest'],
}
except ImportError:
from distutils.core import setup
--- virtualenv-16.0.0/tests/test_virtualenv.py 2018-05-16 19:36:07.000000000 -0400
+++ virtualenv-16.0.0/tests/test_virtualenv.py 2018-10-22 20:56:38.771682266 -0400
@@ -7,7 +7,7 @@
import tempfile
import pytest
import platform # noqa
-from mock import patch, Mock
+from unittest.mock import patch, Mock
def test_version():
This diff is collapsed.
Click to expand it.
Preview
0%
Loading
Try again
or
attach a new file
.
Cancel
You are about to add
0
people
to the discussion. Proceed with caution.
Finish editing this message first!
Save comment
Cancel
Please
register
or
sign in
to comment