Skip to content
GitLab
Explore
Sign in
Register
Primary navigation
Search or go to…
Project
Adélie Package Tree
Manage
Activity
Members
Labels
Plan
Issues
Issue boards
Milestones
Wiki
Code
Merge requests
Repository
Branches
Commits
Tags
Repository graph
Compare revisions
Build
Pipelines
Jobs
Pipeline schedules
Artifacts
Help
Help
Support
GitLab documentation
Compare GitLab plans
Community forum
Contribute to GitLab
Provide feedback
Keyboard shortcuts
?
Snippets
Groups
Projects
Show more breadcrumbs
Adélie Linux
Adélie Package Tree
Commits
6158245f
Verified
Commit
6158245f
authored
4 years ago
by
Anna Wilcox
Browse files
Options
Downloads
Patches
Plain Diff
user/horizon: Update to 0.9.6
parent
d62b118a
No related branches found
Branches containing commit
No related tags found
Tags containing commit
No related merge requests found
Changes
2
Hide whitespace changes
Inline
Side-by-side
Showing
2 changed files
user/horizon/APKBUILD
+4
-7
4 additions, 7 deletions
user/horizon/APKBUILD
user/horizon/bootloader.patch
+0
-94
0 additions, 94 deletions
user/horizon/bootloader.patch
with
4 additions
and
101 deletions
user/horizon/APKBUILD
+
4
−
7
View file @
6158245f
# Contributor: A. Wilcox <awilfox@adelielinux.org>
# Maintainer: A. Wilcox <awilfox@adelielinux.org>
pkgname
=
horizon
pkgver
=
0.9.
5
pkgrel
=
1
pkgver
=
0.9.
6
pkgrel
=
0
pkgdesc
=
"Installation tools for Adélie Linux"
url
=
"https://horizon.adelielinux.org/"
arch
=
"all"
...
...
@@ -17,9 +17,7 @@ makedepends="bcnm-dev boost-dev cmake curl-dev eudev-dev libarchive-dev
libcap-dev libx11-dev libxkbfile-dev qt5-qtbase-dev"
subpackages
=
"
$pkgname
-image
$pkgname
-dbg
$pkgname
-dev
$pkgname
-doc
$pkgname
-qt5
$pkgname
-tools
$pkgname
-wizard
$pkgname
-boot"
source
=
"https://distfiles.adelielinux.org/source/horizon-
$pkgver
.tar.xz
bootloader.patch
"
source
=
"https://distfiles.adelielinux.org/source/horizon-
$pkgver
.tar.xz"
build
()
{
if
[
"
$CBUILD
"
!=
"
$CHOST
"
]
;
then
...
...
@@ -158,5 +156,4 @@ GLOBALS
"
$subpkgdir
"
/usr/share/xsessions/horizon.desktop
}
sha512sums
=
"373cbf87aa468d0ea41abad07f61cdaa6088cfdcba13c0beff245dbd8e270aa42c3e301a22913299d148e829114bd0b5aa746541c4b4b0c7286da35015c54d88 horizon-0.9.5.tar.xz
88e7c6df4dc2c8c7f6befd5f96f82267fefccb98d0c5e6c26c611323e505f7ee964dcfd2128dbe165c064d953e7afef2787ab49a6c4a834ffe8fd50c00eb26ae bootloader.patch"
sha512sums
=
"d5ffe9bd423e98272ca780c59e6e32c42b284c68f3a0bace07bd693d457e2edcd68d7fc03f638b545960154ea26b7c09feee083dbffa986da2a7cd418be9500f horizon-0.9.6.tar.xz"
This diff is collapsed.
Click to expand it.
user/horizon/bootloader.patch
deleted
100644 → 0
+
0
−
94
View file @
d62b118a
From 3658104dcc622e69a64cf97fbc9ed477f3faed6c Mon Sep 17 00:00:00 2001
From: "A. Wilcox" <AWilcox@Wilcox-Tech.com>
Date: Wed, 30 Sep 2020 19:19:59 -0500
Subject: [PATCH] meta: Run update-boot when bootloader requested
MIME-Version: 1.0
Content-Type: text/plain; charset=UTF-8
Content-Transfer-Encoding: 8bit
If the user chooses no-boot or isn't installing Adélie, this will fail
quietly. But if the user is installing Adélie, this is necessary to
generate bootloader configuration.
---
hscript/meta.cc | 26 ++++++++++++++++++++------
1 file changed, 20 insertions(+), 6 deletions(-)
diff --git a/hscript/meta.cc b/hscript/meta.cc
index 4efdc80..84e851a 100644
--- a/hscript/meta.cc
+++ b/hscript/meta.cc
@@ -823,7 +823,7 @@
bool Bootloader::execute() const {
<< std::endl
<< "chroot " << script->targetDirectory()
<< " grub-install " << _device << std::endl;
- return true;
+ goto updateboot;
}
#ifdef HAS_INSTALL_ENV
if(run_command("/sbin/apk",
@@ -851,8 +851,8 @@
bool Bootloader::execute() const {
mount(nullptr, efipath.c_str(), nullptr,
MS_REMOUNT | MS_BIND | MS_RDONLY | MS_NOEXEC | MS_NODEV |
MS_NOSUID | MS_RELATIME, nullptr);
+ goto updateboot;
#endif /* HAS_INSTALL_ENV */
- return true; /* LCOV_EXCL_LINE */
}
else if(method == "grub-bios") {
if(script->options().test(Simulate)) {
@@ -861,7 +861,7 @@
bool Bootloader::execute() const {
<< std::endl
<< "chroot " << script->targetDirectory()
<< " grub-install " << _device << std::endl;
- return true;
+ goto updateboot;
}
#ifdef HAS_INSTALL_ENV
if(run_command("/sbin/apk",
@@ -876,8 +876,8 @@
bool Bootloader::execute() const {
output_error(pos, "bootloader: failed to install GRUB");
return false;
}
+ goto updateboot;
#endif /* HAS_INSTALL_ENV */
- return true; /* LCOV_EXCL_LINE */
}
else if(method == "iquik") {
output_error(pos, "bootloader: iQUIK is not yet supported");
@@ -891,7 +891,7 @@
bool Bootloader::execute() const {
<< "chroot " << script->targetDirectory()
<< " grub-install --macppc-directory=/boot/grub "
<< _device << std::endl;
- return true;
+ goto updateboot;
}
#ifdef HAS_INSTALL_ENV
if(run_command("/sbin/apk",
@@ -907,9 +907,23 @@
bool Bootloader::execute() const {
output_error(pos, "bootloader: failed to install GRUB");
return false;
}
+ goto updateboot;
#endif /* HAS_INSTALL_ENV */
- return true; /* LCOV_EXCL_LINE */
}
return false; /* LCOV_EXCL_LINE */
+
+updateboot:
+ /* We ignore if update-boot fails, in case the user has chosen no-boot. */
+ if(script->options().test(Simulate)) {
+ std::cout << "chroot " << script->targetDirectory()
+ << " /usr/sbin/update-boot || true" << std::endl;
+ }
+#ifdef HAS_INSTALL_ENV
+ else {
+ run_command("chroot",
+ {script->targetDirectory(), "/usr/sbin/update-boot"});
+ }
+#endif /* HAS_INSTALL_ENV */
+ return true;
}
--
2.25.4
This diff is collapsed.
Click to expand it.
Preview
0%
Loading
Try again
or
attach a new file
.
Cancel
You are about to add
0
people
to the discussion. Proceed with caution.
Finish editing this message first!
Save comment
Cancel
Please
register
or
sign in
to comment