Skip to content
GitLab
Explore
Sign in
Register
Primary navigation
Search or go to…
Project
Adélie Package Tree
Manage
Activity
Members
Labels
Plan
Issues
Issue boards
Milestones
Wiki
Code
Merge requests
Repository
Branches
Commits
Tags
Repository graph
Compare revisions
Build
Pipelines
Jobs
Pipeline schedules
Artifacts
Help
Help
Support
GitLab documentation
Compare GitLab plans
Community forum
Contribute to GitLab
Provide feedback
Keyboard shortcuts
?
Snippets
Groups
Projects
Show more breadcrumbs
Adélie Linux
Adélie Package Tree
Commits
5ba732fc
Verified
Commit
5ba732fc
authored
6 years ago
by
Anna Wilcox
Browse files
Options
Downloads
Patches
Plain Diff
experimental/erlang: new package (does not pass tests)
parent
9c9e18e9
No related branches found
Branches containing commit
No related tags found
Tags containing commit
No related merge requests found
Changes
2
Hide whitespace changes
Inline
Side-by-side
Showing
2 changed files
experimental/erlang/APKBUILD
+57
-0
57 additions, 0 deletions
experimental/erlang/APKBUILD
experimental/erlang/fix-wx-linking.patch
+11
-0
11 additions, 0 deletions
experimental/erlang/fix-wx-linking.patch
with
68 additions
and
0 deletions
experimental/erlang/APKBUILD
0 → 100644
+
57
−
0
View file @
5ba732fc
# Contributor: A. Wilcox <awilfox@adelielinux.org>
# Maintainer: A. Wilcox <awilfox@adelielinux.org>
pkgname
=
erlang
pkgver
=
21.2
pkgrel
=
0
pkgdesc
=
"Soft real-time system programming language"
url
=
"https://www.erlang.org/"
arch
=
"all"
license
=
"Apache-2.0"
depends
=
""
makedepends
=
"libxml2-utils libxslt-dev m4 ncurses-dev openssl-dev perl
unixodbc-dev"
subpackages
=
"
$pkgname
-dev
$pkgname
-doc"
source
=
"http://erlang.org/download/otp_src_
$pkgver
.tar.gz
fix-wx-linking.patch
"
builddir
=
"
$srcdir
/otp_src_
$pkgver
"
build
()
{
cd
"
$builddir
"
./configure
\
--build
=
$CBUILD
\
--host
=
$CHOST
\
--prefix
=
/usr
\
--sysconfdir
=
/etc
\
--mandir
=
/usr/share/man
\
--localstatedir
=
/var
\
--enable-shared-zlib
\
--enable-ssl
=
dynamic-ssl-lib
\
--enable-threads
make
}
check
()
{
local
_header
cd
"
$builddir
"
export
ERL_TOP
=
$builddir
make release_tests
for
_header
in
erl_fixed_size_int_types.h
\
${
CHOST
}
/erl_int_sizes_config.h
\
erl_memory_trace_parser.h
;
do
cp
erts/include/
$_header
erts/emulator/beam/
done
cd
release/tests/test_server
$ERL_TOP
/bin/erl
-s
ts
install
-s
ts smoke_test batch
-s
init stop
}
package
()
{
cd
"
$builddir
"
make
DESTDIR
=
"
$pkgdir
"
install
}
sha512sums
=
"5707ef0d49a9af12cd9d93c3e4fd200092773645838bbe0163782d0fa40562d2b48bdb07f0e650311bfec896ed9e3c9621b4d0ba114c578d7ca3209c2a96ac24 otp_src_21.2.tar.gz
5f1b05d8be71d5e3d7e8c5ad019329af8f68174251b5b6e0a9ee9cb3da51a10983b8696e23b3954c19de5d54783ec16f38c80c74724341dbafb22fcac83c77d4 fix-wx-linking.patch"
This diff is collapsed.
Click to expand it.
experimental/erlang/fix-wx-linking.patch
0 → 100644
+
11
−
0
View file @
5ba732fc
--- otp_src_21.2/lib/wx/configure.old 2018-12-10 20:11:00.000000000 +0000
+++ otp_src_21.2/lib/wx/configure 2019-02-24 22:16:37.340000000 +0000
@@ -5765,7 +5765,7 @@
// it isn't in too old wxWidgets versions
wxString test = wxString::FromUTF8((const char *)"foo");
wxStyledTextCtrl * foo = new wxStyledTextCtrl();
- wxGLCanvas * bar = new wxGLCanvas((wxWindow *) NULL, -1,
+ wxGLCanvas * bar = new wxGLCanvas((wxWindow *) NULL, -1, NULL,
wxDefaultPosition,wxDefaultSize,0);
return true;
};
This diff is collapsed.
Click to expand it.
Anna Wilcox
@awilfox
mentioned in issue
#1227
·
7 months ago
mentioned in issue
#1227
mentioned in issue #1227
Toggle commit list
Preview
0%
Loading
Try again
or
attach a new file
.
Cancel
You are about to add
0
people
to the discussion. Proceed with caution.
Finish editing this message first!
Save comment
Cancel
Please
register
or
sign in
to comment