Skip to content
Snippets Groups Projects
Verified Commit 54003d7a authored by Anna Wilcox's avatar Anna Wilcox :fox:
Browse files

{experimental => user}/openjdk7: new package

parent 3bb3a78b
No related branches found
No related tags found
No related merge requests found
Showing
with 208 additions and 15 deletions
......@@ -10,11 +10,11 @@ pkgrel=0
pkgdesc="OpenJDK 7 via IcedTea"
url="https://icedtea.classpath.org/"
arch="all"
license="GPL-2.0 with Classpath"
license="GPL-2.0-only WITH Classpath-exception-2.0"
depends="$pkgname-jre java-cacerts"
options="sover-namecheck"
makedepends="bash findutils zip file paxmark mawk util-linux libxslt
autoconf automake linux-headers coreutils
makedepends="bash findutils zip file mawk util-linux libxslt
autoconf automake linux-headers coreutils cmd:which
ca-certificates
nss-dev cups-dev libjpeg-turbo-dev giflib-dev libpng-dev libxt-dev
lcms2-dev libxp-dev libxtst-dev libxinerama-dev zlib-dev
......@@ -37,6 +37,8 @@ arm*) _jarch=arm
options="$options textrels";;
s390x) _jarch=s390x;;
ppc64le) _jarch=ppc64le;;
ppc64) _jarch=ppc64
export CFLAGS="$CFLAGS -DABI_ELFv2";;
esac
INSTALL_BASE=/usr/lib/jvm/java-1.7-openjdk
......@@ -82,6 +84,11 @@ source="https://icedtea.classpath.org/download/source/icedtea-$_icedteaver.tar.g
icedtea-jdk-musl.patch
icedtea-jdk-no-soname.patch
icedtea-cpio.patch
icedtea-tar.patch
icedtea-remove-gawk.patch
icedtea-xattr.patch
remove-gawk.patch
xattr.patch
"
# secfixes:
......@@ -178,9 +185,8 @@ build() {
--with-jaxws-src-zip=$srcdir/jaxws-$_dropsver.tar.bz2 \
--with-jdk-src-zip=$srcdir/jdk-$_dropsver.tar.bz2 \
--with-langtools-src-zip=$srcdir/langtools-$_dropsver.tar.bz2 \
--with-pax=paxmark \
--with-jdk-home=$BOOTSTRAP_JAVA_HOME \
--with-pkgversion="Alpine ${pkgver}-r${pkgrel}"
--with-pkgversion="Adelie ${pkgver}-r${pkgrel}"
msg "Icedtea boot"
make -j1 icedtea-boot SHELL=/bin/bash
......@@ -193,9 +199,6 @@ package() {
cp -a "$builddir"/openjdk.build/j2sdk-image/* "$pkgdir"/$INSTALL_BASE
rm "$pkgdir"/$INSTALL_BASE/src.zip
# pax mark again (due to fakeroot xattr handling bug)
"$builddir"/pax-mark-vm "$pkgdir"/$INSTALL_BASE
# symlink to shared java cacerts store
rm -f "$pkgdir"/$INSTALL_BASE/jre/lib/security/cacerts
ln -sf /etc/ssl/certs/java/cacerts \
......@@ -229,9 +232,6 @@ jrebase() {
# rest of the jre subdir (which were not taken by -jre subpkg)
mv "$pkgdir"/$INSTALL_BASE/jre "$subpkgdir"/$INSTALL_BASE
# pax mark again (due to fakeroot xattr handling bug)
"$builddir"/pax-mark-vm "$subpkgdir"/$INSTALL_BASE
}
jre() {
......@@ -250,9 +250,6 @@ jre() {
mkdir -p "$subpkgdir"/$INSTALL_BASE/$dirname
mv "$pkgdir"/$INSTALL_BASE/$A "$subpkgdir"/$INSTALL_BASE/$dirname
done
# pax mark again (due to fakeroot xattr handling bug)
"$builddir"/pax-mark-vm "$subpkgdir"/$INSTALL_BASE
}
doc() {
......@@ -280,4 +277,9 @@ e7a2c1771bb582d427041f8d22e48c0daf8f20d7c0926cbce3549d49c4e949359ee25a35682b486e
48533f87fc2cf29d26b259be0df51087d2fe5b252e72d00c6ea2f4add7b0fb113141718c116279c5905e03f64a1118082e719393786811367cf4d472b5d36774 icedtea-jdk-fix-ipv6-init.patch
44a35941c80f408d0607e32763b3b6ccee21e1d39886309327d3d74d2900117e4346ef59e77c663fd022fec10ee8f365eeb46c1260014d5765d226ce175ce3c5 icedtea-jdk-musl.patch
bf4b184e170f7b0ff64ab30d2162784fe2bd5460d1fa31973259f7065fd4c511c46f97724fe2bd72bb94e9006cb568d0e0c87d1a9c90819e65880f8f44830bb1 icedtea-jdk-no-soname.patch
a54c79c82afa1bc95265397b274260584c8b8c6be1651ddfb907d9523a809ea4581409e0d3fb0bbb63ef5a204e8ce29b7940e78cd640af1f490ae938c59129b6 icedtea-cpio.patch"
a54c79c82afa1bc95265397b274260584c8b8c6be1651ddfb907d9523a809ea4581409e0d3fb0bbb63ef5a204e8ce29b7940e78cd640af1f490ae938c59129b6 icedtea-cpio.patch
dc5f59068395e9501b17308c91ec80670c195117e22cb7bef78d551d118f180a11d7f0b5d47f4c7106909d9a9a8c060ddd60b78f251fd35afa6c72a1515af53e icedtea-tar.patch
049061b97d6e744b7ad9bad4a3dbfa1d236400003175e49740830dcb78a1f164b5c67b066e76c970eb27e09707f948cac0f5b7073abe0f49bcecfdd747f0107d icedtea-remove-gawk.patch
b9950ddf9c5ebb53d1e029a1fe8ef843860128ceb05872313b33fd2696a4acadbc8291110ca6513ce7531e0f943e42b167068e603f7ecd0e36f5b16d6bb827ab icedtea-xattr.patch
fda1ba46276475cced16c4f380dbc0a0ac07ae2d66a8da10e88455a299bd40ff04a63dae1c5f3d3de6adbb3c6c240db5d37df0be2fc3391764cb21c9ad83eb8b remove-gawk.patch
3dd758e04e3b852398d81356c02a89afce0c664938d3f0179ee32e358d7057f5f969379329dd1ebcbf4bc3d37bd5e0d94102cd3f023326db5175968cfbbc9c35 xattr.patch"
--- openjdk/corba/make/common/shared/Defs-utils.gmk.old 2018-10-22 05:22:47.000000000 +0000
+++ openjdk/corba/make/common/shared/Defs-utils.gmk 2019-02-27 00:44:26.900000000 +0000
@@ -182,7 +182,7 @@
# others have it in /usr/bin.
SORT=$(firstword $(wildcard $(UTILS_COMMAND_PATH)sort) \
$(wildcard $(UTILS_USR_BIN_PATH)sort))
- NAWK = $(USRBIN_PATH)gawk
+ NAWK = $(USRBIN_PATH)mawk
# Intrinsic unix command, with backslash-escaped character interpretation
ECHO = /bin/echo -e
# These are really in UTILS_USR_BIN_PATH on Linux (only sccs is not)
--- openjdk/jdk/make/common/shared/Defs-utils.gmk.old 2019-02-27 00:40:12.430000000 +0000
+++ openjdk/jdk/make/common/shared/Defs-utils.gmk 2019-02-27 00:43:49.520000000 +0000
@@ -207,7 +207,7 @@
# others have it in /usr/bin.
SORT=$(firstword $(wildcard $(UTILS_COMMAND_PATH)sort) \
$(wildcard $(UTILS_USR_BIN_PATH)sort))
- NAWK = $(USRBIN_PATH)gawk
+ NAWK = $(USRBIN_PATH)mawk
# Intrinsic unix command, with backslash-escaped character interpretation
ECHO = /bin/echo -e
# These are really in UTILS_USR_BIN_PATH on Linux
--- openjdk/jdk/make/common/shared/Defs-utils.gmk.old 2019-02-27 01:45:10.950000000 +0000
+++ openjdk/jdk/make/common/shared/Defs-utils.gmk 2019-02-27 02:26:55.870000000 +0000
@@ -150,7 +150,7 @@
SHOWREV = $(UTILS_USR_BIN_PATH)showrev
SORT = $(UTILS_COMMAND_PATH)sort
TAIL = $(UTILS_USR_BIN_PATH)tail
-TAR = $(UTILS_COMMAND_PATH)tar
+TAR = $(UTILS_USR_BIN_PATH)tar
TEST = $(UTILS_USR_BIN_PATH)test
TOUCH = $(UTILS_COMMAND_PATH)touch
TR = $(UTILS_USR_BIN_PATH)tr
--- openjdk/corba/make/common/shared/Defs-utils.gmk.old 2019-02-27 02:27:38.910000000 +0000
+++ openjdk/corba/make/common/shared/Defs-utils.gmk 2019-02-27 02:28:00.210000000 +0000
@@ -129,7 +129,7 @@
SORT = $(UTILS_COMMAND_PATH)sort
STRIP = $(UTILS_CCS_BIN_PATH)strip
TAIL = $(UTILS_USR_BIN_PATH)tail
-TAR = $(UTILS_COMMAND_PATH)tar
+TAR = $(UTILS_USR_BIN_PATH)tar
TEST = $(UTILS_USR_BIN_PATH)test
TOUCH = $(UTILS_COMMAND_PATH)touch
TR = $(UTILS_USR_BIN_PATH)tr
--- openjdk/jdk/src/solaris/native/sun/nio/fs/LinuxNativeDispatcher.c.old 2018-10-22 05:32:13.000000000 +0000
+++ openjdk/jdk/src/solaris/native/sun/nio/fs/LinuxNativeDispatcher.c 2019-02-27 01:37:00.950000000 +0000
@@ -38,7 +38,7 @@
#ifdef COMPILE_AGAINST_SYSCALLS
#include <sys/types.h>
-#include <attr/xattr.h>
+#include <sys/xattr.h>
#else
#include <syscalls_fp.h>
#endif
--- icedtea-2.6.16/configure.old 2019-01-01 20:11:07.846602426 +0000
+++ icedtea-2.6.16/configure 2019-02-27 00:23:41.230000000 +0000
@@ -6881,108 +6881,7 @@
LDD="$ac_cv_prog_LDD"
fi
-if test -n "$ac_tool_prefix"; then
- # Extract the first word of "${ac_tool_prefix}gawk", so it can be a program name with args.
-set dummy ${ac_tool_prefix}gawk; ac_word=$2
-{ $as_echo "$as_me:${as_lineno-$LINENO}: checking for $ac_word" >&5
-$as_echo_n "checking for $ac_word... " >&6; }
-if ${ac_cv_path_GAWK+:} false; then :
- $as_echo_n "(cached) " >&6
-else
- case $GAWK in
- [\\/]* | ?:[\\/]*)
- ac_cv_path_GAWK="$GAWK" # Let the user override the test with a path.
- ;;
- *)
- as_save_IFS=$IFS; IFS=$PATH_SEPARATOR
-for as_dir in $PATH
-do
- IFS=$as_save_IFS
- test -z "$as_dir" && as_dir=.
- for ac_exec_ext in '' $ac_executable_extensions; do
- if as_fn_executable_p "$as_dir/$ac_word$ac_exec_ext"; then
- ac_cv_path_GAWK="$as_dir/$ac_word$ac_exec_ext"
- $as_echo "$as_me:${as_lineno-$LINENO}: found $as_dir/$ac_word$ac_exec_ext" >&5
- break 2
- fi
-done
- done
-IFS=$as_save_IFS
-
- ;;
-esac
-fi
-GAWK=$ac_cv_path_GAWK
-if test -n "$GAWK"; then
- { $as_echo "$as_me:${as_lineno-$LINENO}: result: $GAWK" >&5
-$as_echo "$GAWK" >&6; }
-else
- { $as_echo "$as_me:${as_lineno-$LINENO}: result: no" >&5
-$as_echo "no" >&6; }
-fi
-
-
-fi
-if test -z "$ac_cv_path_GAWK"; then
- ac_pt_GAWK=$GAWK
- # Extract the first word of "gawk", so it can be a program name with args.
-set dummy gawk; ac_word=$2
-{ $as_echo "$as_me:${as_lineno-$LINENO}: checking for $ac_word" >&5
-$as_echo_n "checking for $ac_word... " >&6; }
-if ${ac_cv_path_ac_pt_GAWK+:} false; then :
- $as_echo_n "(cached) " >&6
-else
- case $ac_pt_GAWK in
- [\\/]* | ?:[\\/]*)
- ac_cv_path_ac_pt_GAWK="$ac_pt_GAWK" # Let the user override the test with a path.
- ;;
- *)
- as_save_IFS=$IFS; IFS=$PATH_SEPARATOR
-for as_dir in $PATH
-do
- IFS=$as_save_IFS
- test -z "$as_dir" && as_dir=.
- for ac_exec_ext in '' $ac_executable_extensions; do
- if as_fn_executable_p "$as_dir/$ac_word$ac_exec_ext"; then
- ac_cv_path_ac_pt_GAWK="$as_dir/$ac_word$ac_exec_ext"
- $as_echo "$as_me:${as_lineno-$LINENO}: found $as_dir/$ac_word$ac_exec_ext" >&5
- break 2
- fi
-done
- done
-IFS=$as_save_IFS
-
- ;;
-esac
-fi
-ac_pt_GAWK=$ac_cv_path_ac_pt_GAWK
-if test -n "$ac_pt_GAWK"; then
- { $as_echo "$as_me:${as_lineno-$LINENO}: result: $ac_pt_GAWK" >&5
-$as_echo "$ac_pt_GAWK" >&6; }
-else
- { $as_echo "$as_me:${as_lineno-$LINENO}: result: no" >&5
-$as_echo "no" >&6; }
-fi
-
- if test "x$ac_pt_GAWK" = x; then
- GAWK=""
- else
- case $cross_compiling:$ac_tool_warned in
-yes:)
-{ $as_echo "$as_me:${as_lineno-$LINENO}: WARNING: using cross tools not prefixed with host triplet" >&5
-$as_echo "$as_me: WARNING: using cross tools not prefixed with host triplet" >&2;}
-ac_tool_warned=yes ;;
-esac
- GAWK=$ac_pt_GAWK
- fi
-else
- GAWK="$ac_cv_path_GAWK"
-fi
-
- if test x"$GAWK" = x ; then
- as_fn_error $? "The following program was not found on the PATH: gawk" "$LINENO" 5
- fi
-
+GAWK="$AWK"
if test -n "$ac_tool_prefix"; then
# Extract the first word of "${ac_tool_prefix}perl", so it can be a program name with args.
--- icedtea-2.6.16/configure.ac.old 2019-01-01 20:09:39.139994680 +0000
+++ icedtea-2.6.16/configure.ac 2019-02-27 00:25:01.960000000 +0000
@@ -39,9 +39,7 @@
IT_FIND_TOOLS([FASTJAR], [fastjar jar])
IT_FIND_TOOLS([SED],[gsed sed])
AC_CHECK_TOOL([LDD], [ldd])
-dnl OpenJDK's README-builds.html lists gawk as a build dependency so we
-dnl check for it explicitly rather than using AC_PROG_AWK.
-IT_FIND_TOOL([GAWK], [gawk])
+IT_FIND_TOOL([GAWK], [awk])
IT_FIND_TOOL([PERL], [perl])
IT_CHECK_FOR_MERCURIAL
IT_OBTAIN_HG_REVISIONS
--- icedtea-2.6.16/acinclude.m4.old 2019-01-01 20:09:39.127994868 +0000
+++ icedtea-2.6.16/acinclude.m4 2019-02-27 00:35:33.320000000 +0000
@@ -2271,7 +2271,7 @@
dnl Check for syscalls
AC_CHECK_FUNCS([openat64 fstatat64 fgetxattr fsetxattr fremovexattr flistxattr unlinkat renameat futimesat fdopendir epoll_create epoll_ctl epoll_wait],,
[AC_MSG_ERROR([Could not find required syscalls; check config.log and use --disable-compile-against-syscalls if necessary.])])
- AC_CHECK_HEADERS([sys/epoll.h attr/xattr.h],
+ AC_CHECK_HEADERS([sys/epoll.h sys/xattr.h],
, [AC_MSG_ERROR([Could not find required system headers; install the appropriate files from glibc-headers, libc6-dev and/or libattr-devel, libattr1-dev or use --disable-compile-against-syscalls if necessary.])])
ENABLE_SYSCALL_COMPILATION=true
fi
0% Loading or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment