Skip to content
GitLab
Explore
Sign in
Register
Primary navigation
Search or go to…
Project
Adélie Package Tree
Manage
Activity
Members
Labels
Plan
Issues
Issue boards
Milestones
Wiki
Code
Merge requests
Repository
Branches
Commits
Tags
Repository graph
Compare revisions
Build
Pipelines
Jobs
Pipeline schedules
Artifacts
Help
Help
Support
GitLab documentation
Compare GitLab plans
Community forum
Contribute to GitLab
Provide feedback
Keyboard shortcuts
?
Snippets
Groups
Projects
Show more breadcrumbs
Adélie Linux
Adélie Package Tree
Commits
5288e2ca
Verified
Commit
5288e2ca
authored
5 years ago
by
Max Rees
Browse files
Options
Downloads
Patches
Plain Diff
system/libssh2: kneecap test that relies on tty group access
parent
34908a6d
No related branches found
Branches containing commit
No related tags found
Tags containing commit
1 merge request
!339
Fixes for auto-building system/, part one
Changes
2
Hide whitespace changes
Inline
Side-by-side
Showing
2 changed files
system/libssh2/APKBUILD
+4
-2
4 additions, 2 deletions
system/libssh2/APKBUILD
system/libssh2/test-sshd.patch
+33
-0
33 additions, 0 deletions
system/libssh2/test-sshd.patch
with
37 additions
and
2 deletions
system/libssh2/APKBUILD
+
4
−
2
View file @
5288e2ca
...
...
@@ -10,7 +10,8 @@ license="BSD-3-Clause"
checkdepends
=
"openssh-server"
makedepends
=
"openssl-dev zlib-dev"
subpackages
=
"
$pkgname
-dev
$pkgname
-doc"
source
=
"https://www.libssh2.org/download/libssh2-
$pkgver
.tar.gz"
source
=
"https://www.libssh2.org/download/libssh2-
$pkgver
.tar.gz
test-sshd.patch"
build
()
{
./configure
\
...
...
@@ -33,4 +34,5 @@ package() {
make
DESTDIR
=
"
$pkgdir
"
install
}
sha512sums
=
"41a3ebcf84e32eab69b7411ffb0a3b6e6db71491c968602b17392cfe3490ef00239726ec28acb3d25bf0ed62700db7f4d0bb5a9175618f413865f40badca6e17 libssh2-1.9.0.tar.gz"
sha512sums
=
"41a3ebcf84e32eab69b7411ffb0a3b6e6db71491c968602b17392cfe3490ef00239726ec28acb3d25bf0ed62700db7f4d0bb5a9175618f413865f40badca6e17 libssh2-1.9.0.tar.gz
eef3c43184d53a3c655915ad61d182a88d9cced75ba8f8dde73ccf771ff4aeaa0f26e95aeb53601d7c47d96a2421c98678e9baf497f3883faa4427a091eea62c test-sshd.patch"
This diff is collapsed.
Click to expand it.
system/libssh2/test-sshd.patch
0 → 100644
+
33
−
0
View file @
5288e2ca
--- libssh2-1.9.0/tests/ssh2.sh 2010-10-25 17:15:14.000000000 -0500
+++ libssh2-1.9.0/tests/ssh2.sh 2019-09-11 18:52:25.932354801 -0500
@@ -28,6 +28,7 @@
$SSHD -f /dev/null -h "$srcdir"/etc/host
-o 'UsePrivilegeSeparation no' \
-o 'StrictModes no' \
-D \
+ -e \
$libssh2_sshd_params &
sshdpid=$!
--- libssh2-1.9.0/tests/ssh2.c 2019-03-26 08:08:54.000000000 -0500
+++ libssh2-1.9.0/tests/ssh2.c 2019-09-11 19:38:03.782403778 -0500
@@ -143,20 +143,6 @@
int main(int argc, char *argv[])
*/
libssh2_channel_setenv(channel, "FOO", "bar");
- /* Request a terminal with 'vanilla' terminal emulation
- * See /etc/termcap for more options
- */
- if(libssh2_channel_request_pty(channel, "vanilla")) {
- fprintf(stderr, "Failed requesting pty\n");
- goto skip_shell;
- }
-
- /* Open a SHELL on that pty */
- if(libssh2_channel_shell(channel)) {
- fprintf(stderr, "Unable to request shell on allocated pty\n");
- goto shutdown;
- }
-
ec = 0;
skip_shell:
This diff is collapsed.
Click to expand it.
Preview
0%
Loading
Try again
or
attach a new file
.
Cancel
You are about to add
0
people
to the discussion. Proceed with caution.
Finish editing this message first!
Save comment
Cancel
Please
register
or
sign in
to comment