Skip to content
GitLab
Explore
Sign in
Register
Primary navigation
Search or go to…
Project
Adélie Package Tree
Manage
Activity
Members
Labels
Plan
Issues
Issue boards
Milestones
Wiki
Code
Merge requests
Repository
Branches
Commits
Tags
Repository graph
Compare revisions
Build
Pipelines
Jobs
Pipeline schedules
Artifacts
Help
Help
Support
GitLab documentation
Compare GitLab plans
Community forum
Contribute to GitLab
Provide feedback
Keyboard shortcuts
?
Snippets
Groups
Projects
Show more breadcrumbs
Adélie Linux
Adélie Package Tree
Commits
51e70151
Commit
51e70151
authored
3 years ago
by
Zach van Rijn
Browse files
Options
Downloads
Patches
Plain Diff
user/kcoreaddons: patch for use of deleted function. fixes
#484
.
parent
a99cda9b
No related branches found
Branches containing commit
No related tags found
Tags containing commit
No related merge requests found
Changes
2
Hide whitespace changes
Inline
Side-by-side
Showing
2 changed files
user/kcoreaddons/APKBUILD
+4
-2
4 additions, 2 deletions
user/kcoreaddons/APKBUILD
user/kcoreaddons/fix-build-deleted-function.patch
+12
-0
12 additions, 0 deletions
user/kcoreaddons/fix-build-deleted-function.patch
with
16 additions
and
2 deletions
user/kcoreaddons/APKBUILD
+
4
−
2
View file @
51e70151
...
...
@@ -2,7 +2,7 @@
# Maintainer: A. Wilcox <awilfox@adelielinux.org>
pkgname
=
kcoreaddons
pkgver
=
5.74.0
pkgrel
=
0
pkgrel
=
1
pkgdesc
=
"Core KF5 framework"
url
=
"https://www.kde.org/"
arch
=
"all"
...
...
@@ -15,6 +15,7 @@ makedepends="$depends_dev cmake extra-cmake-modules qt5-qttools-dev doxygen
subpackages
=
"
$pkgname
-dev
$pkgname
-doc
$pkgname
-lang"
source
=
"https://download.kde.org/stable/frameworks/
${
pkgver
%.*
}
/kcoreaddons-
$pkgver
.tar.xz
utf8.patch
fix-build-deleted-function.patch
"
build
()
{
...
...
@@ -42,4 +43,5 @@ package() {
}
sha512sums
=
"bbb1bdba02cf745ac705753558719d2b8b6b8279bdde2b77013da25f44f56421c5199efc061257f729ee4430e2674c4818941d89fd908b76a5a044628bbf9d3c kcoreaddons-5.74.0.tar.xz
d462866912d9cc9a768477d872142eb67be6b616c044436a27aa71577546efe4aa323b3dac913f9dbb52fc62dbe27d464b30ac3c4cb23c5d7c414d96138e9300 utf8.patch"
d462866912d9cc9a768477d872142eb67be6b616c044436a27aa71577546efe4aa323b3dac913f9dbb52fc62dbe27d464b30ac3c4cb23c5d7c414d96138e9300 utf8.patch
ad40fed8bc7d0433c31d6ee49ba36961886293894e17a32e8dd72a22832357976faf7d7337b1515181136ad809ab98e98def61d4338df2ece8843d0806877edd fix-build-deleted-function.patch"
This diff is collapsed.
Click to expand it.
user/kcoreaddons/fix-build-deleted-function.patch
0 → 100644
+
12
−
0
View file @
51e70151
diff -ur a/src/lib/randomness/krandom.cpp b/src/lib/randomness/krandom.cpp
--- a/src/lib/randomness/krandom.cpp 2022-02-03 22:19:56.740000000 +0000
+++ b/src/lib/randomness/krandom.cpp 2022-02-03 22:20:23.160000000 +0000
@@ -73,7 +73,7 @@
if (r > 90) {
r += 6;
}
- str[i++] = char(r);
+ str[i++] = QLatin1Char(char(r));
// so what if I work backwards?
}
return str;
This diff is collapsed.
Click to expand it.
Preview
0%
Loading
Try again
or
attach a new file
.
Cancel
You are about to add
0
people
to the discussion. Proceed with caution.
Finish editing this message first!
Save comment
Cancel
Please
register
or
sign in
to comment