Skip to content
Snippets Groups Projects
Commit 4dd22b68 authored by Anna Wilcox's avatar Anna Wilcox :fox:
Browse files

Merge branch 'cifs-utils' into 'master'

cifs-utils and friends

- [x] cifs-utils
  - [x] talloc

ACL / idmap support can be added later once `samba` is packaged.

See merge request !158
parents 35c913e7 795cfbff
No related branches found
No related tags found
No related merge requests found
# Contributor: Francesco Colista <fcolista@alpinelinux.org>
# Maintainer: Max Rees <maxcrees@me.com>
pkgname=cifs-utils
pkgver=6.8
pkgrel=0
pkgdesc="CIFS filesystem user-space tools"
url="https://wiki.samba.org/index.php/LinuxCIFS_utils"
arch="all"
options="!check suid" # No test suite.
license="GPL-3.0+ AND GPL-2.0+ AND LGPL-3.0+"
depends=""
makedepends="keyutils-dev krb5-dev libcap-ng-dev linux-pam-dev
py3-docutils talloc-dev"
subpackages="$pkgname-doc $pkgname-dev"
source="https://ftp.samba.org/pub/linux-cifs/$pkgname/$pkgname-$pkgver.tar.bz2
musl-fix-includes.patch
xattr_size_max.patch"
build() {
cd "$builddir"
# --enable-cifsidmap and --enable-cifsacl require libwbclient (samba)
autoreconf -i
./configure \
--build=$CBUILD \
--host=$CHOST \
--prefix=/usr \
--sysconfdir=/etc \
--mandir=/usr/share/man \
--infodir=/usr/share/info \
--localstatedir=/var \
--enable-cifsidmap=no \
--enable-cifsacl=no
make
}
check() {
cd "$builddir"
make check
}
package() {
cd "$builddir"
make DESTDIR="$pkgdir" install
# Allow unprivileged mount
chmod u+s "$pkgdir"/sbin/mount.cifs
}
sha512sums="54a094f78c9e07acc997adfe0c8d4c2fb8e15c18adcc1805450e2180f8539aaec8619e781e985b289e097932637e2de3e6815e32f59ec2fc06cfc3762b832e13 cifs-utils-6.8.tar.bz2
99a2fab05bc2f14a600f89526ae0ed2c183cfa179fe386cb327075f710aee3aed5ae823f7c2f51913d1217c2371990d6d4609fdb8d80288bd3a6139df3c8aebe musl-fix-includes.patch
2a9366ec1ddb0389c535d2fa889f63287cb8374535a47232de102c7e50b6874f67a3d5ef3318df23733300fd8459c7ec4b11f3211508aca7800b756119308e98 xattr_size_max.patch"
--- cifs-utils-6.2.orig/mount.h
+++ cifs-utils-6.2/mount.h
@@ -20,6 +20,8 @@
#ifndef _MOUNT_H_
#define _MOUNT_H_
+#include <paths.h>
+
/* exit status - bits below are ORed */
#define EX_USAGE 1 /* incorrect invocation or permission */
#define EX_SYSERR 2 /* out of memory, cannot fork, ... */
diff --git a/getcifsacl.c b/getcifsacl.c
index f08cdea..5c46999 100644
--- a/getcifsacl.c
+++ b/getcifsacl.c
@@ -38,6 +38,11 @@
#include "cifsacl.h"
#include "idmap_plugin.h"
+#ifdef __linux__
+#include <linux/limits.h> /* for XATTR_SIZE_MAX */
+#include <endian.h> /* le16toh, le32toh etc */
+#endif
+
static void *plugin_handle;
static bool plugin_loaded;
diff --git a/setcifsacl.c b/setcifsacl.c
index ba34403..64e6eaa 100644
--- a/setcifsacl.c
+++ b/setcifsacl.c
@@ -39,6 +39,11 @@
#include "cifsacl.h"
#include "idmap_plugin.h"
+#ifdef __linux__
+#include <linux/limits.h> /* for XATTR_SIZE_MAX */
+#include <endian.h> /* le16toh, le32toh etc */
+#endif
+
enum setcifsacl_actions {
ActUnknown = -1,
ActDelete,
# Contributor: William Pitcock <nenolod@dereferenced.org>
# Maintainer: Max Rees <maxcrees@me.com>
pkgname=talloc
pkgver=2.1.15
pkgrel=0
pkgdesc="Memory pool management library"
url="https://talloc.samba.org"
arch="all"
license="LGPL-3.0+ AND GPL-3.0+ AND ISC AND LGPL-2.1+ AND BSD-3-Clause AND PostgreSQL"
replaces="samba-common"
depends=""
makedepends="docbook-xsl libxslt python3-dev"
subpackages="$pkgname-dev py3-$pkgname:py3 $pkgname-doc"
source="https://samba.org/ftp/$pkgname/$pkgname-$pkgver.tar.gz
waf-location.patch"
build() {
cd "$builddir"
PYTHON=python3 ./configure \
--build=$CBUILD \
--host=$CHOST \
--prefix=/usr \
--sysconfdir=/etc \
--mandir=/usr/share/man \
--infodir=/usr/share/info \
--localstatedir=/var \
--bundled-libraries=NONE \
--builtin-libraries=replace \
--disable-rpath \
--disable-rpath-install
make
}
check() {
cd "$builddir"
make check
}
package() {
cd "$builddir"
make DESTDIR="$pkgdir" install
}
py3() {
pkgdesc="Python 3 binding for libtalloc"
mkdir -p "$subpkgdir"/usr/lib
mv "$pkgdir"/usr/lib/libpytalloc-util.cpython* \
"$pkgdir"/usr/lib/python3* "$subpkgdir"/usr/lib/
}
sha512sums="41896f8877e9a52e70b9881c41667dc52d7c1b03c3b248020fd909b794a4c5a4addee3eb944aa80ecfa3b03e6e5e1f67a62b5f3a5dcdc412b3e975352057ff40 talloc-2.1.15.tar.gz
d19553fae679b5db10ab77a86f9fa0525ccba37a3ef30e530cd96245ee5fc94d4570079bbfe0271c32fbc84a3556c4bf86cc1cab6ffb61863cbce3f5a911efec waf-location.patch"
--- talloc-2.1.15/Makefile 2019-01-14 17:24:45.000000000 -0500
+++ talloc-2.1.15/Makefile 2019-01-27 22:57:15.919981283 -0500
@@ -1,6 +1,6 @@
# simple makefile wrapper to run waf
-WAF_BINARY=$(PYTHON) ../../buildtools/bin/waf
+WAF_BINARY=$(PYTHON) buildtools/bin/waf
WAF=PYTHONHASHSEED=1 WAF_MAKE=1 $(WAF_BINARY)
all:
0% Loading or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment