Skip to content
Snippets Groups Projects
Verified Commit 4b5db770 authored by Anna Wilcox's avatar Anna Wilcox :fox:
Browse files

user/perl-xml-sax: new package

parent a51b72fc
No related branches found
No related tags found
No related merge requests found
# Contributor: A. Wilcox <awilfox@adelielinux.org>
# Maintainer: Adélie Perl Team <adelie-perl@lists.adelielinux.org>
pkgname=perl-xml-sax
pkgver=1.00
pkgrel=0
pkgdesc="Perl SAX parser"
url="https://metacpan.org/release/XML-SAX"
arch="noarch"
license="Artistic-1.0-Perl OR GPL-1.0+"
depends="perl-xml-namespacesupport perl-xml-sax-base"
makedepends="perl-dev"
install="$pkgname.post-install $pkgname.pre-deinstall"
subpackages="$pkgname-doc"
source="https://cpan.metacpan.org/authors/id/G/GR/GRANTM/XML-SAX-$pkgver.tar.gz
install-fix.patch
"
builddir="$srcdir/XML-SAX-$pkgver"
build() {
cd "$builddir"
PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor
make
}
check() {
cd "$builddir"
make test
}
package() {
cd "$builddir"
make DESTDIR="$pkgdir" install
find "$pkgdir" \( -name perllocal.pod -o -name .packlist \) -delete
}
sha512sums="95553c9693d8a310747b4b86d4e80a58d4056b18cfc334f6979c98d0e9034a34253bfb17daecfc5bb28b1bd65e6baf52136f5135a969fadba86aa4148ea9bc1d XML-SAX-1.00.tar.gz
a2177f0aa00bb31c41298f0c622f800ac0dddb1d30bc1bf86e035cfd8327fa8078baf46587ffd4a782c22fba0783709f2459c81b95a8ef86e1fd4e4058e3a166 install-fix.patch"
--- XML-SAX-1.00/Makefile.PL.old 2018-02-15 09:44:15.000000000 +0000
+++ XML-SAX-1.00/Makefile.PL 2019-01-11 20:58:06.250000000 +0000
@@ -23,7 +23,7 @@
eval { require XML::SAX };
if ($@) {
- $write_ini_ok = 1;
+ $write_ini_ok = 0;
}
else {
my $dir = File::Basename::dirname($INC{'XML/SAX.pm'});
#!/bin/sh
# Add the parser to the registry.
LC_ALL=C perl -MXML::SAX -e \
"XML::SAX->add_parser(q(XML::SAX::PurePerl))->save_parsers()"
#!/bin/sh
# Remove the parser from the registry.
LC_ALL=C perl -MXML::SAX -e \
"XML::SAX->remove_parser(q(XML::SAX::PurePerl))->save_parsers()"
0% Loading or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment