Skip to content
GitLab
Explore
Sign in
Register
Primary navigation
Search or go to…
Project
Adélie Package Tree
Manage
Activity
Members
Labels
Plan
Issues
Issue boards
Milestones
Wiki
Code
Merge requests
Repository
Branches
Commits
Tags
Repository graph
Compare revisions
Build
Pipelines
Jobs
Pipeline schedules
Artifacts
Help
Help
Support
GitLab documentation
Compare GitLab plans
Community forum
Contribute to GitLab
Provide feedback
Keyboard shortcuts
?
Snippets
Groups
Projects
Show more breadcrumbs
Adélie Linux
Adélie Package Tree
Commits
4b1b0550
Verified
Commit
4b1b0550
authored
5 years ago
by
Anna Wilcox
Browse files
Options
Downloads
Patches
Plain Diff
user/grub: fix boot error on 64-bit PowerPC
parent
98b1f96f
No related branches found
No related tags found
No related merge requests found
Changes
3
Hide whitespace changes
Inline
Side-by-side
Showing
3 changed files
user/grub/APKBUILD
+4
-4
4 additions, 4 deletions
user/grub/APKBUILD
user/grub/grub2-accept-empty-module.patch
+1
-1
1 addition, 1 deletion
user/grub/grub2-accept-empty-module.patch
user/grub/x86_64_asm.patch
+1
-1
1 addition, 1 deletion
user/grub/x86_64_asm.patch
with
6 additions
and
6 deletions
user/grub/APKBUILD
+
4
−
4
View file @
4b1b0550
...
...
@@ -2,7 +2,7 @@
# Maintainer: A. Wilcox <awilfox@adelielinux.org>
pkgname
=
grub
pkgver
=
2.02
pkgrel
=
6
pkgrel
=
7
pkgdesc
=
"Bootloader with support for Linux, Multiboot and more"
url
=
"https://www.gnu.org/software/grub/"
arch
=
"all !s390x"
...
...
@@ -46,7 +46,7 @@ _build_flavor() {
shift
local
_configure
=
"
$@
"
case
$CTARGET_ARCH
in
ppc64
)
export
CFLAGS
=
"-O2 -ggdb -mcpu=970"
;;
# Workaround for http://savannah.gnu.org/bugs/?52629
ppc64
)
export
CFLAGS
=
"-O2 -ggdb -mcpu=970
-mno-altivec
"
;;
# Workaround for http://savannah.gnu.org/bugs/?52629
esac
msg
"Building grub for platform
$flavor
"
...
...
@@ -159,8 +159,8 @@ emu() {
sha512sums
=
"cc6eb0a42b5c8df2f671cc128ff725afb3ff1f8832a196022e433cf0d3b75decfca2316d0aa5fabea75747d55e88f3d021dd93508563f8ca80fd7b9e7fe1f088 grub-2.02.tar.xz
f2a7d9ab6c445f4e402e790db56378cecd6631b5c367451aa6ce5c01cd95b95c83c3dd24d6d4b857f8f42601eba82c855607513eb6ce5b2af6bd6c71f046e288 fix-gcc-no-pie-specs.patch
098a1742aef131c85d63b934a9815879b991f2e73030cb90ac4b5dcd07d249fa0dd0a281e52ada0e10f05d59223493bd416eb47543242bf0ba336a0ebc
9b2
a
1a grub2-accept-empty-module.patch
2fefc6d5c1388dba6d368451f47c216171136f03891e87777ee392884d7ef53c70b2a2565af676237216565f203f62b79aec0d1a8297
9b21a
a29c4ebf87ac566
grub2-accept-empty-module.patch
4e7394e0fff6772c89683039ccf81099ebbfe4f498e6df408977a1488fd59389b6e19afdbf0860ec271e2b2aea0df7216243dcc8235d1ca3af0e7f4d0a9d60a4 grub-xen-host_grub.cfg
088455205f2f397d60e43eab19ed73994880ea1f442661f7975846cceaf2b112d92fd1341119d7dbfad3af2174dfd4d4721f31dead1ac35f4a3cb7c0d92f8a04 the-arch-everyone-uses-and-nobody-loves.patch
271fdcfbdec567802b351e0a6c38a227ff4ad4eb17533cfa433398fa0929645671a2bfebcc7911d71c1fc3ced94985de148c153834bd2d62018f033eedfbdaf7
x86_64_asm.patch
8752b5e689ec3b7e1f438c7207adc517d7acb4f7d15fda2907bc9177883a686f23994c66641bfc0c7620365415972b5d8b74f511c13dd234f5f3461dda4bb445
x86_64_asm.patch
048d061ac0aab0106f59a3d257739ff5de6c7dc08a4dc9b8b12e9bd2b1ec11f9bc6214013f3d1083b11c3ce41185fcbb5615beb2f290380abf392bb4c3f0d509 default-grub"
This diff is collapsed.
Click to expand it.
user/grub/grub2-accept-empty-module.patch
+
1
−
1
View file @
4b1b0550
...
...
@@ -10,7 +10,7 @@ also no relocations that's no problem (and that is checked
independendly).
--- grub-2.02~beta3/util/grub-module-verifierXX.c.mm 2016-02-11 10:57:41.000000000 +0000
+++ grub-2.02~beta3/util/grub-module-verifierXX.c 2016-08-31 15:26:36.000000000 +0000
@@ -
199
,7 +
199
,8 @@
check_symbols (const struct grub_module_
@@ -
224
,7 +
224
,8 @@
check_symbols (const struct grub_module_
Elf_Shdr *s = find_section (arch, e, ".moddeps");
if (!s)
...
...
This diff is collapsed.
Click to expand it.
user/grub/x86_64_asm.patch
+
1
−
1
View file @
4b1b0550
...
...
@@ -48,7 +48,7 @@ diff --git a/util/grub-mkimagexx.c b/util/grub-mkimagexx.c
index a2bb054..39d7efb 100644
--- a/util/grub-mkimagexx.c
+++ b/util/grub-mkimagexx.c
@@ -8
41
,6 +8
41
,7 @@
SUFFIX (relocate_addresses) (Elf_Ehdr *e, Elf_Shdr *sections,
@@ -8
32
,6 +8
32
,7 @@
SUFFIX (relocate_addresses) (Elf_Ehdr *e, Elf_Shdr *sections,
break;
case R_X86_64_PC32:
...
...
This diff is collapsed.
Click to expand it.
Preview
0%
Loading
Try again
or
attach a new file
.
Cancel
You are about to add
0
people
to the discussion. Proceed with caution.
Finish editing this message first!
Save comment
Cancel
Please
register
or
sign in
to comment