Skip to content
GitLab
Explore
Sign in
Register
Primary navigation
Search or go to…
Project
Adélie Package Tree
Manage
Activity
Members
Labels
Plan
Issues
Issue boards
Milestones
Wiki
Code
Merge requests
Repository
Branches
Commits
Tags
Repository graph
Compare revisions
Build
Pipelines
Jobs
Pipeline schedules
Artifacts
Help
Help
Support
GitLab documentation
Compare GitLab plans
Community forum
Contribute to GitLab
Provide feedback
Keyboard shortcuts
?
Snippets
Groups
Projects
Show more breadcrumbs
Adélie Linux
Adélie Package Tree
Commits
45e7d514
Verified
Commit
45e7d514
authored
6 years ago
by
Anna Wilcox
Browse files
Options
Downloads
Patches
Plain Diff
user/qastools: new package
parent
88924496
No related branches found
No related tags found
No related merge requests found
Changes
3
Hide whitespace changes
Inline
Side-by-side
Showing
3 changed files
user/ffmpeg/APKBUILD
+3
-3
3 additions, 3 deletions
user/ffmpeg/APKBUILD
user/qastools/APKBUILD
+43
-0
43 additions, 0 deletions
user/qastools/APKBUILD
user/rust/APKBUILD
+5
-4
5 additions, 4 deletions
user/rust/APKBUILD
with
51 additions
and
7 deletions
user/ffmpeg/APKBUILD
+
3
−
3
View file @
45e7d514
...
...
@@ -3,8 +3,8 @@
# Contributor: Jakub Skrzypnik <j.skrzypnik@openmailbox.org>
# Maintainer: A. Wilcox <awilfox@adelielinux.org>
pkgname
=
ffmpeg
pkgver
=
4.1
pkgrel
=
1
pkgver
=
4.1
.1
pkgrel
=
0
pkgdesc
=
"Record, convert, and stream audio and video"
url
=
"https://ffmpeg.org/"
arch
=
"all"
...
...
@@ -101,5 +101,5 @@ libs() {
mv
"
$pkgdir
"
/usr/lib
"
$subpkgdir
"
/usr/
}
sha512sums
=
"
59db7e8a6238048c04c3b0bd5885aea2bf7951f79949fc0659a8d235c4cd809ac0c1a74544a4c218a38c8c739eea76f5ee1
23
1
bf
b96439487212c6e65591780e
ffmpeg-4.1.tar.xz
sha512sums
=
"
fe72680f1e4ca0b226199d1407803e1de11f00f5a88a23251182172cda4a7369cf1826c4ef86
23
0
bf
60b0f9ff0d69382da5eeec26574a31eacd9935cf4eeb86f
ffmpeg-4.1.
1.
tar.xz
32652e18d4eb231a2e32ad1cacffdf33264aac9d459e0e2e6dd91484fced4e1ca5a62886057b1f0b4b1589c014bbe793d17c78adbaffec195f9a75733b5b18cb 0001-libavutil-clean-up-unused-FF_SYMVER-macro.patch"
This diff is collapsed.
Click to expand it.
user/qastools/APKBUILD
0 → 100644
+
43
−
0
View file @
45e7d514
# Contributor: A. Wilcox <awilfox@adelielinux.org>
# Maintainer: A. Wilcox <awilfox@adelielinux.org>
pkgname
=
qastools
pkgver
=
0.21.0
pkgrel
=
0
pkgdesc
=
"ALSA mixer and utilities for Qt"
url
=
"https://xwmw.org/qastools/index.html"
arch
=
"all"
license
=
"GPL-3.0-only"
depends
=
"bash"
makedepends
=
"alsa-lib-dev cmake eudev-dev qt5-qtbase-dev qt5-qtsvg-dev
qt5-qttools-dev"
subpackages
=
"
$pkgname
-doc
$pkgname
-lang"
source
=
"https://downloads.sourceforge.net/qastools/qastools_
$pkgver
.tar.xz"
builddir
=
"
$srcdir
/
${
pkgname
}
_
${
pkgver
}
"
langdir
=
"/usr/share/qastools/l10n"
build
()
{
cd
"
$builddir
"
if
[
"
$CBUILD
"
!=
"
$CHOST
"
]
;
then
CMAKE_CROSSOPTS
=
"-DCMAKE_SYSTEM_NAME=Linux -DCMAKE_HOST_SYSTEM_NAME=Linux"
fi
cmake
\
-DCMAKE_INSTALL_PREFIX
=
/usr
\
-DBUILD_SHARED_LIBS
=
True
\
-DCMAKE_BUILD_TYPE
=
RelWithDebugInfo
\
-DCMAKE_CXX_FLAGS
=
"
$CXXFLAGS
"
\
-DCMAKE_C_FLAGS
=
"
$CFLAGS
"
\
${
CMAKE_CROSSOPTS
}
make
}
check
()
{
cd
"
$builddir
"
CTEST_OUTPUT_ON_FAILURE
=
TRUE ctest
}
package
()
{
cd
"
$builddir
"
make
DESTDIR
=
"
$pkgdir
"
install
}
sha512sums
=
"17c837ef508a5bf1853f597abd38c3c950914c8cefe98f83a47a911462e1da11f410e3fe3f8426e3f17a3aac8980ee6459f50de2480120813202b342a1e3509b qastools_0.21.0.tar.xz"
This diff is collapsed.
Click to expand it.
user/rust/APKBUILD
+
5
−
4
View file @
45e7d514
...
...
@@ -115,7 +115,7 @@ build() {
codegen-units = 1
debuginfo = true
debuginfo-lines = true
debuginfo-only-std =
fals
e
debuginfo-only-std =
tru
e
debuginfo-tools = true
use-jemalloc = false
backtrace = true
...
...
@@ -138,6 +138,7 @@ build() {
check
()
{
cd
"
$builddir
"
RUST_BACKTRACE
=
1
\
./x.py
test
-j
${
JOBS
:-
2
}
--no-doc
--no-fail-fast
\
src/test/codegen
\
src/test/codegen-units
\
...
...
@@ -301,9 +302,9 @@ _mv() {
mv
"
$@
"
}
sha512sums
=
"d6688711452295c41468af214f036499074d82fbeedc3f03560275219c2fae910e623e38e3210176d86f78ba5533ea098da5ff21532c8ad1a5aac132bb74ee02 rustc-1.31.1-src.tar.xz
c414a250edcf5b9c390137a01dc728f22e3067adab43f91bc06a4bed7580bf0e6171e4a844167b5c4bc13774c9ef9e33e1f5cab018dac8b3df6d630a9a163e2c
cargo-0.31.0-powerpc
64
-foxkit-linux-musl.tar.xz
c
6eeb91d7de95401d118d287435ac24e014711f73e86fab7da0a082d7cf03abfe137563cfe6a88b1309cdb0fec11acfceac01cc3bbc2e83650026230ce0cf079
rust-std-1.30.1-powerpc
64
-foxkit-linux-musl.tar.xz
f6099a632de0b4201c3d4639a9c32244fb2fccee891af13fc7efdbaf546e37a67c80b0bce92a19ad746349c59a3627fded64ebcace34fb33c2773bb4aa799cfb
rustc-1.30.1-powerpc
64
-foxkit-linux-musl.tar.xz
16596561ff87c66f64f4b40602184355d3695822b9b9e6e0e929f340664718698e6f5b378c9162b48f9cb180be5fd8e583e5e51a1c57c1cd55dcc80f468cb509
cargo-0.31.0-powerpc-foxkit-linux-musl.tar.xz
c
dfc7a3d51d66338f31007daafab95570e4e465983add99db7a45f1a3e601588b19e1257fe3e7fcc6b7104ba445add2fa1cda71325a9ab6d196b4ad0dcef2fb5
rust-std-1.30.1-powerpc-foxkit-linux-musl.tar.xz
190ed9d84513a229f389fc5d1bf0b8e22202bd3b9802330ee2844c436ae13700bdaded091498be4f2c4c65b2f6ef55c1e2db41a918747ac60e8e11e331be2c29
rustc-1.30.1-powerpc-foxkit-linux-musl.tar.xz
acab7c5ffa73cd83cf3ae23e69d2c05ccc3ca03aa4d5a15179af76f2e75b7c5a1bc8d2969c0a9a4b5ad36a50a8cce283e62db878797be6d0da252b414de004cd 0001-Don-t-pass-CFLAGS-to-the-C-compiler.patch
f9773277e91e91d0bd6749890b8d332a86522927d90548af02892c6d01b8fbb3b234993eec8e5b8d6a3b6f1cec310a112e274f47f70d30829ca61a0da8d45bb5 0002-Fix-LLVM-build.patch
9e87964d41e14f70acc1961a0162bbf3ebca73f1c2b2842c3b1c8b65776466c9299d6974fc6b94a4e06547ae8ce638c28cdedf24eeb2616976f9dd727b989c13 0003-Allow-rustdoc-to-work-when-cross-compiling-on-musl.patch
...
...
This diff is collapsed.
Click to expand it.
Preview
0%
Loading
Try again
or
attach a new file
.
Cancel
You are about to add
0
people
to the discussion. Proceed with caution.
Finish editing this message first!
Save comment
Cancel
Please
register
or
sign in
to comment