Skip to content
GitLab
Explore
Sign in
Register
Primary navigation
Search or go to…
Project
Adélie Package Tree
Manage
Activity
Members
Labels
Plan
Issues
Issue boards
Milestones
Wiki
Code
Merge requests
Repository
Branches
Commits
Tags
Repository graph
Compare revisions
Build
Pipelines
Jobs
Pipeline schedules
Artifacts
Help
Help
Support
GitLab documentation
Compare GitLab plans
Community forum
Contribute to GitLab
Provide feedback
Keyboard shortcuts
?
Snippets
Groups
Projects
Show more breadcrumbs
Adélie Linux
Adélie Package Tree
Commits
45b55733
Verified
Commit
45b55733
authored
4 years ago
by
Anna Wilcox
Browse files
Options
Downloads
Patches
Plain Diff
experimental/horizon: Bump to 0.9.1
parent
b8e3ced8
No related branches found
No related tags found
No related merge requests found
Changes
2
Hide whitespace changes
Inline
Side-by-side
Showing
2 changed files
experimental/horizon/APKBUILD
+9
-9
9 additions, 9 deletions
experimental/horizon/APKBUILD
experimental/horizon/noninstall-mount.patch
+0
-61
0 additions, 61 deletions
experimental/horizon/noninstall-mount.patch
with
9 additions
and
70 deletions
experimental/horizon/APKBUILD
+
9
−
9
View file @
45b55733
# Contributor: A. Wilcox <awilfox@adelielinux.org>
# Maintainer: A. Wilcox <awilfox@adelielinux.org>
pkgname
=
horizon
pkgver
=
0.9.
0
pkgver
=
0.9.
1
pkgrel
=
0
pkgdesc
=
"Installation tools for Adélie Linux"
url
=
"https://horizon.adelielinux.org/"
arch
=
"all"
options
=
"!check"
# Unpackaged dependency ruby-aruba.
options
=
"
!archcheck
!check"
# Unpackaged dependency ruby-aruba.
license
=
"AGPL-3.0+"
depends
=
""
checkdepends
=
"ruby-aruba ruby-rspec valgrind"
...
...
@@ -15,11 +15,9 @@ makedepends="bcnm-dev boost-dev cmake curl-dev eudev-dev libarchive-dev
linux-headers parted-dev skalibs-dev util-linux-dev
libcap-dev libx11-dev libxkbfile-dev qt5-qtbase-dev"
subpackages
=
"
$pkgname
-
dev
$pkgname
-d
oc
$pkgname
-
image
$pkgname
-qt5
subpackages
=
"
$pkgname
-
image
$pkgname
-d
bg
$pkgname
-
dev
$pkgname
-doc
$pkgname
-qt5
$pkgname
-tools
$pkgname
-wizard"
source
=
"https://distfiles.adelielinux.org/source/horizon-
$pkgver
.tar.xz
noninstall-mount.patch
"
source
=
"https://distfiles.adelielinux.org/source/horizon-
$pkgver
.tar.xz"
build
()
{
if
[
"
$CBUILD
"
!=
"
$CHOST
"
]
;
then
...
...
@@ -61,15 +59,19 @@ package() {
image
()
{
pkgdesc
=
"Tools for generating images using HorizonScript"
depends
=
"mtools"
mkdir
-p
"
$subpkgdir
"
/usr/bin
mkdir
-p
"
$subpkgdir
"
/usr/lib
mkdir
-p
"
$subpkgdir
"
/usr/share/horizon
mv
"
$pkgdir
"
/usr/bin/hscript-image
"
$subpkgdir
"
/usr/bin/
mv
"
$pkgdir
"
/usr/lib/libhi-backends.so
"
$subpkgdir
"
/usr/lib/
mv
"
$pkgdir
"
/usr/share/horizon/iso
"
$subpkgdir
"
/usr/share/horizon/
}
qt5
()
{
pkgdesc
=
"Qt 5 installation wizard for Adélie Linux"
depends
=
"horizon"
mkdir
-p
"
$subpkgdir
"
/usr/bin
for
_bin
in
horizon-ppc64-detect horizon-qt5 horizon-run-qt5
;
do
...
...
@@ -90,11 +92,9 @@ wizard() {
pkgdesc
=
"Wizard to generate a HorizonScript for another computer"
make
DESTDIR
=
"
$subpkgdir
"
-C
"
$builddir
"
/build-wizard
install
rm
"
$subpkgdir
"
/usr/bin/hscript-printowner
rm
-r
"
$subpkgdir
"
/usr/include
rm
-r
"
$subpkgdir
"
/usr/lib
rm
-r
"
$subpkgdir
"
/usr/share
}
sha512sums
=
"a2185744b611154f41ba433399f621c8114147bc981dad03fac581bf7ddd67c46042bc230fd68d4c89188cefa281022d101d7394cf1a0554729da540706e6216 horizon-0.9.0.tar.xz
44a4f022df03a3ac3ec9fe3aea9faa8d98ed6c9b61ff50e3c363f5691a2ed428d328f6d5aa019f25be67811dede8da7195eaf354f1cd3a4a56c77f698d53e7fb noninstall-mount.patch"
sha512sums
=
"fe8f58a232b7e577aeba62cecfd97bec4037d41dd179781af912c9974210ce4648b0c56bd84fbf78866698e91882b8f4b7168c22842bde1682ea118ca931832f horizon-0.9.1.tar.xz"
This diff is collapsed.
Click to expand it.
experimental/horizon/noninstall-mount.patch
deleted
100644 → 0
+
0
−
61
View file @
b8e3ced8
diff --git a/ui/qt5/horizonwizard.cc b/ui/qt5/horizonwizard.cc
index 143ae43..556a6f3 100644
--- a/ui/qt5/horizonwizard.cc
+++ b/ui/qt5/horizonwizard.cc
@@ -542,7 +542,9 @@
QString HorizonWizard::toHScript() {
break;
}
+#ifdef HAS_INSTALL_ENV
part_lines << (dynamic_cast<PartitionMountPage *>(page(Page_PartitionMount)))->mountLines();
+#endif /* HAS_INSTALL_ENV */
if(chosen_disk.empty()) {
lines << part_lines;
diff --git a/ui/qt5/mountdialog.cc b/ui/qt5/mountdialog.cc
index f986423..103e442 100644
--- a/ui/qt5/mountdialog.cc
+++ b/ui/qt5/mountdialog.cc
@@ -16,6 +16,7 @@
#include <QLabel>
#include <QLineEdit>
#include <QPushButton>
+#include <QSet>
#include <QVBoxLayout>
MountDialog::MountDialog(QStringList skipParts, QStringList skipMounts,
@@ -75,7 +76,11 @@
MountDialog::MountDialog(QStringList skipParts, QStringList skipMounts,
QVBoxLayout *controlLayout = new QVBoxLayout;
controlLayout->addWidget(new QLabel(tr("Partition")));
+#ifdef HAS_INSTALL_ENV
controlLayout->addWidget(partList);
+#else /* !HAS_INSTALL_ENV */
+ controlLayout->addWidget(partInput);
+#endif /* HAS_INSTALL_ENV */
controlLayout->addWidget(new QLabel(tr("will be mounted on")));
controlLayout->addWidget(pathInput);
@@ -87,14 +92,22 @@
MountDialog::MountDialog(QStringList skipParts, QStringList skipMounts,
}
QString MountDialog::partition() const {
+#ifdef HAS_INSTALL_ENV
assert(partList->currentItem() != nullptr);
return partList->currentItem()->text();
+#else /* !HAS_INSTALL_ENV */
+ return partInput->text();
+#endif /* HAS_INSTALL_ENV */
}
void MountDialog::setPartition(const QString &part) {
+#ifdef HAS_INSTALL_ENV
QList<QListWidgetItem *> candidate = partList->findItems(part, Qt::MatchExactly);
if(candidate.empty()) return;
partList->setCurrentItem(candidate.at(0));
+#else /* !HAS_INSTALL_ENV */
+ partInput->setText(part);
+#endif /* HAS_INSTALL_ENV */
}
QString MountDialog::mountPoint() const {
This diff is collapsed.
Click to expand it.
Preview
0%
Loading
Try again
or
attach a new file
.
Cancel
You are about to add
0
people
to the discussion. Proceed with caution.
Finish editing this message first!
Save comment
Cancel
Please
register
or
sign in
to comment