Skip to content
GitLab
Explore
Sign in
Register
Primary navigation
Search or go to…
Project
Adélie Package Tree
Manage
Activity
Members
Labels
Plan
Issues
Issue boards
Milestones
Wiki
Code
Merge requests
Repository
Branches
Commits
Tags
Repository graph
Compare revisions
Build
Pipelines
Jobs
Pipeline schedules
Artifacts
Help
Help
Support
GitLab documentation
Compare GitLab plans
Community forum
Contribute to GitLab
Provide feedback
Keyboard shortcuts
?
Snippets
Groups
Projects
Show more breadcrumbs
Adélie Linux
Adélie Package Tree
Commits
3a5cecce
Commit
3a5cecce
authored
2 years ago
by
Zach van Rijn
Browse files
Options
Downloads
Patches
Plain Diff
system/icu: bump { 70.1 --> 71.1 }.
parent
40230937
No related branches found
Branches containing commit
No related tags found
Tags containing commit
1 merge request
!651
Draft: Upgrade to MATE 1.26
Changes
2
Hide whitespace changes
Inline
Side-by-side
Showing
2 changed files
system/icu/APKBUILD
+3
-5
3 additions, 5 deletions
system/icu/APKBUILD
system/icu/tests.patch
+0
-41
0 additions, 41 deletions
system/icu/tests.patch
with
3 additions
and
46 deletions
system/icu/APKBUILD
+
3
−
5
View file @
3a5cecce
# Contributor: Sergey Lukin <sergej.lukin@gmail.com>
# Maintainer: A. Wilcox <awilfox@adelielinux.org>
pkgname
=
icu
pkgver
=
7
0
.1
pkgver
=
7
1
.1
# convert x.y.z to x_y_z
_ver
=
$(
printf
'%s'
"
$pkgver
"
|
tr
.
_
)
...
...
@@ -17,7 +17,6 @@ makedepends=""
subpackages
=
"
$pkgname
-static
$pkgname
-dev
$pkgname
-doc
$pkgname
-libs"
source
=
"https://github.com/unicode-org/icu/releases/download/release-
$(
printf
'%s'
"
$pkgver
"
|
tr
.
-
)
/
${
pkgname
}
4c-
$_ver
-src.tgz
icu-60.2-always-use-utf8.patch
tests.patch
"
# secfixes:
...
...
@@ -76,6 +75,5 @@ static() {
mv
"
$pkgdir
"
/usr/lib/
*
.a
"
$subpkgdir
"
/usr/lib/
}
sha512sums
=
"0b26ae7207155cb65a8fdb25f7b2fa4431e74b12bccbed0884a17feaae3c96833d12451064dd152197fd6ea5fd3adfd95594284a463e66c82e0d860f645880c9 icu4c-70_1-src.tgz
f86c62422f38f6485c58d4766e629bab69e4b0e00fa910854e40e7db1ace299152eaefa99ae2fbab7465e65d3156cbea7124612defa60680db58ab5c34d6262f icu-60.2-always-use-utf8.patch
9f5796fac698803e18556340322c020caa32308d93b94bda3871ceebc0cecb7fa167dc4548fed4060dab8891f3f7a47d4dd422c708751cada35a36874e255fd6 tests.patch"
sha512sums
=
"1fd2a20aef48369d1f06e2bb74584877b8ad0eb529320b976264ec2db87420bae242715795f372dbc513ea80047bc49077a064e78205cd5e8b33d746fd2a2912 icu4c-71_1-src.tgz
f86c62422f38f6485c58d4766e629bab69e4b0e00fa910854e40e7db1ace299152eaefa99ae2fbab7465e65d3156cbea7124612defa60680db58ab5c34d6262f icu-60.2-always-use-utf8.patch"
This diff is collapsed.
Click to expand it.
system/icu/tests.patch
deleted
100644 → 0
+
0
−
41
View file @
40230937
Upstream report: https://unicode-org.atlassian.net/browse/ICU-21793
From 1b84ce27b41067e8f913da074917a1f6f9831fb9 Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?J=C3=A9r=C3=A9my=20Lal?= <kapouer@melix.org>
Date: Wed, 3 Nov 2021 02:31:18 +0100
Subject: [PATCH] ICU-21793 Fix ucptrietest golden diff
---
icu4c/source/tools/toolutil/toolutil.cpp | 13 +++++++------
1 file changed, 7 insertions(+), 6 deletions(-)
diff --git a/icu4c/source/tools/toolutil/toolutil.cpp b/icu4c/source/tools/toolutil/toolutil.cpp
index 1fc68aa69c8..a9dc37377a8 100644
--- a/tools/toolutil/toolutil.cpp
+++ b/tools/toolutil/toolutil.cpp
@@ -228,18 +228,19 @@
uprv_compareGoldenFiles(
std::ifstream ifs(goldenFilePath, std::ifstream::in);
int32_t pos = 0;
char c;
- while ((c = ifs.get()) != std::char_traits<char>::eof() && pos < bufferLen) {
+ while (ifs.get(c) && pos < bufferLen) {
if (c != buffer[pos]) {
// Files differ at this position
- return pos;
+ break;
}
pos++;
}
- if (pos < bufferLen || c != std::char_traits<char>::eof()) {
- // Files are different lengths
- return pos;
+ if (pos == bufferLen && ifs.eof()) {
+ // Files are same lengths
+ pos = -1;
}
- return -1;
+ ifs.close();
+ return pos;
}
/*U_CAPI UDate U_EXPORT2
This diff is collapsed.
Click to expand it.
Preview
0%
Loading
Try again
or
attach a new file
.
Cancel
You are about to add
0
people
to the discussion. Proceed with caution.
Finish editing this message first!
Save comment
Cancel
Please
register
or
sign in
to comment