Skip to content
GitLab
Explore
Sign in
Register
Primary navigation
Search or go to…
Project
Adélie Package Tree
Manage
Activity
Members
Labels
Plan
Issues
Issue boards
Milestones
Wiki
Code
Merge requests
Repository
Branches
Commits
Tags
Repository graph
Compare revisions
Build
Pipelines
Jobs
Pipeline schedules
Artifacts
Help
Help
Support
GitLab documentation
Compare GitLab plans
Community forum
Contribute to GitLab
Provide feedback
Keyboard shortcuts
?
Snippets
Groups
Projects
Show more breadcrumbs
Adélie Linux
Adélie Package Tree
Commits
2da8d116
Verified
Commit
2da8d116
authored
5 years ago
by
Anna Wilcox
Browse files
Options
Downloads
Patches
Plain Diff
user/vte: fix compatibility with Vala 0.43+
parent
e7e7003e
No related branches found
Branches containing commit
No related tags found
Tags containing commit
No related merge requests found
Changes
2
Hide whitespace changes
Inline
Side-by-side
Showing
2 changed files
user/vte/APKBUILD
+6
-6
6 additions, 6 deletions
user/vte/APKBUILD
user/vte/vala.patch
+29
-0
29 additions, 0 deletions
user/vte/vala.patch
with
35 additions
and
6 deletions
user/vte/APKBUILD
+
6
−
6
View file @
2da8d116
...
...
@@ -2,7 +2,7 @@
# Maintainer: Kiyoshi Aman <kiyoshi.aman+adelie@gmail.com>
pkgname
=
vte
pkgver
=
0.54.3
pkgrel
=
0
pkgrel
=
1
pkgdesc
=
"Virtual terminal emulator library for Gnome"
url
=
"https://www.gnome.org"
arch
=
"all"
...
...
@@ -11,10 +11,11 @@ makedepends="intltool gtk+3.0-dev gnutls-dev zlib-dev pcre2-dev
gobject-introspection-dev vala vala-dev libxml2-utils"
subpackages
=
"
$pkgname
-dev
$pkgname
-doc
$pkgname
-lang"
source
=
"https://download.gnome.org/sources/vte/0.54/vte-
$pkgver
.tar.xz
exitcode.patch"
exitcode.patch
vala.patch
"
build
()
{
cd
"
$builddir
"
./configure
\
--build
=
$CBUILD
\
--host
=
$CHOST
\
...
...
@@ -26,14 +27,13 @@ build() {
}
check
()
{
cd
"
$builddir
"
make check
}
package
()
{
cd
"
$builddir
"
make
DESTDIR
=
"
$pkgdir
"
install
}
sha512sums
=
"dd7d2ac361ed9ac0550599bb3164a3bd6ba95535275c9b559c81ce0af1bbf4b3d150a7489f987b2e626b32d4a8adc82d1ff78e8c8640e5b1c036fe4076c5d8ce vte-0.54.3.tar.xz
4987254439a136f66a7b7be1300f5efbf85db74bdb64fdd8d0c9a555173a172b4fd519174f932e73d58a2618ef37273e82fe681bb129891f2792a414025f6c61 exitcode.patch"
4987254439a136f66a7b7be1300f5efbf85db74bdb64fdd8d0c9a555173a172b4fd519174f932e73d58a2618ef37273e82fe681bb129891f2792a414025f6c61 exitcode.patch
6f699507326dcef82ab2eb1b94eb0a21255e90053d27db24c38e0dd1ec389ed7710b8032b4c12374448b59ff5b73852bbdd5ce0f5e5cdd4c84be290c7203aafc vala.patch"
This diff is collapsed.
Click to expand it.
user/vte/vala.patch
0 → 100644
+
29
−
0
View file @
2da8d116
From 53690d5cee51bdb7c3f7680d3c22b316b1086f2c Mon Sep 17 00:00:00 2001
From: Rico Tzschichholz <ricotz@ubuntu.com>
Date: Sat, 1 Dec 2018 19:04:59 +0100
Subject: [PATCH] vala: Fix build with vala 0.43+ git master due to empty
struct definition
This should get a proper refactoring as the FIXME suggests.
See https://gitlab.gnome.org/GNOME/vte/issues/76
---
bindings/vala/app.vala | 2 ++
1 file changed, 2 insertions(+)
diff --git a/bindings/vala/app.vala b/bindings/vala/app.vala
index 8663d63c..a534e76b 100644
--- a/bindings/vala/app.vala
+++ b/bindings/vala/app.vala
@@ -819,6 +819,8 @@
class App : Gtk.Application
public struct Options
{
+ //FIXME Merge this struct into App class
+ public int dummy;
public static bool audible = false;
public static string? command = null;
private static string? cjk_ambiguous_width_string = null;
--
2.18.1
This diff is collapsed.
Click to expand it.
Preview
0%
Loading
Try again
or
attach a new file
.
Cancel
You are about to add
0
people
to the discussion. Proceed with caution.
Finish editing this message first!
Save comment
Cancel
Please
register
or
sign in
to comment