Skip to content
GitLab
Explore
Sign in
Register
Primary navigation
Search or go to…
Project
Adélie Package Tree
Manage
Activity
Members
Labels
Plan
Issues
Issue boards
Milestones
Wiki
Code
Merge requests
Repository
Branches
Commits
Tags
Repository graph
Compare revisions
Build
Pipelines
Jobs
Pipeline schedules
Artifacts
Help
Help
Support
GitLab documentation
Compare GitLab plans
Community forum
Contribute to GitLab
Provide feedback
Keyboard shortcuts
?
Snippets
Groups
Projects
Show more breadcrumbs
Adélie Linux
Adélie Package Tree
Commits
2ca11ad6
Verified
Commit
2ca11ad6
authored
5 years ago
by
Anna Wilcox
Browse files
Options
Downloads
Patches
Plain Diff
user/xorg-gtest: remove atrocious hack so arm64 builds
parent
2aef9276
No related branches found
Branches containing commit
No related tags found
Tags containing commit
No related merge requests found
Changes
2
Hide whitespace changes
Inline
Side-by-side
Showing
2 changed files
user/xorg-gtest/APKBUILD
+5
-2
5 additions, 2 deletions
user/xorg-gtest/APKBUILD
user/xorg-gtest/remove-ridiculous-va_list-hacks.patch
+24
-0
24 additions, 0 deletions
user/xorg-gtest/remove-ridiculous-va_list-hacks.patch
with
29 additions
and
2 deletions
user/xorg-gtest/APKBUILD
+
5
−
2
View file @
2ca11ad6
...
@@ -11,7 +11,9 @@ license="MIT AND BSD-3-Clause"
...
@@ -11,7 +11,9 @@ license="MIT AND BSD-3-Clause"
depends
=
""
depends
=
""
makedepends
=
"libx11-dev libxi-dev util-macros xorg-server-dev xf86-video-dummy"
makedepends
=
"libx11-dev libxi-dev util-macros xorg-server-dev xf86-video-dummy"
subpackages
=
"
$pkgname
-dev"
subpackages
=
"
$pkgname
-dev"
source
=
"https://gitlab.freedesktop.org/xorg/test/xorg-gtest/-/archive/xorg-gtest-
$pkgver
/xorg-gtest-xorg-gtest-
$pkgver
.tar.bz2"
source
=
"https://gitlab.freedesktop.org/xorg/test/xorg-gtest/-/archive/xorg-gtest-
$pkgver
/xorg-gtest-xorg-gtest-
$pkgver
.tar.bz2
remove-ridiculous-va_list-hacks.patch
"
builddir
=
"
$srcdir
"
/
$pkgname
-
$pkgname
-
$pkgver
builddir
=
"
$srcdir
"
/
$pkgname
-
$pkgname
-
$pkgver
prepare
()
{
prepare
()
{
...
@@ -45,4 +47,5 @@ package() {
...
@@ -45,4 +47,5 @@ package() {
done
done
}
}
sha512sums
=
"100746225dd6b24f030893da7b960c2f2562fa9f5d02ee7fca3eb99c40e3ae17d408d5e3c4e99e05e3767984d48648d5a42473a9922d699cf1281290af1eb86c xorg-gtest-xorg-gtest-0.7.1.tar.bz2"
sha512sums
=
"100746225dd6b24f030893da7b960c2f2562fa9f5d02ee7fca3eb99c40e3ae17d408d5e3c4e99e05e3767984d48648d5a42473a9922d699cf1281290af1eb86c xorg-gtest-xorg-gtest-0.7.1.tar.bz2
14055ccca54d083d231084acda63b0769946d1d2d8243752842c1043db6638ac3e581021bb61e6e2b97566b075ed345a2949646886281e58a1e3679d949d2f34 remove-ridiculous-va_list-hacks.patch"
This diff is collapsed.
Click to expand it.
user/xorg-gtest/remove-ridiculous-va_list-hacks.patch
0 → 100644
+
24
−
0
View file @
2ca11ad6
--- xorg-gtest-xorg-gtest-0.7.1/src/process.cpp.old 2013-02-24 22:15:08.000000000 +0000
+++ xorg-gtest-xorg-gtest-0.7.1/src/process.cpp 2019-04-09 16:12:31.822094989 +0000
@@ -126,15 +126,12 @@
void xorg::testing::Process::Start(const std::string& program, va_list args) {
std::vector<std::string> argv;
-
- if (args) {
- char *arg;
- do {
- arg = va_arg(args, char*);
- if (arg)
- argv.push_back(std::string(arg));
- } while (arg);
- }
+ char *arg;
+ do {
+ arg = va_arg(args, char*);
+ if (arg)
+ argv.push_back(std::string(arg));
+ } while (arg);
Start(program, argv);
}
This diff is collapsed.
Click to expand it.
Preview
0%
Loading
Try again
or
attach a new file
.
Cancel
You are about to add
0
people
to the discussion. Proceed with caution.
Finish editing this message first!
Save comment
Cancel
Please
register
or
sign in
to comment