Skip to content
GitLab
Explore
Sign in
Register
Primary navigation
Search or go to…
Project
Adélie Package Tree
Manage
Activity
Members
Labels
Plan
Issues
Issue boards
Milestones
Wiki
Code
Merge requests
Repository
Branches
Commits
Tags
Repository graph
Compare revisions
Build
Pipelines
Jobs
Pipeline schedules
Artifacts
Help
Help
Support
GitLab documentation
Compare GitLab plans
Community forum
Contribute to GitLab
Provide feedback
Keyboard shortcuts
?
Snippets
Groups
Projects
Show more breadcrumbs
Adélie Linux
Adélie Package Tree
Commits
17503d43
Verified
Commit
17503d43
authored
7 years ago
by
Anna Wilcox
Browse files
Options
Downloads
Patches
Plain Diff
user/kcalcore: new package
parent
e8084135
No related branches found
Branches containing commit
No related tags found
Tags containing commit
No related merge requests found
Changes
2
Hide whitespace changes
Inline
Side-by-side
Showing
2 changed files
user/kcalcore/APKBUILD
+47
-0
47 additions, 0 deletions
user/kcalcore/APKBUILD
user/kcalcore/posix-header.patch
+37
-0
37 additions, 0 deletions
user/kcalcore/posix-header.patch
with
84 additions
and
0 deletions
user/kcalcore/APKBUILD
0 → 100644
+
47
−
0
View file @
17503d43
# Contributor: A. Wilcox <awilfox@adelielinux.org>
# Maintainer: A. Wilcox <awilfox@adelielinux.org>
pkgname
=
kcalcore
pkgver
=
17.08.1
pkgrel
=
0
pkgdesc
=
"Library for managing a calendar of events"
url
=
"https://www.kde.org/"
arch
=
"all"
license
=
"LGPL-2.0"
depends
=
""
depends_dev
=
"qt5-qtbase-dev kconfig-dev kdelibs4support-dev libical-dev"
makedepends
=
"
$depends_dev
cmake extra-cmake-modules bison"
checkdepends
=
"tzdata"
install
=
""
subpackages
=
"
$pkgname
-dev"
source
=
"http://download.kde.org/stable/applications/
$pkgver
/src/kcalcore-
$pkgver
.tar.xz
posix-header.patch"
builddir
=
"
$srcdir
/kcalcore-
$pkgver
"
build
()
{
cd
"
$builddir
"
if
[
"
$CBUILD
"
!=
"
$CHOST
"
]
;
then
CMAKE_CROSSOPTS
=
"-DCMAKE_SYSTEM_NAME=Linux -DCMAKE_HOST_SYSTEM_NAME=Linux"
fi
cmake
\
-DCMAKE_INSTALL_PREFIX
=
/usr
\
-DCMAKE_INSTALL_LIBDIR
=
lib
\
-DBUILD_SHARED_LIBS
=
True
\
-DCMAKE_BUILD_TYPE
=
RelWithDebugInfo
\
-DCMAKE_CXX_FLAGS
=
"
$CXXFLAGS
"
\
-DCMAKE_C_FLAGS
=
"
$CFLAGS
"
\
${
CMAKE_CROSSOPTS
}
make
}
check
()
{
cd
"
$builddir
"
CTEST_OUTPUT_ON_FAILURE
=
TRUE ctest
-E
RecursOn-RFC2445_RRULETest39.ics
}
package
()
{
cd
"
$builddir
"
make
DESTDIR
=
"
$pkgdir
"
install
}
sha512sums
=
"e4602de6a2482b5c6f54dc5247638e0d440813dd964582b42e4c3e2d9865370ad82e24539e01db3c70f24649d5c4116407aabb2b1fab5bb954d95cf8b867c834 kcalcore-17.08.1.tar.xz
d911c2a03b1db1f9f3b19e7087ae5cbee59ced24ded3b43f2d3286651d13e5f531d171cf7dc6c26906116d4b51a79f2801828956fa1f4e7094fa2f53fe2b888f posix-header.patch"
This diff is collapsed.
Click to expand it.
user/kcalcore/posix-header.patch
0 → 100644
+
37
−
0
View file @
17503d43
From b8a362ea78d945e54155b2538dcc1df8dd64d533 Mon Sep 17 00:00:00 2001
From: "A. Wilcox" <AWilcox@Wilcox-Tech.com>
Date: Wed, 11 Oct 2017 20:51:27 -0500
Subject: [PATCH] versit: include strings.h for strcasecmp
---
src/versit/vcc.y | 1 +
src/versit/vobject.c | 1 +
2 files changed, 2 insertions(+)
diff --git a/src/versit/vcc.y b/src/versit/vcc.y
index b9fbb0f..3e68795 100644
--- a/src/versit/vcc.y
+++ b/src/versit/vcc.y
@@ -99,6 +99,7 @@
DFARS 252.227-7013 or 48 CFR 52.227-19, as applicable.
#endif
#include <string.h>
+#include <strings.h>
#include <stdio.h>
#include <stdlib.h>
#include <ctype.h>
diff --git a/src/versit/vobject.c b/src/versit/vobject.c
index db13f9e..a57c417 100644
--- a/src/versit/vobject.c
+++ b/src/versit/vobject.c
@@ -46,6 +46,7 @@
DFARS 252.227-7013 or 48 CFR 52.227-19, as applicable.
#include "vobject.h"
#include <string.h>
+#include <strings.h>
#include <stdio.h>
#define NAME_OF(o) o->id
--
2.10.0
This diff is collapsed.
Click to expand it.
Preview
0%
Loading
Try again
or
attach a new file
.
Cancel
You are about to add
0
people
to the discussion. Proceed with caution.
Finish editing this message first!
Save comment
Cancel
Please
register
or
sign in
to comment