Skip to content
GitLab
Explore
Sign in
Register
Primary navigation
Search or go to…
Project
Adélie Package Tree
Manage
Activity
Members
Labels
Plan
Issues
Issue boards
Milestones
Code
Merge requests
Repository
Branches
Commits
Tags
Repository graph
Compare revisions
Build
Pipelines
Jobs
Pipeline schedules
Artifacts
Deploy
Releases
Package Registry
Model registry
Operate
Terraform modules
Analyze
Model experiments
Help
Help
Support
GitLab documentation
Compare GitLab plans
Community forum
Contribute to GitLab
Provide feedback
Keyboard shortcuts
?
Snippets
Groups
Projects
Show more breadcrumbs
Ermine
Adélie Package Tree
Commits
471f8326
Verified
Commit
471f8326
authored
7 years ago
by
Anna Wilcox
Browse files
Options
Downloads
Patches
Plain Diff
system/abuild: add our functions patch
parent
a59d41ab
No related branches found
Branches containing commit
No related tags found
Tags containing commit
No related merge requests found
Changes
2
Hide whitespace changes
Inline
Side-by-side
Showing
2 changed files
system/abuild/APKBUILD
+3
-2
3 additions, 2 deletions
system/abuild/APKBUILD
system/abuild/adelie-customisations.patch
+56
-0
56 additions, 0 deletions
system/abuild/adelie-customisations.patch
with
59 additions
and
2 deletions
system/abuild/APKBUILD
+
3
−
2
View file @
471f8326
...
@@ -2,11 +2,11 @@
...
@@ -2,11 +2,11 @@
pkgname
=
abuild
pkgname
=
abuild
pkgver
=
3.1.0
pkgver
=
3.1.0
_ver
=
${
pkgver
%_git*
}
_ver
=
${
pkgver
%_git*
}
pkgrel
=
1
pkgrel
=
2
pkgdesc
=
"Script to build Alpine Packages"
pkgdesc
=
"Script to build Alpine Packages"
url
=
"http://git.alpinelinux.org/cgit/abuild/"
url
=
"http://git.alpinelinux.org/cgit/abuild/"
arch
=
"all"
arch
=
"all"
license
=
"GPL
2
"
license
=
"GPL
-2.0
"
depends
=
"fakeroot sudo pax-utils openssl apk-tools>=2.0.7-r1 libc-utils
depends
=
"fakeroot sudo pax-utils openssl apk-tools>=2.0.7-r1 libc-utils
attr libarchive-tools pkgconf patch lzip"
attr libarchive-tools pkgconf patch lzip"
if
[
"
$CBUILD
"
=
"
$CHOST
"
]
;
then
if
[
"
$CBUILD
"
=
"
$CHOST
"
]
;
then
...
@@ -23,6 +23,7 @@ pkggroups="abuild"
...
@@ -23,6 +23,7 @@ pkggroups="abuild"
source
=
"http://dev.alpinelinux.org/archive/abuild/abuild-
$_ver
.tar.xz
source
=
"http://dev.alpinelinux.org/archive/abuild/abuild-
$_ver
.tar.xz
posix-abuild.patch
posix-abuild.patch
newapkbuild-cmake.patch
newapkbuild-cmake.patch
adelie-customisations.patch
0001-abuild-add-env-option-to-require-tests.patch
0001-abuild-add-env-option-to-require-tests.patch
"
"
builddir
=
"
$srcdir
/
$pkgname
-
$_ver
"
builddir
=
"
$srcdir
/
$pkgname
-
$_ver
"
...
...
This diff is collapsed.
Click to expand it.
system/abuild/adelie-customisations.patch
0 → 100644
+
56
−
0
View file @
471f8326
diff --git a/functions.sh.in b/functions.sh.in
index 4f2c023..a4de25c 100644
--- a/functions.sh.in
+++ b/functions.sh.in
@@ -5,20 +5,20 @@
program=${0##*/}
arch_to_hostspec() {
case "$1" in
- aarch64) echo "aarch64-alpine-linux-musl" ;;
- armel) echo "armv5-alpine-linux-musleabi" ;;
- armhf) echo "armv6-alpine-linux-muslgnueabihf" ;;
- armv7) echo "armv7-alpine-linux-musleabihf" ;;
- mips) echo "mips-alpine-linux-musl" ;;
- mips64) echo "mips64-alpine-linux-musl" ;;
- mipsel) echo "mipsel-alpine-linux-musl" ;;
- mips64el) echo "mips64el-alpine-linux-musl" ;;
- ppc) echo "powerpc-alpine-linux-musl" ;;
- ppc64) echo "powerpc64-alpine-linux-musl" ;;
- ppc64le) echo "powerpc64le-alpine-linux-musl" ;;
- s390x) echo "s390x-alpine-linux-musl" ;;
- x86) echo "i586-alpine-linux-musl" ;;
- x86_64) echo "x86_64-alpine-linux-musl" ;;
+ aarch64) echo "aarch64-foxkit-linux-musl" ;;
+ armel) echo "armv5-foxkit-linux-musleabi" ;;
+ armhf) echo "armv6-foxkit-linux-muslgnueabihf" ;;
+ armv7) echo "armv7-foxkit-linux-musleabihf" ;;
+ i528) echo "pentium4-foxkit-linux-musl" ;;
+ mips) echo "mips-foxkit-linux-musl" ;;
+ mips32) echo "mips32el-foxkit-linux-musl" ;;
+ pmmx) echo "i586-foxkit-linux-musl" ;;
+ ppc) echo "powerpc-foxkit-linux-musl" ;;
+ ppc64) echo "powerpc64-foxkit-linux-musl" ;;
+ ppc64le) echo "powerpc64le-foxkit-linux-musl" ;;
+ s390x) echo "s390x-foxkit-linux-musl" ;;
+ x86) echo "i486-foxkit-linux-musl" ;;
+ x86_64) echo "x86_64-foxkit-linux-musl" ;;
*) echo "unknown" ;;
esac
}
@@ -29,11 +29,11 @@
hostspec_to_arch() {
arm*-*-*-*eabi) echo "armel" ;;
armv6*-*-*-*eabihf) echo "armhf" ;;
armv7*-*-*-*eabihf) echo "armv7" ;;
- i[0-9]86-*-*-*) echo "x86" ;;
- mips-*-*-*) echo "mips" ;;
- mips64-*-*-*) echo "mips64" ;;
- mipsel-*-*-*) echo "mipsel" ;;
- mips64el-*-*-*) echo "mips64el" ;;
+ i486-*-*-*) echo "x86" ;;
+ i586-*-*-*) echo "pmmx" ;;
+ mips32*-*-*-*) echo "mips32" ;;
+ mips*-*-*-*) echo "mips" ;;
+ pentium4-*-*-*) echo "i528" ;;
powerpc-*-*-*) echo "ppc" ;;
powerpc64-*-*-*) echo "ppc64" ;;
powerpc64le-*-*-*) echo "ppc64le" ;;
This diff is collapsed.
Click to expand it.
Preview
0%
Loading
Try again
or
attach a new file
.
Cancel
You are about to add
0
people
to the discussion. Proceed with caution.
Finish editing this message first!
Save comment
Cancel
Please
register
or
sign in
to comment