Skip to content
GitLab
Explore
Sign in
Register
Primary navigation
Search or go to…
Project
Adélie Package Tree
Manage
Activity
Members
Labels
Plan
Issues
Issue boards
Milestones
Code
Merge requests
Repository
Branches
Commits
Tags
Repository graph
Compare revisions
Build
Pipelines
Jobs
Pipeline schedules
Artifacts
Deploy
Releases
Package Registry
Model registry
Operate
Terraform modules
Analyze
Model experiments
Help
Help
Support
GitLab documentation
Compare GitLab plans
Community forum
Contribute to GitLab
Provide feedback
Keyboard shortcuts
?
Snippets
Groups
Projects
Show more breadcrumbs
Ermine
Adélie Package Tree
Commits
45e41a50
Verified
Commit
45e41a50
authored
7 years ago
by
Anna Wilcox
Browse files
Options
Downloads
Patches
Plain Diff
user/kwallet: Fix endianness issue again
parent
eafdb47b
No related branches found
Branches containing commit
No related tags found
Tags containing commit
No related merge requests found
Changes
2
Hide whitespace changes
Inline
Side-by-side
Showing
2 changed files
user/kwallet/APKBUILD
+5
-3
5 additions, 3 deletions
user/kwallet/APKBUILD
user/kwallet/kwallet-5.22.0-blowfish-endianness.patch
+52
-0
52 additions, 0 deletions
user/kwallet/kwallet-5.22.0-blowfish-endianness.patch
with
57 additions
and
3 deletions
user/kwallet/APKBUILD
+
5
−
3
View file @
45e41a50
...
...
@@ -2,7 +2,7 @@
# Maintainer: A. Wilcox <awilfox@adelielinux.org>
pkgname
=
kwallet
pkgver
=
5.41.0
pkgrel
=
0
pkgrel
=
1
pkgdesc
=
"Secure storage system for passwords built atop Qt"
url
=
"https://www.kde.org/"
arch
=
"all"
...
...
@@ -14,7 +14,8 @@ depends_dev="qt5-qtbase-dev kcoreaddons-dev kconfig-dev kwindowsystem-dev
makedepends
=
"
$depends_dev
cmake extra-cmake-modules kdoctools-dev"
install
=
""
subpackages
=
"
$pkgname
-dev
$pkgname
-doc
$pkgname
-lang"
source
=
"http://download.kde.org/stable/frameworks/
${
pkgver
%.*
}
/kwallet-
$pkgver
.tar.xz"
source
=
"http://download.kde.org/stable/frameworks/
${
pkgver
%.*
}
/kwallet-
$pkgver
.tar.xz
kwallet-5.22.0-blowfish-endianness.patch"
builddir
=
"
$srcdir
/kwallet-
$pkgver
"
build
()
{
...
...
@@ -43,4 +44,5 @@ package() {
make
DESTDIR
=
"
$pkgdir
"
install
}
sha512sums
=
"572b1d145f7092ed8ca581a00ced425f6a6fa4d153853ec591bbe6f91c5851c8476356b907ea1808e93f881a9e24797e894e7621f5627eadaf086a7f92e89e74 kwallet-5.41.0.tar.xz"
sha512sums
=
"572b1d145f7092ed8ca581a00ced425f6a6fa4d153853ec591bbe6f91c5851c8476356b907ea1808e93f881a9e24797e894e7621f5627eadaf086a7f92e89e74 kwallet-5.41.0.tar.xz
edca12963a5db9db05b3b4d581c1b970569f3b96dc672422e561c189c9024b69710732281f054514ce3d596688a5b0ba512766f4fd768eea8e00a18dcfd59179 kwallet-5.22.0-blowfish-endianness.patch"
This diff is collapsed.
Click to expand it.
user/kwallet/kwallet-5.22.0-blowfish-endianness.patch
0 → 100644
+
52
−
0
View file @
45e41a50
--- kwallet-5.29.0/src/runtime/kwalletd/backend/blowfish.cc.old 2016-12-03 21:12:17.000000000 +0000
+++ kwallet-5.29.0/src/runtime/kwalletd/backend/blowfish.cc 2017-01-29 18:02:10.193293280 +0000
@@ -31,9 +31,7 @@
#include "blowfishtables.h"
-// DO NOT INCLUDE THIS. IT BREAKS KWALLET.
-// We need to live with -Wundef until someone really figures out the problem.
-//#include <QtCore/qglobal.h> // for Q_BYTE_ORDER and friends
+#include <QtGlobal> // for Q_BYTE_ORDER and friends
BlowFish::BlowFish()
{
@@ -135,7 +133,7 @@
return init();
}
-#if Q_BYTE_ORDER == Q_BIG_ENDIAN
+#if Q_BYTE_ORDER == Q_LITTLE_ENDIAN
#define shuffle(x) do { \
uint32_t r = x; \
x = (r & 0xff000000) >> 24; \
@@ -154,12 +152,12 @@
}
for (int i = 0; i < len / _blksz; i++) {
-#if Q_BYTE_ORDER == Q_BIG_ENDIAN
+#if Q_BYTE_ORDER == Q_LITTLE_ENDIAN
shuffle(*d);
shuffle(*(d + 1));
#endif
encipher(d, d + 1);
-#if Q_BYTE_ORDER == Q_BIG_ENDIAN
+#if Q_BYTE_ORDER == Q_LITTLE_ENDIAN
shuffle(*d);
shuffle(*(d + 1));
#endif
@@ -178,12 +176,12 @@
}
for (int i = 0; i < len / _blksz; i++) {
-#if Q_BYTE_ORDER == Q_BIG_ENDIAN
+#if Q_BYTE_ORDER == Q_LITTLE_ENDIAN
shuffle(*d);
shuffle(*(d + 1));
#endif
decipher(d, d + 1);
-#if Q_BYTE_ORDER == Q_BIG_ENDIAN
+#if Q_BYTE_ORDER == Q_LITTLE_ENDIAN
shuffle(*d);
shuffle(*(d + 1));
#endif
This diff is collapsed.
Click to expand it.
Preview
0%
Loading
Try again
or
attach a new file
.
Cancel
You are about to add
0
people
to the discussion. Proceed with caution.
Finish editing this message first!
Save comment
Cancel
Please
register
or
sign in
to comment