Skip to content
GitLab
Explore
Sign in
Register
Primary navigation
Search or go to…
Project
Adélie Package Tree
Manage
Activity
Members
Labels
Plan
Issues
Issue boards
Milestones
Code
Merge requests
Repository
Branches
Commits
Tags
Repository graph
Compare revisions
Snippets
Deploy
Releases
Model registry
Monitor
Incidents
Analyze
Value stream analytics
Contributor analytics
Repository analytics
Model experiments
Help
Help
Support
GitLab documentation
Compare GitLab plans
Community forum
Contribute to GitLab
Provide feedback
Keyboard shortcuts
?
Snippets
Groups
Projects
Show more breadcrumbs
CyberLeo
Adélie Package Tree
Commits
ebabf853
Verified
Commit
ebabf853
authored
5 years ago
by
Anna Wilcox
Browse files
Options
Downloads
Patches
Plain Diff
user/pulseaudio: fix building on new ALSA
parent
b7ffaa4d
No related branches found
Branches containing commit
No related tags found
Tags containing commit
No related merge requests found
Changes
2
Hide whitespace changes
Inline
Side-by-side
Showing
2 changed files
user/pulseaudio/APKBUILD
+3
-4
3 additions, 4 deletions
user/pulseaudio/APKBUILD
user/pulseaudio/alsa-include.patch
+45
-0
45 additions, 0 deletions
user/pulseaudio/alsa-include.patch
with
48 additions
and
4 deletions
user/pulseaudio/APKBUILD
+
3
−
4
View file @
ebabf853
...
...
@@ -3,7 +3,7 @@
# Maintainer: A. Wilcox <awilfox@adelielinux.org>
pkgname
=
pulseaudio
pkgver
=
12.2
pkgrel
=
4
pkgrel
=
5
pkgdesc
=
"A featureful, general-purpose sound server"
url
=
"https://www.freedesktop.org/wiki/Software/PulseAudio"
pkgusers
=
"pulse"
...
...
@@ -23,11 +23,11 @@ subpackages="$pkgname-dev $pkgname-doc $pkgname-libs $pkgname-bluez
source
=
"https://freedesktop.org/software/pulseaudio/releases/pulseaudio-
$pkgver
.tar.xz
$pkgname
.initd
$pkgname
.confd
alsa-include.patch
disable-flat-volume.patch
"
build
()
{
cd
"
$builddir
"
LIBS
=
"-lintl"
./configure
\
--build
=
$CBUILD
\
--host
=
$CHOST
\
...
...
@@ -50,12 +50,10 @@ build() {
}
check
()
{
cd
"
$builddir
"
make check
}
package
()
{
cd
"
$builddir
"
make
-j1
DESTDIR
=
"
$pkgdir
"
install
}
...
...
@@ -134,4 +132,5 @@ zshcomp() {
sha512sums
=
"877754c1838b3cb042dbc18a5f1cc3cf313ffcaee7a64703330406d1f86279c34f1107634ac3083b158365e6757fbacf5ec406bc3c5788d291de67b77a561a4e pulseaudio-12.2.tar.xz
34fe54ece5df60ce63a7955cd828a2716670fef71f40960698ae5518fdaf9cd599f4d8f8852e2c88d715600a9ad06a38984415e5eb320071012e5eb6e5c1b8b1 pulseaudio.initd
75b54581591519d63a3362b155c0f9b0501a60763ab394693a456c44d0216138cf3a40bdd0f7442028663bc045e9ffee286f8f8eaf2ee3bb17379b43615fee0e pulseaudio.confd
1549c495395ea0b9bf863f063be85c5847cdffc27b4e59e8d528aae5de29d1f2552dbae94f8c649fcab264e07ede330e584dcee46118b98ddf64c63cb1e8397e alsa-include.patch
dcb50f7c4fd86b0311ab050f7f0340dcf54379a685903951f22e24df6aee5486ee5e02f866c9e53dd55a54ba302658ad282114ce37f169d185855dc37dae0349 disable-flat-volume.patch"
This diff is collapsed.
Click to expand it.
user/pulseaudio/alsa-include.patch
0 → 100644
+
45
−
0
View file @
ebabf853
From b89d33bb182c42db5ad3987b0e91b7bf62f421e8 Mon Sep 17 00:00:00 2001
From: Takashi Iwai <tiwai@suse.de>
Date: Sun, 21 Apr 2019 11:59:30 +0200
Subject: [PATCH] alsa: Fix inclusion of use-case.h
The recent change in ALSA upstream stripped -I$include/alsa path from
pkgconfig. We already fixed for this change in some places but still
the code for UCM was overlooked, and this resulted in the unresolved
symbols in alsa card module. Fix them as well.
Signed-off-by: Takashi Iwai <tiwai@suse.de>
---
configure.ac | 2 +-
src/modules/alsa/alsa-ucm.h | 2 +-
2 files changed, 2 insertions(+), 2 deletions(-)
diff --git a/configure.ac b/configure.ac
index c004bd70d..b44ed1595 100644
--- a/configure.ac
+++ b/configure.ac
@@ -826,7 +826,7 @@
AS_IF([test "x$enable_alsa" = "xyes" && test "x$HAVE_ALSA" = "x0"],
AS_IF([test "x$HAVE_ALSA" = "x1"],
[
save_CPPFLAGS="$CPPFLAGS"; CPPFLAGS="$CPPFLAGS $ASOUNDLIB_CFLAGS"
- AC_CHECK_HEADERS([use-case.h], HAVE_ALSA_UCM=1, HAVE_ALSA_UCM=0)
+ AC_CHECK_HEADERS([alsa/use-case.h], HAVE_ALSA_UCM=1, HAVE_ALSA_UCM=0)
CPPFLAGS="$save_CPPFLAGS"
],
HAVE_ALSA_UCM=0)
diff --git a/src/modules/alsa/alsa-ucm.h b/src/modules/alsa/alsa-ucm.h
index 53abf3f90..c926f3cc3 100644
--- a/src/modules/alsa/alsa-ucm.h
+++ b/src/modules/alsa/alsa-ucm.h
@@ -23,7 +23,7 @@
***/
#ifdef HAVE_ALSA_UCM
-#include <use-case.h>
+#include <alsa/use-case.h>
#else
typedef void snd_use_case_mgr_t;
#endif
--
2.21.0
This diff is collapsed.
Click to expand it.
Preview
0%
Loading
Try again
or
attach a new file
.
Cancel
You are about to add
0
people
to the discussion. Proceed with caution.
Finish editing this message first!
Save comment
Cancel
Please
register
or
sign in
to comment